Slave health reboot/shutdown fails with "Expecting property name: line 4382 column 1 (char 128981)"

RESOLVED FIXED

Status

Release Engineering
General
--
major
RESOLVED FIXED
3 years ago
2 months ago

People

(Reporter: emorley, Assigned: pmoore)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
I've tried to reboot and also shutdown this machine:
https://secure.pub.build.mozilla.org/builddata/reports/slave_health/slave.html?name=talos-mtnlion-r5-029

However the actions failed with "Expecting property name: line 4382 column 1 (char 128981)".
(Assignee)

Comment 1

3 years ago
I am able to reproduce:

pmoore@Elisandra:~ $ ssh slaveapi1.build.mozilla.org 'cd /builds/slaveapi/prod; source bin/activate; python -c "import requests; all_devices=requests.get('\''http://hg.mozilla.org/build/tools/raw-file/default/buildfarm/mobile/devices.json'\'').json()"'
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/builds/slaveapi/prod/lib/python2.7/site-packages/requests/models.py", line 650, in json
    return json.loads(self.content.decode(encoding), **kwargs)
  File "/tools/python27/lib/python2.7/json/__init__.py", line 326, in loads
    return _default_decoder.decode(s)
  File "/tools/python27/lib/python2.7/json/decoder.py", line 366, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/tools/python27/lib/python2.7/json/decoder.py", line 382, in raw_decode
    obj, end = self.scan_once(s, idx)
ValueError: Expecting property name: line 4382 column 1 (char 128981)
pmoore@Elisandra:~ $
(Assignee)

Comment 2

3 years ago
Checking json file is valid...
(Assignee)

Comment 3

3 years ago
Looks like a syntax bug introduced in https://hg.mozilla.org/build/tools/rev/41f47fdb78d2
(Assignee)

Updated

3 years ago
See Also: → bug 1066823
(Reporter)

Comment 4

3 years ago
Trailing commas strike again :-)
Blocks: 1066823
See Also: bug 1066823
(Assignee)

Comment 5

3 years ago
Fixed: https://hg.mozilla.org/build/tools/rev/94d1b963f985

This should have immediate effect, will tail logs now... Things should start cleaning up, since the service queries http://hg.mozilla.org/build/tools/raw-file/default/buildfarm/mobile/devices.json directly...
(Reporter)

Comment 6

3 years ago
Thank you :-)

Confirmed working.
Assignee: nobody → pmoore
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(In reply to Ed Morley [:edmorley] from comment #4)
> Trailing commas strike again :-)

Ugh I thought we had jenkins checking that for us.... and I don't recall seeing any errors when that landed.
(Assignee)

Updated

3 years ago
See Also: → bug 1071746
(Assignee)

Comment 8

3 years ago
(In reply to Justin Wood (:Callek) from comment #7)
> (In reply to Ed Morley [:edmorley] from comment #4)
> > Trailing commas strike again :-)
> 
> Ugh I thought we had jenkins checking that for us.... and I don't recall
> seeing any errors when that landed.

I've created some unit tests in bug 1071746 for jenkins to run.
Component: Tools → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.