Status

Infrastructure & Operations
Infrastructure: IRC
RESOLVED DUPLICATE of bug 1125827
4 years ago
3 years ago

People

(Reporter: cyliang, Unassigned)

Tracking

Details

(Reporter)

Description

4 years ago
This is a placeholder bug for a IRC "log service" for public channels that was floated as an alternative to setting up a ZNC server.

Updated

4 years ago
Whiteboard: [kanban:https://kanbanize.com/ctrl_board/4/1336]
i've been running an irc logging service on irc.mozilla.org for 10 years - http://logs.glob.uno/
anything i can do to help here?

Updated

3 years ago
Whiteboard: [kanban:https://kanbanize.com/ctrl_board/4/1336] → [kanban:https://webops.kanbanize.com/ctrl_board/2/239]
(In reply to C. Liang [:cyliang] from comment #0)
> This is a placeholder bug for a IRC "log service" for public channels that
> was floated as an alternative to setting up a ZNC server.

Between IRCCloud (either public or hosted) and glob's logs, does this still need further action?
Not all channels are logged. For example, #git, #vcs, #build, #perf, #taskcluster, ... The problem wouldn't exist if logging was done at the server level.
Webops, if you still want to set up an alternative to glob's logs site, no objections here - but as no action is occurring at this time, and there's a request for server-based logging (as opposed to glob's logs), I'm going to steal this away from Webops and drop it into the IRC component, since any decision on whether or not to provide a logging service *in general*, rather than by-request-only for specific channels, needs to be made by the IRC admins rather than Webops.

Mike, note that for all of the channels you listed, you may (if you wish) use /msg ChanServ INFO #git (for example) to find out who the Owner of the channel is, and request their permission to invite glob's log bot in. I understand this does not satisfy "log all channels by default" (and requires you to take steps to make it happen for each channel), but it *is* available today.
Assignee: cliang → infra
Component: WebOps: Other → Infrastructure: IRC
QA Contact: nmaul → dparsons
Whiteboard: [kanban:https://webops.kanbanize.com/ctrl_board/2/239]

Updated

3 years ago
Whiteboard: [kanban:https://webops.kanbanize.com/ctrl_board/2/654]
i suspect this is a duplicate of bug 1125827.
Confirmed, thanks :glob. Also clearing private flag so they can see this bug.
Group: mozilla-employee-confidential
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1125827
(Reporter)

Updated

3 years ago
Whiteboard: [kanban:https://webops.kanbanize.com/ctrl_board/2/654]
You need to log in before you can comment on or make changes to this bug.