Firefox Marketplace app developers should be vouched on mozillians.org upon request

RESOLVED WONTFIX

Status

Community Building
Recognition
RESOLVED WONTFIX
4 years ago
2 years ago

People

(Reporter: toshazed, Assigned: gen)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140924084003

Steps to reproduce:

Few Firefox App Developers from Bangladesh (http://nutboltu.net) applied for vouch as to comply with the new voching system by Mozilla.


Actual results:

In reply to their account voching request app developers got the following email from the Mozilla Bangladesh authorized person.
===
[Mozillian] About being vouched

Hi there!
Thank you very much for your interest in Mozilla! We have received your request to be a vouched Mozillian. As it seems, you have only been creating Open Web apps but don't have any real contribution for Mozilla. We are sorry to let you know that developing apps for a certain marketplace like Firefox OS Marketplace, Google Play or Apple iTunes cannot be considered as a way of contribution. If you have any other sort of contribution as mentioned in here[1], do reply with the link of it. We be able to vouch you then.

Thank you for being with Mozilla, hope to see you as an active contributor!

[1] https://www.mozilla.org/en-US/contribute/

Cheers!
===


Expected results:

# Does Mozilla deny to credit it's Firefox OS App developers as contributors?
# Is it an official message to all the Firefox OS App developers?
(Reporter)

Comment 1

4 years ago
As a volunteer of mozilla I should be free to do for mozilla. I may translate, I may do queries, I may answer them. I should not be forced to join parties or anything such as the name of real activities.

Comment 2

4 years ago
Hi!  There is no application to be vouched. 

It sounds like the app developers are asking to be vouched on our get involved page, which is NOT the intended use. 

If that is the case, they are getting a response that is not meant for them. 

Can you please let me know where this "application to be vouched" is?
Flags: needinfo?(toshazed)
(Reporter)

Comment 3

4 years ago
This is the official vouch application/processing link by the Mozilla Bangladesh Community. https://docs.google.com/forms/d/1E3wNQXnERspnSK94GRJERN-g1JQGcIrtPTYO2zfgC0A/viewform
Flags: needinfo?(toshazed)

Comment 4

4 years ago
OK, now I understand the beginnings of the confusion here. 

The only way to actually be vouched is through Mozillians.org  That google form appears to be driven by the Bangladesh community, and I'm not sure what happens to information submitted into it.  

I've cc'd William Reynolds, the product owner for Mozillians.org into the bug so that he can help.  I'm concerned that there is a perception of that app contributions are not worth y of vouching.  I've included Amy Tsay, the Marketplace community manager on this bug as well, I'm sure she will have an opinion about if apps are a vouch worthy contribution. 

I personally do not agree that apps are not a significant contribution.  The vouching guidelines for Mozillians also do not specify that.   https://wiki.mozilla.org/Mozillians/Vouching

Comment 5

4 years ago
This is troubling indeed--app developers are a very important part of our community, and their contributions are considered to be very valuable. How can we better align expectations?

Comment 6

4 years ago
Hello,
I have faced the same problem. I have developed three apps for Firefox marketplace and they are approved.

https://marketplace.firefox.com/app/septic-tank-calculator?src=search

https://marketplace.firefox.com/app/fire-ball?src=search

https://marketplace.firefox.com/app/bmi-5?src=search

I have applied to be vouched on this link https://docs.google.com/forms/d/1E3wNQXnERspnSK94GRJERN-g1JQGcIrtPTYO2zfgC0A/viewform and I got an email reply like this below: 

===========================================================================

Subject: [Mozillian] About being vouched

Hi there!

Thank you very much for your interest in Mozilla! We have received your request to be a vouched Mozillian. As it seems, you have only been creating Open Web apps but don't have any real contribution for Mozilla. We are sorry to let you know that developing apps for a certain marketplace like Firefox OS Marketplace, Google Play or Apple iTunes cannot be considered as a way of contribution. If you have any other sort of contribution as mentioned in here[1], do reply with the link of it. We be able to vouch you then.

Thank you for being with Mozilla, hope to see you as an active contributor!

[1] https://www.mozilla.org/en-US/contribute/

Cheers!

Ratul Minhaz
Mozilla Representative
Mozilla Bangladesh
about.me/minhaz.ratul
==================================================================================

-- Thanks

Comment 7

4 years ago
Previous comment was my first ever comment/Bug Report. I have unconciously disclosed some personal information. I am really sorry for that.

Comment 8

4 years ago
 Thanks for bringing this to our attention!  We will reach out to Ratul Minhaz and see if we can help revise the Bangladesh community vouching guidelines he's setting.  This information was crucial to us understanding who to talk to to help you resolve the situation. 

We value our app developers very much and want you to be fully vouched members of the community.

Comment 9

4 years ago
Hello,
I have faced the same problem. I have developed three apps for Firefox marketplace and they are approved.

Comment 10

4 years ago
Would you mind listing your apps here? I would be happy to vouch for you.
Thanks everyone! I too would be happy to vouch for any Mozillian app developers - publishing an app is a significant contribution, as it is a commitment of time and coding effort that easily could be spent making a similar effort in a closed stack. 

Can we identify the source of this email response (from the "contribute" link) and amend it as soon as possible? It makes me VERY sad! 

Thanks so much for filing this bug - and for everyone who's shared this. Please note, I've also cc'ed Bill Walker, who's an engineering manager on the Apps team for Web Runtime & Partner engineering, and shares my concern. Note: I'm on the Tech evangelism team where we've worked w/awesome app developers/contributors.

Comment 13

4 years ago
Hi Havi!  

Gen Kanai and I are working to get this changed with the community members responsible for the google form.  We consider this very important to help resolve.   

I'll report back here when I have an update on how that is going. 

There are several reasons for the community to have this form, and to have requirements around it, and we look forward to working with them to help them understand the importance of app development and it's place in the larger Mozilla community.  We believe these contributions are very important and that they should be vouched for them.
Thanks Michelle for responding so quickly. If you and Gen are working on this with leads in the community, I know it will be resolved fairly and promptly. Please lmk if I can help.

Comment 15

4 years ago
I suggest not only changing the message, but also following up with applicants who received the first version of the message, to let them know they are not rejected after all. 

Not all app developers will want to be vouched (because they may or may not share Mozilla's goals). But any app developer who has an app in the Marketplace and wants to be vouched, should be vouched.
(In reply to Janet Swisher from comment #15)
> I suggest not only changing the message, but also following up with
> applicants who received the first version of the message, to let them know
> they are not rejected after all. 

Great suggestion. I agree we should contact any developers who completed the form in comment 3 and were rejected.

Michelle, perhaps you can discuss that with Ratul.

Delighted to see the discussion in this bug and fast response on the whole issue - let me know if you need any help on the mozillians.org side.
Summary: Are not the Firefox App developers are the real contributors to mozilla? → Firefox Marketplace app developers should be vouched on mozillians.org upon request
Assignee: nobody → mmarovich
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 17

4 years ago
toshazed, thank you for filing this bug. I was not aware of this spreadsheet.

I have counseled Ratul in the Mozilla Bangladesh community mailing list regarding the mis-evaluation of your contributions. FXOS app development is certainly worthy actions for vouching. 

https://groups.google.com/forum/#!topic/mozilla.community.bangladesh/S886EtUmsVA

I will review the other submissions and make sure that none others were mis-evaluated.

Thank you for your patience- I think this is just some confusion on behalf of those who have built a tool to help Bangladeshis get vouched.
Assignee: mmarovich → gen

Comment 18

4 years ago
Hello Everybody,
I have faced the same problem as I have developed two apps for Firefox marketplace and they are approved.

1. https://marketplace.firefox.com/app/love-calculator-1
2. https://marketplace.firefox.com/app/fire-circle-slide
(Reporter)

Comment 19

4 years ago
(In reply to Gen Kanai [:gen] from comment #17)

Dear Gen Kanai
I do not think anything missing or confusion here. The Mozilla Bangladesh Community Leaders just ignoring us, the developers and our contribution to Mozilla projects.

They even uttered that kind of ruthless mindset in public mailing list. I am very sad that these leaders are not listening to Mozilla or Mozillian's like Havi or you or any of us. Plz have the attachments as the proof of ignoring us/our contributions.

with regards
RING
(Reporter)

Comment 20

4 years ago
Created attachment 8496407 [details]
snapshot21.png [ignoring a very simple app developer as a contribution in the vouch application/tool]
(Reporter)

Comment 21

4 years ago
Created attachment 8496408 [details]
snapshot22.png[mozilla bangaldesh leader is saying in public that very simple app developer cannot be a PATHWAY CONTRIBUTOR]

Comment 22

4 years ago
Hello,
I have faced the same problem. I have developed two apps for Firefox marketplace and they are approved.
Here is my app link locations-
1. https://marketplace.firefox.com/app/unit-converter
2. https://marketplace.firefox.com/app/age-calculator-2

with regards
redwan

Comment 23

4 years ago
While it is true that I had misunderstood the new vouching process, this issue could have been handled easily by simply replying the email I sent to the app developers. As you can see, I tried to start a conversation on contributions rather than passing a final judgement. It was my fault that even after reading the wiki on vouching, I assumed apps development can not be considered as significant contributions. Of course, I never recieved any inquiry or email on this.

The reason why we are collecting contribution data needs a bit explanation. Back in the mid August when the new vouching system was introduced, Mozilla Bangladesh community was busy with l10n sprints, Maker Party, and most importantly, the launch of Firefox OS in Bangladesh. We wanted to vouch as many of contributors as we can before September 30, but we had very little time in our hands. Besides, there weren't many other options for us to vouch contributors of such a large community which grows everyday! There was absolutely no reason to believe we tried to override an existing system with our own application process. As a matter of fact, the form is entitled as "Mozillians profile vouch request", which implies that you would be vouched upon request. Some of many other communities have implemented this and it deemed to us to be fit with our circumstances. With less than one week time left, we wanted to gather as many Mozillian profiles as we can so that the Mozilla Summit 2013 attendees can vouch them before September 30.

I personally know Mr. Ring here and have worked together in a few events. He is also well known in our community as a FOSS activist. I don't know why someone from the same background as him would not contact with me to clear up the confusion and instead file this bug without letting me know. It's also not comprehensible to me why would an app developer who wants to get vouched consult with someone note even remotely related to the process, instead of replying to my email.

We are prone to do mistakes like this, we are only human. Specially me, as a relatively new Rep who is still learning ways of leadership. As a senior Mr. Ring could have contaced me directly to point out my fault. His submitting bug without any sort of communication is really hurtful in many ways.

I am extremely sorry that I couldn't percieve the new vouching process in time. I am fully responsible for any damage that might have occured because of it, but this is definitely not the best way to solve the problem.

Comment 24

4 years ago
Man makes mistakes. But this is not the way to solve. As this doc was created by our Bangladesh community he should talk with us first. This is not the proper way to solve any problem. I don't know if he actually communicate with anyone from MozillaBD. He introduces himself as a Mozillian but not a part of MozillaBD. It's truly sad...

Comment 25

4 years ago
We are Humans and we do mistake. As Ratul Minhaz was taking care of that form, he had done a mistake. But he never ended the path of discussion on his email. For any kind of concern, developers should consult with Ratul personally by replying his email. At least we have a mailing list where we can discuss on this issue. 

This is really a wrong approach from toshazed  or Mr. Ring . This is not a community approach.As a Mozillian, this approach not only hurts Ratul but also hurts me.
(Reporter)

Comment 26

4 years ago
(In reply to Ratul Minhaz from comment #23)
>
> I personally know Mr. Ring here and have worked together in a few events. He
> is also well known in our community as a FOSS activist. I don't know why
> someone from the same background as him would not contact with me to clear
> up the confusion and instead file this bug without letting me know. It's
> also not comprehensible to me why would an app developer who wants to get
> vouched consult with someone note even remotely related to the process,
> instead of replying to my email.

Being a Mozillian It is not just about personal relationship, It's all about community. And there was no confusion that you have confirmed me or a Mozillian who has become a Mozillian by following/motivate by me with your mail that "AS AN APP DEVELOPER OUR CONTRIBUTION WAS UNREAL".

And today what I have mentioned with the attachments proves that It was not just your fault. It proves that our Mozilla Bangladesh Community Leadership does not have the sense about CONTRIBUTION and they are even trying to set the PATHWAY of CONTRIBUTION, which does not comply with the guidelines set by Mozilla.

> 
> We are prone to do mistakes like this, we are only human. Specially me, as a
> relatively new Rep who is still learning ways of leadership. As a senior Mr.
> Ring could have contaced me directly to point out my fault. His submitting
> bug without any sort of communication is really hurtful in many ways.

You have not mailed to them yet, whom you have rejected by mis-evaluation. 

So still you have not understood how much disgraceful your mail was to a newbie/young developer. You have broken not only his/their heart with that sluggish mail but also made them and all of the app developer Mozillians from all over Bangladesh, dis-hearted for the next level communication. 

I entered in here this time as I felt that without my bug report these boys will never feel that where I bring them to Mozilla and make them involved in developing apps of Firefox Marketplace, may stand with them and support them to have their minimum graceful rights.

You are senior to them in this community and as a senior we all have to be careful on our communications with our juniors or new volunteers. We should not led any young ones to be broken mind with our words or works. We must cheer them up on their simple and very very very little contribution if we all wants to achieve the OPEN WEB and carry on.

This bug was not submitted for anything personal or to achieve any kind of personal benefit. It was for all of us.

> 
> I am extremely sorry that I couldn't percieve the new vouching process in
> time. I am fully responsible for any damage that might have occured because
> of it, but this is definitely not the best way to solve the problem.

As a Mozillian I have the rights to let the other Mozillian's know what is actually going on with me or anyone else I know and this is why bugzilla stands for. 

And please do not be sorry until we all are having the actual mindset of yours(Mozilla Bangladesh community leaders) for the newbie Mozilla marketplace app developers be loud and clear as your (Mr. Ratul) so called confused mail was. Let us have an public announcement with amendment in your form/tools and in the community mailing list you run on google.

Comment 27

4 years ago
Hi I'm Salman Rahman Desh from Mozilla Bangladesh Community. I'm a FSA, contributing in L10n, working with Firefox OS App development, trainer of Firefox OS launching in BD and Task force member of MDN. 
It's almost 10 months I contributing to Mozilla and very glad to be in such a family like Mozilla Bangladesh. In my past 10 months journey with Mozilla Bangladesh Community I felt and learned some awesome things like What is a family without having any blood connection and how Mozilla is doing this bonding whole over the world. And this is only why I never questioned myself Why I'm in Mozilla rather every time I proudly said to my sub-conscious mind that I'm a Mozillian and I'm damn proud of that. I saw how Mozilla Bangladesh works and how much passion they have to Grow Mozilla in Bangladesh. Mozilla Bangladesh Community doesn't neglect anyone's curiosity about Mozilla. If they do then I may not be get a chance to be proud-full member of this community. I'm over sure there is something fishy going out. The person who submitted this bug may contact with us through mailing list or our Mozilla Bangladesh Facebook group/page or from where he had gotten this vouching google form link. Moreover he didn't mention his contribution/App link.   
Mozilla Bangldesh Community planned to vouch eligible mozillian for the last one week. We also kept on our mind that we mustn't misuse the power of vouch. And also be conscious to vouch the right and the eligible person so that he/she may not misuse doing vouch others whom doing unstable or seasonal guest just for show-off. We care about Mozilla cause we love Mozilla. We are sorry for our did. Thank you. Regards.
(Reporter)

Comment 28

4 years ago
(In reply to Rabbi Hossain from comment #25)
> We are Humans and we do mistake. As Ratul Minhaz was taking care of that
> form, he had done a mistake. But he never ended the path of discussion on
> his email. For any kind of concern, developers should consult with Ratul
> personally by replying his email. At least we have a mailing list where we
> can discuss on this issue. 
> 
> This is really a wrong approach from toshazed  or Mr. Ring . This is not a
> community approach.As a Mozillian, this approach not only hurts Ratul but
> also hurts me.

Rabbi I found your Mozillian account already being vouched and both of them who vouched you declared your contribution as "AN GREAT APP DEVELOPER" with some other contributions also. So how it can hurt you what we have been poked with except the feelings in my words.

Don't You get the double standard in vouching process by Mozilla Bangladesh yet?

Comment 29

4 years ago
(In reply to toshazed from comment #28)

> Rabbi I found your Mozillian account already being vouched and both of them
> who vouched you declared your contribution as "AN GREAT APP DEVELOPER" with
> some other contributions also.
> Don't You get the double standard in vouching process by Mozilla Bangladesh
> yet?
Dear Ring, Don't judge my vouches with this issue. The guy who vouched me doesn't belong to any leadership and even not a part to this vouch request process maintained by Ratul. "SO, I DON'T FIND ANY KIND OF DOUBLE STANDARD MEANING HERE." 

Personally I don't like to show off or tell anyone about my contributions. While writing this comment I am also writing patch to fix a bug and no one knows about it. This is how I contribute in Mozilla. I also haven't request anyone to vouch me. It was their personal choice who vouched me. They mentioned me As App developer because, I am working on engaging developers around the community and attended many FxOS app training events as a trainer. Nothing else. Before your reminder about my vouch, I don't even know about my vouch status. So, I request you not to judge my vouch status with this issue. I don't care about my vouch status. What I care is, I am a Mozillian.

"SO, I DON'T FIND ANY KIND OF DOUBLE STANDARD MEANING HERE."

Comment 30

4 years ago
 I want my mozillian profile to be vouched. But the google form is not taking any responses.
Please someone vouched me or tell me the proper way to be vouched. My Firefox Apps are--

https://marketplace.firefox.com/app/fire-match
https://marketplace.firefox.com/app/foxypic
(Assignee)

Comment 31

4 years ago
Thank you all for your comments and your passion for Mozilla.

I do agree that toshazed has raised important concerns for the Bangladesh community to consider. One can be a contributor and community member to Mozilla or to a local community WITHOUT participating in offline events and WITHOUT personal connection to core community members. We should remember that the Mozilla Bangladesh community is larger than those who are active on the FB groups, the mailing lists, etc.

I do not believe there was malice intended with the mis-evaluation. Both Ratul and toshazed are contributors to Mozilla in their own way.

We at Mozilla also need to consider how to make vouching more clear and easier. WilliamR has already made some changes and perhaps others also need to be considered. There are lessons to be learned for us here too- so thank you for this discussion.

I would ask that we all refocus our attention back to the broader Firefox and Firefox OS user base in Bangladesh. We all have ways we can contribute to supporting those users, whether it is via app development, community development, localization, FXOS community marketing, etc.
(Reporter)

Comment 32

4 years ago
Thanks Gen for making it very clear to all of us that "One can be a CONTRIBUTOR AND COMMUNITY MEMBER to Mozilla or to a local community WITHOUT participating in OFFLINE events and WITHOUT personal connection to core community members." and "We should remember that the Mozilla Bangladesh community is LARGER than those who are active on the FB groups, the mailing lists, etc."

If you please guide Mr. Saiful Alam on vouching his account will be helpful guideline for all of us.

And I am Shazedur Rahim Joardar Ring from Bangladesh. You can call me Ring, it is my nickname. :)

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.