sched - need to get keep alive working in necko

VERIFIED FIXED in M14

Status

()

Core
Networking
P3
critical
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: chris hofmann, Assigned: ruslan)

Tracking

({perf})

Trunk
x86
Windows 95
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT-])

(Reporter)

Updated

19 years ago
Blocks: 10730

Updated

19 years ago
Target Milestone: M10

Description

19 years ago
I don't think we need this for m9, do we? It's more of a performance thing.

Updated

18 years ago
Blocks: 12833

Comment 1

18 years ago
*** Bug 2434 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M10 → M13

Comment 2

18 years ago
Bulk move of all Necko (to be deleted component) bugs to new Networking

component.

Comment 3

18 years ago
M14 => gagan
Assignee: rpotts → gagan
Status: ASSIGNED → NEW
Target Milestone: M13 → M14

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 4

18 years ago
*** Bug 14610 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Blocks: 23679

Updated

18 years ago
Keywords: beta1

Comment 5

18 years ago
pdt - what is the user impact?

Comment 6

18 years ago
Adding [NEED INFO] to Status Summary.
Whiteboard: [NEED INFO]

Comment 7

18 years ago
user impact is that the performance would be not as good as you'd get with 
keep-alive. 

Comment 8

18 years ago
this fix is critical for performance of browser across satellite-based networks.
Severity: normal → critical

Updated

18 years ago
Keywords: perf
Whiteboard: [NEED INFO] → [PDT-]

Updated

18 years ago
Blocks: 26637
(Assignee)

Comment 9

18 years ago
I'm reassigning this to myself since I'm working on it now. It's almost done 
and sitting on my box awaiting the tree to open. I'm still having trouble 
advertising HTTP/1.1 against www.microsoft.com, I'm looking into it.
Assignee: gagan → ruslan
Status: ASSIGNED → NEW
(Assignee)

Comment 10

18 years ago
Landed; network.http.version=1.1.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 11

18 years ago
qa -> tever
QA Contact: paulmac → tever

Updated

18 years ago
No longer blocks: 26637
(Assignee)

Comment 12

18 years ago
I'm going to put extensive changes into http-handler which will allow us to 
support pipelining eventually. Hold off your testing till then.

Comment 13

18 years ago
verified
Win95: 2000062609
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.