Closed Bug 1074006 Opened 5 years ago Closed 5 years ago

Get Thunderbird to launch with the new .app bundle structure

Categories

(Thunderbird :: General, defect)

All
macOS
defect
Not set

Tracking

(thunderbird34 fixed, thunderbird35 fixed)

RESOLVED FIXED
Tracking Status
thunderbird34 --- fixed
thunderbird35 --- fixed

People

(Reporter: rstrong, Assigned: jsbruner)

References

Details

Attachments

(2 files, 1 obsolete file)

Attached patch patch (obsolete) β€” β€” Splinter Review
I won't be able to drive this patch and land it.
Another patch for v2 signing
needinfoing myself so I don't miss this.
Flags: needinfo?(josiah)
Patch looked good, just a few minor things (which I corrected) and TB seems to be launching again! Thanks Robert!

https://hg.mozilla.org/comm-central/rev/86199339bfe8
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(josiah)
Resolution: --- → FIXED
Hmm, apparently you didn't set an HG User on that patch, so it landed with my name. Sorry about that, didn't mean to steal credit!
I'm perfectly fine with that and no worries whatsoever. Actually Stephen did the original work and I just ported over the changes.
Reopened because of Linux bustage. Looks simple enough: https://treeherder.mozilla.org/ui/logviewer.html#?job_id=307&repo=comm-central

I'll look at it in detail tonight.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to Josiah Bruner [:JosiahOne] from comment #7)
> Reopened because of Linux bustage. Looks simple enough:
> https://treeherder.mozilla.org/ui/logviewer.html#?job_id=307&repo=comm-
> central
> 
> I'll look at it in detail tonight.

In the new patch you could also include the code cleanup from Bug 1077282 into nsMailApp.cpp

-    nsCOMPtr<nsIFile> parent;
-    greDir->GetParent(getter_AddRefs(parent));
-    greDir = parent.forget();
-    greDir->AppendNative(NS_LITERAL_CSTRING(kOSXResourcesFolder));
+    greDir->SetNativeLeafName(NS_LITERAL_CSTRING(kOSXResourcesFolder));

https://hg.mozilla.org/mozilla-central/rev/9c87dcd65628
(In reply to Josiah Bruner [:JosiahOne] from comment #7)
> Reopened because of Linux bustage. Looks simple enough:
> https://treeherder.mozilla.org/ui/logviewer.html#?job_id=307&repo=comm-
> central
> 
> I'll look at it in detail tonight.

Robert missed this out (needed for Linux):
https://hg.mozilla.org/mozilla-central/rev/f438f50b8bb3#l2.19
> +#include <unistd.h>

You might need the makefile changes too.
Assignee: nobody → josiah
Status: REOPENED → ASSIGNED
Attached patch fixLaunching.patch β€” β€” Splinter Review
Now this doesn't break Linux. I'm carrying the review flags because Robert and myself have worked on this.
Attachment #8496633 - Attachment is obsolete: true
Attachment #8504271 - Flags: review+
https://hg.mozilla.org/comm-central/rev/817bad162ea9
Status: ASSIGNED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
(In reply to Josiah Bruner [:JosiahOne] from comment #11)
> https://hg.mozilla.org/comm-central/rev/817bad162ea9
You forgot about comment 8
Oh, yes. I'll write up a followup patch.
Attached patch Cleanup followup β€” β€” Splinter Review
Here's the cleanup portion.
Attachment #8504901 - Flags: review?(philip.chee)
Comment on attachment 8504271 [details] [diff] [review]
fixLaunching.patch

[Approval Request Comment]
Regression caused by (bug #): V2 Codesigning
User impact if declined: 
Testing completed (on c-c, etc.): On c-c
Risk to taking this patch (and alternatives if risky):
Attachment #8504271 - Flags: approval-comm-beta?
Attachment #8504271 - Flags: approval-comm-aurora?
Attachment #8504271 - Flags: approval-comm-beta?
Attachment #8504271 - Flags: approval-comm-beta+
Attachment #8504271 - Flags: approval-comm-aurora?
Attachment #8504271 - Flags: approval-comm-aurora+
Comment on attachment 8504901 [details] [diff] [review]
Cleanup followup

Looks good r=me
Attachment #8504901 - Flags: review?(philip.chee) → review+
You need to log in before you can comment on or make changes to this bug.