SeaMonkey's preprocessed channel-prefs.js file needs to be the same for each build

RESOLVED FIXED in seamonkey2.32

Status

SeaMonkey
Installer
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: rstrong, Unassigned)

Tracking

Trunk
seamonkey2.32
All
Mac OS X
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.31+ fixed, seamonkey2.32+ fixed)

Details

Attachments

(1 attachment)

Port of bug 1070863
Created attachment 8496721 [details]
patch

Without this every build's channel-pref.js is a little different and since we never update the channel-prefs.js file after it is added any changes will break the mac v2 signature since the updated signature would have been created with a slightly different channel-prefs.js.

Updated

3 years ago
Attachment #8496721 - Flags: review?(bugspam.Callek)

Comment 2

3 years ago
Comment on attachment 8496721 [details]
patch

> Heads up that Mac V2 signing also landed on Aurora today. We are still
> discussing whether it will be uplifted to esr31 since from what I know we
> won't be able to whitelist for the entire esr31 lifecycle but we are leaning
> towards not uplifting at this time.

[Approval Request Comment]
Regression caused by (bug #): 1047584
User impact if declined: ?
Testing completed (on m-c, etc.): Yes
Risk to taking this patch (and alternatives if risky): ?
String changes made by this patch: None
Attachment #8496721 - Flags: review?(bugzilla)
Attachment #8496721 - Flags: approval-comm-aurora?

Updated

3 years ago
Depends on: 1047584

Updated

3 years ago
Attachment #8496721 - Flags: review?(bugzilla)
Attachment #8496721 - Flags: review+
Attachment #8496721 - Flags: approval-comm-aurora?
Attachment #8496721 - Flags: approval-comm-aurora+

Comment 3

3 years ago
Pushed to comm-central
http://hg.mozilla.org/comm-central/rev/3b37a416b96b
Status: NEW → ASSIGNED
Whiteboard: [leave open for comm-aurora]
Target Milestone: --- → seamonkey2.32
Version: unspecified → Trunk

Updated

3 years ago
status-seamonkey2.32: --- → fixed

Comment 4

3 years ago
Pushed to comm-beta:
http://hg.mozilla.org/releases/comm-beta/rev/2f62c4401cef
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-seamonkey2.31: --- → fixed
tracking-seamonkey2.31: --- → +
tracking-seamonkey2.32: --- → +
Resolution: --- → FIXED
Whiteboard: [leave open for comm-aurora]

Updated

3 years ago
Attachment #8496721 - Flags: review?(bugspam.Callek)
You need to log in before you can comment on or make changes to this bug.