Closed Bug 1074241 Opened 5 years ago Closed 5 years ago

Forget the last selected job after clicking into empty space in the jobs list

Categories

(Tree Management :: Treeherder, defect, P1)

defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: RyanVM, Assigned: jfrench)

References

()

Details

Attachments

(1 file)

In the TBPL workflow, clicking away to dismiss the job details also forgets the last-selected job in addition to dismissing the panel. This is useful because it gives an easy to get back to the first failure - click away to dismiss and hit 'n'. Treeherder remembers the last-selected job, so as a result, hitting 'n' or 'p' uses that as the starting point.

Also, I believe this is the reason why I've observed on Try pushes that a job I've previously unselected goes from little to big as if selected again when the page refreshes data.
Blocks: 1059368
Priority: -- → P1
Summary: Treeherder remembers the last-selected job after dismissing the pinboard → Forget the last selected job after clicking into empty space in the jobs list
Tweaked summary to match the symptoms that are the regression from TBPL. I don't think we'd want to unselect the job if we just close the pinboard, since we may still be wanting to read the job details panel for that job.
I'll have a look at this one and see if I can match the requested behaviors.
Assignee: nobody → tojonmz
Status: NEW → ASSIGNED
I have a prototype working using some borrowed code from the clonejobs directive. I think I will need to actually implement it using a broadcast event of some kind.

But it is cool and matches all the requested behaviors. You can j/n after a clear and it will start back at the first failure, after an empty mouse-click, or an Esc to close the job panel. The same with k/p, it will loop around and start from the 'bottom' of the job list.
Commits pushed to master at https://github.com/mozilla/treeherder-ui

https://github.com/mozilla/treeherder-ui/commit/f1fd8268c8c9c4a23eee1ed532bae50c4e4132d3
Bug 1074241 - Reset the internal job model position on a job clear

https://github.com/mozilla/treeherder-ui/commit/9e659fca346a0a547fc47452c3d6150af5273d9d
Merge pull request #232 from tojonmz/reset-job-position

Bug 1074241 - Reset the internal job model position on a job clear
Attached file treeherder-ui-PR#232
Adding the PR for posterity since it's already merged. Reviewed by camd.
Verified fixed and working correctly on dev/stage.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Commits pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/cae22fedf7fe1acabe269fae392be8429be0b568
Bug 1074241 - Reset the internal job model position on a job clear

https://github.com/mozilla/treeherder/commit/ad60b22d2226e705efa1399c032bad40171563cd
Merge pull request #232 from tojonmz/reset-job-position

Bug 1074241 - Reset the internal job model position on a job clear
You need to log in before you can comment on or make changes to this bug.