Forward inline places signature file between header area and content of forwarded msg

RESOLVED WORKSFORME

Status

()

Core
Editor
P2
normal
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: lchiang, Assigned: kinmoz)

Tracking

Trunk
Future
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ADT3])

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
Forward inline places signature file between header area and content of
forwarded msg

I'm seeing this on a particular message which I received.  I tried to reproduce
this by copying the content of the mail message and pasting it to a new message,
but cannot reproduce it that way.  I will try to "clean up" the message and post
to this bug report.

Win32 2001-10-26-06 trunk Win32 build

Setup to have a signature file; html compose
1.  Select the message 
2.  Forward inline
3.  Notice that the signature file gets inserted between the header area of the
original message and the content of the original message that you are trying to
forward.

This doesn't happen to all messages.  Only to this particular one I have so far.
(Reporter)

Comment 1

16 years ago
Created attachment 55618 [details]
mail folder w/one msg in it
(Reporter)

Comment 2

16 years ago
I've attached the msg in a local folder.
Just save it to your local mail folder and select the folder/msg.  

Comment 3

16 years ago
Comm trunk build:  2001-10-26-06 win98.  I tried the message attached below and 
was able to see the problem.  The signature is in between the header and body 
both when you have starting reply below or above the quoted text.  
composed a few other emails did not have this problem of signature file placed 
in between header and body.  

Comment 4

16 years ago
I tried several messages and error occured in every message which contains
multipart/alternative plain text and html version.

Comment 5

16 years ago
I tried several messages and error occured in every message which contains
multipart/alternative plain text and html version.

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0.1
(Reporter)

Comment 6

16 years ago
I see this all the time. I'm surprised it's not reported more frequently.  The
drawback to this problem is that this bug will actually alter the text of the
forwarded message by inserting my sig file in the middle of the text which I'm
forwarding.   Normally on forwarded messages, most people don't comment in the
forwarded text and this bug requires that I read the forwarded text of each
message I sent on to check to make sure my sig file is not inserted in the middle.
Keywords: nsbeta1

Updated

16 years ago
Keywords: nsbeta1 → nsbeta1+
Priority: -- → P2

Comment 7

16 years ago
Here is a simple test:  
Send yourself an email with a plain text signature.  
Change your signature file and then click on the message you just sent to yourself.
Select the message you just received, select Forward button (shoud be defaulting
to Inline for this test).

Results: you see:
1.) ----Original Message-----, 
2.)then the outlined header, 
3.)then your newly selected signature, 
4.)then the body of the messge being forwarded with the signature of that
message at the bottom.  
Tabbing to the Body of the message places the cursor at the top of the messsage
window to begin your text (this is correct for my preference setting) So when
you send you have your comment, the header of the Forwarded message, your
signature and then the body of the forwarded message.  Certainly hard to
determine who's signature belongs with what text.  I was curious about how 4.7
did this.  In 4.7, only when forwarding inline, it doesn't include your
signature so the forwarded message looks like the above except for #3.
When trouble shooting this with Lisa we saw another scenario where the Link on
your signature gets separated from your signature during this type of forward
ane placed under the orignial message's signature.  
Confused!  Run through the steps mentioned in this comment and you will see the
problem.

Updated

16 years ago
Target Milestone: mozilla1.0.1 → mozilla1.0
Created attachment 72826 [details] [diff] [review]
Proposed fix, v1

nsIEditorShell::InsertSource not always correctly advance the insertion point,
I'll file a bug for that. Meanwhile, we can protect ourselve againts this
problem by forcing the isertion point to the end of the document after
inserting a block of data.

Updated

16 years ago
Whiteboard: have fix, waiting for reviews

Comment 9

16 years ago
Comment on attachment 72826 [details] [diff] [review]
Proposed fix, v1

r=varada; Looks good to me can you also include the editor bug in this so that
we can track it.
Attachment #72826 - Flags: review+

Updated

16 years ago
Whiteboard: have fix, waiting for reviews → [ADT3] have fix, waiting for reviews

Comment 10

16 years ago
Comment on attachment 72826 [details] [diff] [review]
Proposed fix, v1

sr=bienvenu
Attachment #72826 - Flags: superreview+

Comment 11

16 years ago
Comment on attachment 72826 [details] [diff] [review]
Proposed fix, v1

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #72826 - Flags: approval+
*** Bug 131113 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Whiteboard: [ADT3] have fix, waiting for reviews → [ADT3] have fix, ready to go
Fix checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
I filed bug 131854 for the editor problem.

Comment 15

16 years ago
Using build 20020322 and scenario in comment #7 this is fixed. I tested both
HTML and plain text send.  Verified
Status: RESOLVED → VERIFIED
(Reporter)

Comment 16

16 years ago
This is not fixed.  I still see this problem in the 2002-04-01 commercial trunk 
build.  I will see if I am able to include the email msg in this bug report.
(Reporter)

Comment 17

16 years ago
I don't want to include the mail msg contents in this bug report. JF - when will 
you be in the office?  I can show/send to you.
I'll come Thursday.
(Reporter)

Comment 19

16 years ago
I just saw this bug again on a different mail msg that I'm forwarding.  JF - 
come by.  We can reopen this as necessary or if a different case, I'll file a 
new bug.
(Reporter)

Comment 20

16 years ago
reopening.  Showed JF.  The two msgs I've seen this with were both created by 
the AOL Client.   

Attaching test msg.

Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Whiteboard: [ADT3] have fix, ready to go → [ADT3]
(Reporter)

Comment 21

16 years ago
Created attachment 77699 [details]
test message

Comment 22

16 years ago
Changing nsbeta1+ [adt3] bugs to nsbeta1- on behalf of the adt.  If you have any
questions about this, please email adt@netscape.com.  You can search for
"changing adt3 bugs" to quickly find and delete these bug mails.
Keywords: nsbeta1-

Comment 23

16 years ago
Changing nsbeta1+ [adt3] bugs to nsbeta1- on behalf of the adt.  If you have any
questions about this, please email adt@netscape.com.  You can search for
"changing adt3 bugs" to quickly find and delete these bug mails.
Keywords: nsbeta1+
This is either an editor or a layout bug. The dom node are not displayed in the
right orther! If I send the message, the received message will be correct with
the signature at the end of the document and ot in the middle like it was during
the composition.

I did a copy/past of the whole message body from the msg compose window to the
editor window and the same display problem occurs. However, if I save the editor
window and reopen the document in a browser window, it will be fine. Worst, if I
edit the saved document with editor (edit page), it will be fine despite the
html source or the case that display correctly and the one that doesn't are
exactly the same!!!

Reassign to editor core.
here are the step to reproduce the problem:
1) save the attachment #77699 [details] directly into the folder Mail/Local Folders (in
your profile directory)
2) quit and restart Mozilla
3) open mail and select the file you have just save, it will appears as a mail
folder under Local Folders
4) be sure you have configured a (text) signature for your default account
5) select the message "Re:I won't win"
6) do a forward inline
7) ==> your signature will appears in the middle of the original message body!!
Assignee: ducarroz → kin
Status: REOPENED → NEW
Component: Composition → Editor: Core
Keywords: mailtrack
Product: MailNews → Browser
QA Contact: sheelar → sujay

Comment 25

16 years ago
While I agree that putting the signature in the middle is definitely wrong, I 
would argue that putting it at the end isn't great either. I'd much prefer 
having it *before*. So that only the text I put in introduction to the 
forwarded message is signed by me.
I realize this comment may not exactly belong here, I apologize if you find it 
disruptive.
(Assignee)

Updated

16 years ago
Target Milestone: mozilla1.0 → Future

Updated

15 years ago
Keywords: nsbeta1- → nsbeta1
(Reporter)

Comment 26

15 years ago
For reference, I can still reproduce this bug on a branch (dated 10-7) based of 1.0.

Comment 27

15 years ago
adt: nsbeta1-
Keywords: nsbeta1 → nsbeta1-

Comment 28

13 years ago
M. Ducarroz: I cannot reproduce the symptoms you describe in comment 24, using 
1.4, 1.7 or 1.8a3, whether my mail composition is HTML or plain text.
If you (or lchiang) can confirm, please WFM this bug.

Comment 29

13 years ago
No response; =>WFM
Status: NEW → RESOLVED
Last Resolved: 16 years ago13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.