Closed Bug 1074299 Opened 7 years ago Closed 7 years ago

Fix nav bar shortcut drags in e10s

Categories

(Firefox :: General, defect)

x86_64
All
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 35
Tracking Status
e10s m3+ ---

People

(Reporter: jimm, Assigned: jimm)

References

Details

Attachments

(1 file, 1 obsolete file)

No description provided.
Attached patch fix (obsolete) — Splinter Review
It's unfortunate I have to use a cpow here for the title but I'm not seeing another way to get that in the parent. Even if this isn't optimal, I think its a good work around for nav bar shortcut drags.
Assignee: nobody → jmathies
Attachment #8496963 - Flags: review?(mrbkap)
Attached patch fixSplinter Review
Found something better for title - browser.contentTitle.
Attachment #8496963 - Attachment is obsolete: true
Attachment #8496963 - Flags: review?(mrbkap)
Attachment #8496969 - Flags: review?(mrbkap)
Comment on attachment 8496969 [details] [diff] [review]
fix

Just use:
let value = gBrowser.currentURI.spec;
let urlString = value + "\n" + gBrowser.contentTitle;
Attachment #8496969 - Flags: review?(mrbkap) → review+
https://hg.mozilla.org/mozilla-central/rev/c9e24e09a8b7
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 35
Duplicate of this bug: 1067129
tracking-e10s: --- → m4+
Duplicate of this bug: 1075683
You need to log in before you can comment on or make changes to this bug.