Closed Bug 1074512 Opened 5 years ago Closed 5 years ago

New browser window is not being shown in the Tab Manager

Categories

(Firefox OS Graveyard :: Gaia::Browser, defect, P1)

x86
macOS
defect

Tracking

(tracking-b2g:backlog, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S6 (10oct)
tracking-b2g backlog
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: djabber, Assigned: kgrandon)

References

Details

(Whiteboard: [systemsfe])

Attachments

(2 files)

Steps:

1) Launch browser -> New browser window is shown
2) Tap on Tab button -> Shows tab manager view

Actual:
The New browser window is not shown in the Tab manager. 

Expected:
The new browser window should be treated as a Browser window and be shown in the Tab manager. If the user selects to load a URL, then the URL should load in the window.
[Blocking Requested - why for this release]: Confusing UX. There are inconsistencies between the Task manager and the Tab manager. The New browser window is shown in the Task manager but not the Tab manager. Launching browsing is a key activity and if we don't handle the New browser window well we're compromising a core part of the UX, which is that we should have browsing use cases nailed.
blocking-b2g: --- → 2.1?
Whiteboard: [systemsfe]
Please note, this is not a new feature, but corresponds to the Browser spec at: https://mozilla.box.com/s/3zywxvb5r0q8cqcd6314

See page 18, box 2:
"The browser windows manager displays a horizontal list of all open browser windows.

These windows should be ordered historically, with the most recent window at the
front of the list.

Note, the Browser start page should beincluded in the list of browser windows."
I might give this a stab.
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Target Milestone: --- → 2.1 S6 (10oct)
Attached file Github pull request
Here is a patch that should fix it. I'll add a simple unit test to this as well.
Comment on attachment 8497179 [details] [review]
Github pull request

Aus - could you take a look at this? Thanks!
Attachment #8497179 - Flags: review?(aus)
Attached file Pull request to v2.1
And here is a pull request to uplift should we need to.
blocking-b2g: 2.1? → backlog
Priority: -- → P1
Comment on attachment 8497179 [details] [review]
Github pull request

Code changes look good to me! Thanks for adding a test as well.
Attachment #8497179 - Flags: review?(aus) → review+
In master: https://github.com/mozilla-b2g/gaia/commit/00d916399564df4980d60667d1988865570cc5a5
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8497183 [details] [review]
Pull request to v2.1

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Late task manager filtering work.
[User impact] if declined: Awkward UX when entering task manager from the browser app (I personally think that this should be a blocker).
[Testing completed]: Manual and unit testing.
[Risk to taking this patch] (and alternatives if risky): Low as it's sandboxed to only the filtering code in task manager.
[String changes made]: none.
Attachment #8497183 - Flags: approval-gaia-v2.1?(fabrice)
Attachment #8497183 - Flags: approval-gaia-v2.1?(fabrice) → approval-gaia-v2.1+
Looks like the Gaia Try run has failures?
Flags: needinfo?(kgrandon)
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #10)
> Looks like the Gaia Try run has failures?

Thanks for letting me know. I'm rebasing and trying again. These definitely look unrelated to the test though. I recall seeing other problems on v2.1 gaia-try, so I wonder if this could be some harness issue.
Yeah, they seem to be happening pretty consistently across runs.

v2.1: https://github.com/mozilla-b2g/gaia/commit/cdbbc49802357456222d34d176dc28150833be93
Flags: needinfo?(kgrandon)
Duplicate of this bug: 1073061
Issue verified fixed on Flame 2.1 and Flame 2.2

Device: Flame 2.1 KK (319mb) (Full Flash)
BuildID: 20141011000201
Gaia: f5d4ff60ffed8961f7d0380ada9d0facfdfd56b1
Gecko: d813d79d3eae
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.2 Master KK (319mb) (Full Flash)
BuildID: 20141011040204
Gaia: 95f580a1522ffd0f09302372b78200dab9b6f322
Gecko: 3f6a51950eb5
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

The new browser window page always appears in window manager.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.