The SIM 2 Voice mail displayed as a "Unknown contact" in dialer view and call log view

RESOLVED FIXED in Firefox OS v2.0M

Status

Firefox OS
Gaia::Dialer
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: dwi2, Assigned: dwi2)

Tracking

(Blocks: 1 bug)

unspecified
2.1 S6 (10oct)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.0M+, b2g-v2.0 affected, b2g-v2.0M fixed, b2g-v2.1 fixed, b2g-v2.2 fixed)

Details

Attachments

(2 attachments)

(Assignee)

Description

3 years ago
[Initial condition]
1. SIM information:
   SIM1 :CMCC 3G.
   SIM2:CU 3G
2. Data connection:Off.   
3. Issue happen time: 2014-09-18 20:32

[Step]
1.Set the Voice mail for SIM1 and SIM2
2.Launch Dialer->Long press "1"->Slect SIM2.
   **The "Voice mail" cant' be displayed in dialer screen and coll log  

[Expected Result]
The characters of "Voice mail" should be displayed 

[Error]
The characters of "Voice mail" Can't displayed
(Assignee)

Updated

3 years ago
Assignee: nobody → tzhuang
(Assignee)

Comment 1

3 years ago
This bug happens on v2.0, v2.1, and master as well
Status: NEW → ASSIGNED
status-b2g-v2.0: --- → affected
status-b2g-v2.0M: --- → affected
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1070808
(Assignee)

Comment 3

3 years ago
Created attachment 8497250 [details] [review]
pull request
(Assignee)

Comment 4

3 years ago
Hi Josh, Howie,

Not sure whom to ask, so I just NI you both. 
This bug is duped from bug 1070808 which is 2.0+, however 1070808 is a confidential bug.
So I just made a public version of it.

Raise 2.0m? for you to decide correct flag.

Thanks
Flags: needinfo?(jocheng)
Flags: needinfo?(hochang)
(Assignee)

Updated

3 years ago
Target Milestone: --- → 2.1 S6 (10oct)

Comment 5

3 years ago
Thank you Tzu-Lin. qawanted to confirm this happens on Flame. If so, this bug should be nominated as 2.0?
Flags: needinfo?(hochang)
Keywords: qawanted

Comment 6

3 years ago
Hi Hubert, 
qawanted, thanks!
Flags: needinfo?(jocheng) → needinfo?(hlu)
per comment 4, 2.0+ since the original confidential bug is 2.0+.
blocking-b2g: --- → 2.0+
Flags: needinfo?(hlu)
Keywords: qawanted
Tzu-lin, do you forget to ask review for your PR?
Flags: needinfo?(tzhuang)
(Assignee)

Comment 9

3 years ago
Douglas has gave me some comment but I haven't finish them yet. I'll set review once I address them.
Flags: needinfo?(tzhuang)
(Assignee)

Updated

3 years ago
Summary: The SIM 2 Voice mail displayed as a "Unkonw contact" in dialer view and call log view → The SIM 2 Voice mail displayed as a "Unknown contact" in dialer view and call log view
(Assignee)

Comment 10

3 years ago
Comment on attachment 8497250 [details] [review]
pull request

Hi Douglas,

I've addressed your comments. And I was not sure how to make 'scenarios' to be more readable, so I added some comments to explain it's purpose.
Attachment #8497250 - Flags: review?(drs+bugzilla)
Comment on attachment 8497250 [details] [review]
pull request

I did a pass by review while looking at our blockers. I think the API change for Voicemail makes our code less readable.
Attachment #8497250 - Flags: feedback-
Comment on attachment 8497250 [details] [review]
pull request

Clearing review until Anthony's comments are addressed.
Attachment #8497250 - Flags: review?(drs+bugzilla)
(Assignee)

Comment 13

3 years ago
to update my status: 

I've address feedback comment to update Voicemail.check to use Promise and finished its unit test. 
However I found out that I also broke many other unit tests.

Still trying to fixing them.
(Assignee)

Comment 14

3 years ago
Comment on attachment 8497250 [details] [review]
pull request

Hi Anthony and Douglas,

I've address your comments. Please kindly give some feedback and review.

Because I change Voicemail.check() to return promise now, I also need to manually resolve promise of Voicemail.check() in handle_call_test and dialer_test to make these two tests run synchronously.

Thanks
Attachment #8497250 - Flags: review?(drs+bugzilla)
Attachment #8497250 - Flags: feedback?(anthony)
Attachment #8497250 - Flags: feedback-
Comment on attachment 8497250 [details] [review]
pull request

Thanks for this, all my concerns have been addressed.
Attachment #8497250 - Flags: feedback?(anthony) → feedback+
Comment on attachment 8497250 [details] [review]
pull request

This is looking pretty good now. I left a few fairly nit-picky comments in the PR.
Attachment #8497250 - Flags: review?(drs+bugzilla) → review-
(Assignee)

Comment 17

3 years ago
Comment on attachment 8497250 [details] [review]
pull request

Hi Douglas,

Comment addressed. Please help to review it. 

Thanks
Attachment #8497250 - Flags: review- → review?(drs+bugzilla)
Comment on attachment 8497250 [details] [review]
pull request

Looks good, thanks for sticking with us!
Attachment #8497250 - Flags: review?(drs+bugzilla) → review+
(Assignee)

Comment 19

3 years ago
rebase to master, squash all commits, and waiting for result of Gaia-try
(Assignee)

Comment 20

3 years ago
It seems like Gaia-try stop working now...
I went ahead and landed this because the try run looked clean. Please request uplift to v2.0 and v2.1.

https://github.com/mozilla-b2g/gaia/commit/bb33804b1eb854e7cea1936ca14178f90cdbdd26
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-b2g-v2.2: affected → fixed
Flags: needinfo?(tzhuang)
Resolution: --- → FIXED
(Assignee)

Comment 22

3 years ago
Comment on attachment 8497250 [details] [review]
pull request

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined:
When user dial voicemail number of SIM 2, it would be displayed as regular phone number instead of 'voicemail number' on both call screen and call log.

[Testing completed]: yes, with full coverage of unit tests
[Risk to taking this patch] (and alternatives if risky): not much risk since it only add one more argument to Voicemail.check
[String changes made]: no
Attachment #8497250 - Flags: approval-gaia-v2.1?
Attachment #8497250 - Flags: approval-gaia-v2.0?
Flags: needinfo?(tzhuang)

Updated

3 years ago
Attachment #8497250 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+

Updated

3 years ago
Blocks: 1080481
v2.1: https://github.com/mozilla-b2g/gaia/commit/a38a9e4376c78a65afe23623f8ba208be0fa0159
status-b2g-v2.1: affected → fixed

Updated

3 years ago
Blocks: 1054172
Merge into v2.0m conflict.
Flags: needinfo?(tzhuang)
Keywords: branch-patch-needed
(Assignee)

Comment 25

3 years ago
Created attachment 8503715 [details] [review]
patch to v2.0m

this patch is cherry-picked from the original one.
Flags: needinfo?(tzhuang)
https://github.com/mozilla-b2g/gaia/commit/d09447e851e5f753524bccb8f15051188745fcf2
status-b2g-v2.0M: affected → fixed
Flags: in-testsuite?

Comment 27

3 years ago
This is reported by partner for 2.0M. Make it 2.0M+.

Hi Wesley,
This is generic bug. Please decide whether it's important enough to land on 2.0.
Thanks!
Flags: needinfo?(whuang)

Updated

3 years ago
blocking-b2g: 2.0+ → 2.0M+
(In reply to Josh Cheng [:josh] from comment #27)
> This is reported by partner for 2.0M. Make it 2.0M+.
> 
> Hi Wesley,
> This is generic bug. Please decide whether it's important enough to land on
> 2.0.
> Thanks!

Per the triage meeting, let's not aggressively uplift patch to 2.0.
Flags: needinfo?(whuang)
(Assignee)

Comment 29

3 years ago
Comment on attachment 8497250 [details] [review]
pull request

according to comment 28, revoke approval request
Attachment #8497250 - Flags: approval-gaia-v2.0?
Flags: in-testsuite? → in-qa-testsuite?(jlorenzo)

Comment 30

3 years ago
Hi Norry,
PLease verify on Woodduck 2.0M. Thanks!
Flags: needinfo?(fan.luo)
Keywords: branch-patch-needed → verifyme
Hi Josh,

In Chinese mainland, the voice mail is not supported. So, we can't verify it.
Flags: needinfo?(fan.luo)
Keywords: verifyme
QA Whiteboard: [fxosqa-auto-backlog?]
Flags: in-qa-testsuite?(jlorenzo)
Plussing, but I think it might be a bit challenging to do the SIM and voicemail setup. We should do a dependency exploration before committing to any work.
QA Whiteboard: [fxosqa-auto-backlog?] → [fxosqa-auto-backlog+]
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/11665/
QA Whiteboard: [fxosqa-auto-backlog+] → [fxosqa-auto-backlog+][MGSEI-Triage+]
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.