[Lock Screen] Ambient notification indicator on lock screen

VERIFIED FIXED in Firefox OS v2.1

Status

Firefox OS
Gaia::System::Lockscreen
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: robmac, Assigned: albertopq)

Tracking

unspecified
2.1 S6 (10oct)
x86
Mac OS X
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

Details

(Whiteboard: [systemsfe][tako] [Tako_Blocker])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
One of our partners has pointed out that the ambient indicator on the lock screen is unnecessary as (a) the tray cannot be opened and (b) the notifications appear on the lock screen in any case. As a result, UX is requesting that the ambient notification indicator be removed from the lock screen.
(Reporter)

Updated

4 years ago
Whiteboard: [systemsfe][tako]
(Reporter)

Comment 1

4 years ago
Hi Michael - Flagging you to assess feasibility and the assignment. I'm not in the office currently but Jaime has additional background information if required. - Rob
Flags: needinfo?(mhenretty)
It's a pretty easy fix I believe, but I worry about making feature changes this late in the game for 2.1. We are already knee deep in blockers. Which partner pointed this problem out, was it Tako?
Flags: needinfo?(mhenretty)

Comment 3

4 years ago
Yes, Tako.
Alberto, you wanna have a look here once all your blockers are done? We are going to try and uplift this for 2.1, but we aren't currently blocking on it.
Flags: needinfo?(apastor)

Comment 5

4 years ago
Tagged as blocking as:

Impact on a large number of users
Critical for the first time experience

Users who see a devices with a pending notification for the first time will probably think the display is broken or that it is mounted incorrectly so that an area which should have been hidden by the plastic frame is visible.

This impacts both the in-shop experience as well as HW quality perception.
blocking-b2g: --- → 2.1?
(Assignee)

Updated

4 years ago
Assignee: mhenretty → apastor
Flags: needinfo?(apastor)
(Assignee)

Comment 6

4 years ago
Created attachment 8498202 [details] [review]
Link to Pull Request: https://github.com/mozilla-b2g/gaia/pull/24671
Attachment #8498202 - Flags: review?(mhenretty)
Comment on attachment 8498202 [details] [review]
Link to Pull Request: https://github.com/mozilla-b2g/gaia/pull/24671

Please request uplift, stating this is highly desired by Tako. We'll see what RM thinks. It's a simple low-risk fix, so I think we are ok here.
Attachment #8498202 - Flags: review?(mhenretty) → review+
(Assignee)

Comment 8

4 years ago
Comment on attachment 8498202 [details] [review]
Link to Pull Request: https://github.com/mozilla-b2g/gaia/pull/24671

https://github.com/mozilla-b2g/gaia/pull/24671
Attachment #8498202 - Attachment description: Link to Pull Request: https://github.com/mozilla-b2g/gaia/pull/24614 → Link to Pull Request: https://github.com/mozilla-b2g/gaia/pull/24671
(Assignee)

Comment 9

4 years ago
master: https://github.com/mozilla-b2g/gaia/commit/c99238dcabdcb87eec78499a1a0c99e5fef13b08
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

4 years ago
Comment on attachment 8498202 [details] [review]
Link to Pull Request: https://github.com/mozilla-b2g/gaia/pull/24671

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: Ambient indicator is shown in the Lockscreen, but is not actionable. This commit removes it from the Lockscreen
[Testing completed]: Manual testing
[Risk to taking this patch] (and alternatives if risky): Low risk. css only
[String changes made]: -
Attachment #8498202 - Flags: approval-gaia-v2.1?(fabrice)
Tako request
blocking-b2g: 2.1? → 2.1+
Target Milestone: --- → 2.1 S6 (10oct)

Updated

4 years ago
Whiteboard: [systemsfe][tako] → [systemsfe][tako] [Tako_Blocker]
Blocks: 1076007
Comment on attachment 8498202 [details] [review]
Link to Pull Request: https://github.com/mozilla-b2g/gaia/pull/24671

I'm pretty sure we can add tests here...
Attachment #8498202 - Flags: approval-gaia-v2.1?(fabrice) → approval-gaia-v2.1+
v2.1: https://github.com/mozilla-b2g/gaia/commit/76744433ef8fbdd31a3d7a3d646563061e27b2f4
status-b2g-v2.1: --- → fixed
status-b2g-v2.2: --- → fixed

Comment 14

4 years ago
this issue no longer occurs on Flame 2.2 Master KK (319mb) (Full Flash), 2.1 KK (319mb) (Full Flash) 

Ambient notifications are no longer shown on the lock screen, 


Flame 2.2 Master KK (319mb) (Full Flash)

Device: Flame 2.2 Master
BuildID: 20141011040204
Gaia: 95f580a1522ffd0f09302372b78200dab9b6f322
Gecko: 3f6a51950eb5
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

2.1 KK (319mb) (Full Flash)

Environmental Variables:
Device: Flame 2.1 KK (319mb) (Full Flash)
Build ID: 20141010000201
Gaia: d71f8804d7229f4b354259d5d8543c25b4796064
Gecko: 7fa82c9acdf2
Version: 34.0a2 Flame 2.1 KK (319mb)
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: fixed → verified
status-b2g-v2.2: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Integration test added in bug 1077579.
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.