Closed Bug 1075479 Opened 5 years ago Closed 5 years ago

http://anathemaserial.wordpress.com/table-of-contents/ Mouseover over the header image makes it disappear

Categories

(Core :: ImageLib, defect)

35 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox33 --- unaffected
firefox34 --- unaffected
firefox35 + wontfix
firefox36 - affected
firefox37 --- affected

People

(Reporter: mayankleoboy1, Assigned: seth)

References

Details

(Keywords: regression, testcase)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20140930030202

Steps to reproduce:

1. Create a fresh profile
2. Go to http://anathemaserial.wordpress.com/table-of-contents/
3. Mouseover over the header image


Actual results:

The bottom half of the image flashes (turns white and then appears)


Expected results:

smooth transition from the original image to a different image with darker background.

Works fine in Chrome and FF24.  So definitely a regression
Tentatively marking in imagelib
I'm not able to reproduce it with FF32/35, the fading of the image is smooth.
Component: ImageLib → Layout: Images
This appears to repro better if you open the tabs on top of the header image and then try the mouseover in the new page opened.
Ok, I think a better STR is this:

1. Open the URL
2. While the page is being loaded, start doing the "mouseover and out, mouseover and out" thing on the image as it is being downloaded. 

3. when finally the image is completely downloaded, mouseover would cause white spots.
Please ignore comment #4.
No longer blocks: 1073924
Steps To Reproduce:
1. Clear Recent History and restart
2. Open http://anathemaserial.wordpress.com/table-of-contents/
3. While loading the page, Put mouse pointer to the coordinates(x=600, y=300px from the top-left corner of contents area)(i.e., near the center of the header image). And do not move the mouse pointer.
4. After page loaded, Move around the header image

Regression window(m-c)
Good:
https://hg.mozilla.org/mozilla-central/rev/43ab820c7b68
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0 ID:20140926183438
Bad:
https://hg.mozilla.org/mozilla-central/rev/818f353b7aa6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0 ID:20140927030204
Pushlog
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=43ab820c7b68&tochange=818f353b7aa6
Triggred by:
818f353b7aa6	Seth Fowler — Bug 1069369 - Remove all manual discarding during frame lookup. r=tn a=kwierso
Blocks: 1069369
Component: Layout: Images → ImageLib
Version: Trunk → 35 Branch
This seems pretty easy for me to reproduce. And the regressing bug makes me wonder how bad the problem is.
Flags: needinfo?(seth)
Hmm, I'm not having the easiest time reproducing this, though I've only tried a couple of times.

It would be useful to understand what changed to cause this. (I mean, we obviously have the patch that caused it, but it'd be nice to understand specifically what the issue is.) This is somewhat low priority for me in the short term, though, since I expect us to no longer have to discard to redecode at all somewhat soon, which will render this kind of issue moot. If the schedule starts slipping, I'll investigate this more aggressively.

I'm leaving needinfo on for now, because this definitely does need to be resolved one way or another.
Steps that worked pretty reliably for me were similar to comment 6.
1. Load http://anathemaserial.wordpress.com/table-of-contents/
2. Put mouse on top of the header, and then don't touch it.
3. Shift-reload the page (ctrl-shift-r or cmd-shift-r).
4. Move mouse in and out of header.

The odd part is that it doesn't go away after a while as you'd expect if the image was decoding.
I think it could be a serious regression, because it's a bad interaction between image loading/decoding and fading (transition).

I attached a simple reduced testcase with STR.
Keywords: testcase
Bump on the ni? for Seth - we're a few weeks from shipping FF35, is there something being done to investigate this?  Alternately, is a low risk backout possible?
Flags: needinfo?(seth)
Flags: needinfo?(seth)
We're too late for 35, tracking for 36 to see if we can get a fix in during the next beta cycle.  We'll have to see how bad this regression is in the wild.
Assignee: nobody → seth
This seemd to be fixed by Bug 1098958 in Firefox36 beta.

Could you try Firefox36 beta, Aurora37.0a2 and Nightly38.0a1.

https://www.mozilla.org/en-US/firefox/channel/#beta
https://www.mozilla.org/en-US/firefox/channel/#developer
https://nightly.mozilla.org/
Flags: needinfo?(mayankleoboy1)
cant repro it in nightly
Flags: needinfo?(mayankleoboy1)
Thanks for the feedback, I won't track it anymore then.
I tested FF36/37/38, both websites and testcase are fixed.
as per comment #14 and comment #16
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
Thanks for verifying the fix!
Flags: needinfo?(seth)
You need to log in before you can comment on or make changes to this bug.