Firefox needs a restart in order to update the default search engine from the "<term> - Search with <engine>" string

VERIFIED FIXED in Firefox 35

Status

()

Toolkit
Places
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: avaida, Assigned: Unfocused)

Tracking

35 Branch
mozilla35
Points:
3
Dependency tree / graph
Bug Flags:
firefox-backlog +
qe-verify +

Firefox Tracking Flags

(firefox35 verified)

Details

Attachments

(1 attachment)

Note: this is a follow-up bug for Bug 1067888.

Reproducible on:
 * Nightly 35.0a1 (2014-10-01)
using Windows 7 64-bit, Ubuntu 14.04 LTS 32-bit and Mac OS X 10.9.5.

STR:
1. Launch Firefox with a clean profile.
2. Set a default search engine, e.g. Google.
3. Search for something using the awesomebar, e.g. 'example' (w/o apostrophe).
4. Change the default search engine by clicking on the Google favicon displayed in the Search Bar, e.g. change it to Bing.
5. Type in a different search term in the awesomebar without pressing the <enter> key.

ER:
3. The suggestions pane displays the following entry: "example - Search with Google".
5. The suggestions pane displays the following entry: "example - Search with Bing".

AR:
5. The suggestions pane is still displaying the following entry: "example - Search with Google", instead of "... with Bing".

Additional notes:
- This issue is *not a regression*, given that it's reproducible starting with the build in which Bug 1067888 first landed.
- If you restart the browser after switching to another search engine, the string is updated.
- This issue is reproducible across all platforms.
- Screenshot depicting the issue: http://i.imgur.com/qOL2mnc.png.
Flags: qe-verify+
Depends on: 1067888
Turns out this was what we causing my tests to fail elsewhere!
Assignee: nobody → bmcbride
Status: NEW → ASSIGNED
Points: --- → 3
Flags: needinfo?(mmucci)
Flags: firefox-backlog+
Created attachment 8499260 [details] [diff] [review]
Patch v1
Attachment #8499260 - Flags: review?(mak77)
Added to IT 35.3
Iteration: --- → 35.3
Flags: needinfo?(mmucci)

Updated

3 years ago
Duplicate of this bug: 1075554

Updated

3 years ago
Blocks: 995091
Comment on attachment 8499260 [details] [diff] [review]
Patch v1

Review of attachment 8499260 [details] [diff] [review]:
-----------------------------------------------------------------

::: toolkit/components/places/tests/unifiedcomplete/test_searchEngine_current.js
@@ +34,5 @@
> +  do_log_info("search engine, after current engine has changed");
> +  Services.search.addEngineWithDetails("MozSearch2", "", "", "", "GET",
> +                                       "http://s.example.com/search2");
> +  engine = Services.search.getEngineByName("MozSearch2");
> +  Services.search.currentEngine = engine;

could you please add a sanity test checking that currentEngine is not engine, before you set it?
Attachment #8499260 - Flags: review?(mak77) → review+
https://hg.mozilla.org/integration/fx-team/rev/49c1e23101a2
https://hg.mozilla.org/mozilla-central/rev/49c1e23101a2
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
Verified fixed on Nightly 35.0a1 (2014-10-08)  using Windows 7 64-bit, Mac OS X 10.9.5 and Ubuntu 14.04 LTS 32-bit.
Status: RESOLVED → VERIFIED
status-firefox35: affected → verified
You need to log in before you can comment on or make changes to this bug.