[Dialer] Tapping on the autosuggest part of the dialer when it's empty will trigger an error message & clear your dialed number

RESOLVED DUPLICATE of bug 1038846

Status

RESOLVED DUPLICATE of bug 1038846
4 years ago
4 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
STR:
 1. Dial a phone number for someone not in your contacts.
 2. Tap the empty area, directly below the phone number (where autocomplete suggestions appear, when there's an autocomplete suggestion)

EXPECTED RESULTS: Nothing should happen.

ACTUAL RESULTS: An error message appears saying "Invalid phone number / The phone number you are calling is not valid." When you dismiss the error message, the dialer's text field has been cleared.  Your painstakingly-entered number now needs to be re-entered.


(You can trigger this when no phone number has been entered, too -- just tap the blank area right above the "1 2 3" dialer keys. It's more annoying/destructive when it happens with numbers entered, though.)
(Reporter)

Comment 1

4 years ago
I'm using a Flame with an up-to-date FxOS 2.1 aurora-channel build, BTW.
(Reporter)

Updated

4 years ago
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → All
This should have been fixed in bug 1038846. Daniel, is your setup single-SIM or dual-SIM?
Blocks: 1038846, 1036516
Flags: needinfo?(dholbert)
(Reporter)

Comment 3

4 years ago
The Flame supports dual SIMs, but I've only put one SIM in the phone.
Flags: needinfo?(dholbert)
(Reporter)

Comment 4

4 years ago
Ah -- I only just now noticed: I can only trigger this when a contact suggestion has previously been displayed. (If I entirely quit out of the dialer and then reopen it, I can't repro until I've dialed some numbers to make a suggestion appear.)

So, I think this may be the same thing described in bug 1038846.
(Reporter)

Comment 5

4 years ago
Yeah, I think the issue is just that bug 1038846's fix hasn't made it to aurora (2.1) yet. If I pull /system/b2g/webapps/communications.gaiamobile.org from my device & unzip application.zip & inspect dialer/index.html, I see code from before that bug's fix -- e.g. I see this, which was changed in the first chunk of that bug's patch:
      <section id="suggestion-bar" class="suggestion-bar" aria-hidden="true" hidden="">

Duping.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1038846
(Reporter)

Updated

4 years ago
No longer blocks: 1038846
You need to log in before you can comment on or make changes to this bug.