[Dialer] Once you get a contact suggestion, tapping on it even when empty triggers an "Invalid Number" message

RESOLVED FIXED in Firefox OS v2.0M

Status

Firefox OS
Gaia::Dialer
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: drs, Assigned: jorgep)

Tracking

(Blocks: 2 bugs, {regression})

unspecified
2.1 S4 (12sep)
regression
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.0M+, b2g-v1.4 unaffected, b2g-v2.0 affected, b2g-v2.0M verified, b2g-v2.1 affected, b2g-v2.1S verified, b2g-v2.2 verified)

Details

(Whiteboard: [planned-sprint][in-sprint=v2.1-S3])

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
STR:

1) Enter enough of a phone number into the keypad that you get a contact suggestion.
2) Clear the phone number.
3) Tap where the contact suggestion was.
4) Get "Invalid phone number" message.

I don't know if this is a regression or just always happened.
This bug repro's on: Flame 2.1 Master and Buri 2.1

Actual Results: When entering a phone number and a suggested contact appears, if the number is deleted and the user taps where the suggested contact was displayed, the user sees "Invalid Phone Number" message.

Environmental Variables:
Device: Flame Master
Build ID: 20140715070915
Gaia: 46cd188fdda2397d2b8f3303a184dcd52952e2b2
Gecko: 835e22069c1a
Version: 33.0a1 (Master)
Firmware Version: v122
-----------------------------------------------
Environmental Variables:
Device: Buri Master
Build ID: 20140715070915
Gaia: 46cd188fdda2397d2b8f3303a184dcd52952e2b2
Gecko: 835e22069c1a
Version: 33.0a1 (Master)
Firmware Version: v1.2device.cfg

-----------------------------------------------
-----------------------------------------------

This bug does NOT repro on: Flame 2.0 and Flame 1.4

Actual Result: Tapping in the location of a previously displayed suggested contact in the dialer does nothing.

Environmental Variables:
Device: Flame 2.0
Build ID: 20140715082614
Gaia: 391258012d09cc1dde9a6f3f9a2078739043d0d6
Gecko: 7025d37f4b06
Version: 32.0a2 (2.0)
Firmware Version: v122
-----------------------------------------------
Environmental Variables:
Device: Flame 1.4
Build ID: 20140715071209
Gaia: 7e49e66ae1f8f48bb23a4a551a8e393b0ae8a228
Gecko: 37382637c713
Version: 30.0 (1.4)
Firmware Version: v122
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v1.4: --- → unaffected
status-b2g-v2.0: --- → unaffected
status-b2g-v2.1: --- → affected
Flags: needinfo?(jmitchell)
Keywords: qawanted → regression
QA Contact: croesch
QA-wanted report: not nomming, issue is a fringe case with low visibility.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]

Updated

3 years ago
Blocks: 1036516
(Assignee)

Updated

3 years ago
Assignee: nobody → jpruden92
Target Milestone: --- → 2.1 S3 (29aug)
(Assignee)

Updated

3 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 3

3 years ago
Created attachment 8478228 [details]
23271.html
Attachment #8478228 - Flags: review?(anthony)
(Reporter)

Updated

3 years ago
Whiteboard: [planned-sprint][in-sprint=v2.1-S3]
Target Milestone: 2.1 S3 (29aug) → 2.1 S4 (12sep)
Comment on attachment 8478228 [details]
23271.html

If we're going to use display: none, we don't need to use hidden and aria-hidden so please remove those. And the associated CSS selectors in suggestion.css.

Instead of doing explicitly setting |display: none|, I'd rather set a class and have the display: none done in the CSS. That allows us to not duplicate the flex style.

And we'll need to modify the tests.
Attachment #8478228 - Flags: review?(anthony) → review-
(Assignee)

Comment 5

3 years ago
Comment on attachment 8478228 [details]
23271.html

Hello Anthony,

I've already changed the code. I think that now it's better. I've changed the unit tests too. Can you review the patch?

Thanks!
Attachment #8478228 - Flags: review- → review?(anthony)
Comment on attachment 8478228 [details]
23271.html

We need to remove the two rules in suggestion.css that match [hidden].
Attachment #8478228 - Flags: review?(anthony) → review-
(Assignee)

Comment 7

3 years ago
Comment on attachment 8478228 [details]
23271.html

Hello Anthony,

I've already applied your comments.

Thanks!
Attachment #8478228 - Flags: review- → review?(anthony)
I've left questions in the pull request.
(Assignee)

Comment 9

3 years ago
I have done the changes. :-)
(Reporter)

Comment 10

3 years ago
Comment on attachment 8478228 [details]
23271.html

Anthony is on PTO.
Attachment #8478228 - Flags: review?(anthony) → review?(drs+bugzilla)
(Reporter)

Comment 11

3 years ago
Comment on attachment 8478228 [details]
23271.html

See my comments in the PR.
Attachment #8478228 - Flags: review?(drs+bugzilla) → review-
(Assignee)

Comment 12

3 years ago
Comment on attachment 8478228 [details]
23271.html

Hello Doug,

I've already made the changes.

Thanks!
Attachment #8478228 - Flags: review- → review?(drs+bugzilla)
(Reporter)

Comment 13

3 years ago
Comment on attachment 8478228 [details]
23271.html

Thanks, looks good. Please add the "hide" class here:
https://github.com/mozilla-b2g/gaia/blob/master/apps/communications/dialer/test/unit/suggestion_bar_test.js#L126

Once you're done with that, I'll land it.
Attachment #8478228 - Flags: review?(drs+bugzilla) → review+
(Reporter)

Comment 14

3 years ago
This needs a demo. Please add one to https://wiki.mozilla.org/FirefoxOS/Comms/Dialer/Sprint/v2.1-S5#Demos
Flags: needinfo?(jpruden92)
(Assignee)

Comment 15

3 years ago
Hello Doug,

I have uploaded the code with your changes. I'm going to make the Demo now.

Thanks!
Flags: needinfo?(jpruden92)
(Reporter)

Comment 16

3 years ago
https://github.com/mozilla-b2g/gaia/commit/a8eaf1ef31c199aeabd8c207d9d3268b68f9e753

Re-setting ni until the demo has been added, just as a reminder.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-b2g-v2.1: affected → fixed
Flags: needinfo?(jpruden92)
Resolution: --- → FIXED
(Assignee)

Comment 17

3 years ago
Hello Doug,

I've already published the demo: https://wiki.mozilla.org/FirefoxOS/Comms/Dialer/Sprint/v2.1-S5#Demos

Thanks!
Flags: needinfo?(jpruden92)
(Reporter)

Updated

3 years ago
Depends on: 1075740
Duplicate of this bug: 1075740
As discussed in bug 1075740 comment 5, this hasn't actually made it to b2g 2.1 builds yet. (Not the flame aurora channel, at least).

Should this be really be marked "status-b2g-v2.1: fixed"?  And, is there anything else that needs doing to get this actually-fixed on the aurora channel?

For reference, my flame has this version info:
 OS Version: 2.1.0.0-prerelease
 Build Identifier: 20140930160205
 Git commit  info: 2014-09-30 20:59:29  08be48c7
No longer depends on: 1075740
Flags: needinfo?(drs+bugzilla)
(Reporter)

Comment 20

3 years ago
Thanks for noticing that. I think I made a mistake when setting the tracking flags. I don't think this is worth uplifting as it's a relatively minor bug, and v2.1 is nearing FC.
status-b2g-v2.1: fixed → affected
status-b2g-v2.2: --- → fixed
Flags: needinfo?(drs+bugzilla)
blocking-b2g: --- → 2.0M?
status-b2g-v2.0M: --- → affected
Duplicate of this bug: 1118190
Created attachment 8556387 [details] [review]
PR https://github.com/mozilla-b2g/gaia/pull/27773

Hi this PR if for v2.0m.

Comment 23

3 years ago
Hi Kai-Zhen,
Could you help to land this on 2.0M? Thanks!
Blocks: 1054172
blocking-b2g: 2.0M? → 2.0M+
status-b2g-v2.0: unaffected → affected
Flags: needinfo?(kli)
v2.0m: https://github.com/mozilla-b2g/gaia/commit/bdf3742fbbb900fd940fbbd6c8f7b1ae09521874
status-b2g-v2.0M: affected → fixed
status-b2g-v2.1S: --- → affected
Flags: needinfo?(kli)
This bug has been successfully verified on latest Woodduck v2.0 and Flame v2.2.
See attachment: verified_v2.0m.mp4
Reproduce rate: 0/5

STR:
1) Enter a phone number into the keypad that you get a contact suggestion.
2) Clear the phone number.
3) Tap on where the contact suggestion was.
**There is no message "Invalid phone number".

Woodduck 2.0:
Build ID               20150216050313
Gaia Revision          a1b5959728c8bc2a82354e197bb161922d419866
Gaia Date              2015-02-13 09:00:02
Gecko Revision         917050ccd94ab32278090e3d3fdf33e62096d449
Gecko Version          32.0
Device Name            jrdhz72_w_ff
Firmware(Release)      4.4.2
Firmware(Incremental)  1424034320
Firmware Date          Mon Feb 16 05:05:46 CST 2015

Flame 2.2 build:
Build ID               20150215002504
Gaia Revision          ea64caf6d4ab03fc4472eca9f41f20d651d55fa9
Gaia Date              2015-02-13 05:27:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/62c80c92b39e
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150215.040852
Firmware Date          Sun Feb 15 04:09:03 EST 2015
Bootloader             L1TC000118D0
status-b2g-v2.0M: fixed → verified
status-b2g-v2.2: fixed → verified
Created attachment 8564868 [details]
verified_v2.0m.MP4
QA Whiteboard: [QAnalyst-Triage+][lead-review+] → [QAnalyst-Triage+][lead-review+][MGSEI-Triage+]
Duplicate of this bug: 1133427
Created attachment 8573183 [details] [review]
Pull request to 2.1s

This patch cherry-pick attachment 8478228 [details] to 2.1s branch
2.1s: https://github.com/mozilla-b2g/gaia/commit/dd5aa67e3d49648383dec48ff4b0f33f2b7ba085
status-b2g-v2.1S: affected → fixed
This bug has been successfully verified on latest v2.1S(512mb and 256mb).
Reproduce rate: 0/5

2.1S 512mb:
Build ID               20150309161206
Gaia Revision          485b69e877429b85d08129ddd1cc2c22fd4806ce
Gaia Date              2015-03-09 03:47:59
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1s/rev/fc6db70a7ea2
Gecko Version          34.0
Device Name            scx15_sp7715ea
Firmware(Release)      4.4.2
Firmware(Incremental)  122
Firmware Date          Thu Feb  5 12:42:58 CST 2015

2.1S 256mb:
Build ID               20150309161206
Gaia Revision          485b69e877429b85d08129ddd1cc2c22fd4806ce
Gaia Date              2015-03-09 03:47:59
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1s/rev/fc6db70a7ea2
Gecko Version          34.0
Device Name            scx15_sp7715ga
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150309.194645
Firmware Date          Mon Mar  9 19:46:57 EDT 2015
status-b2g-v2.1S: fixed → verified
You need to log in before you can comment on or make changes to this bug.