Closed Bug 1076454 Opened 8 years ago Closed 8 years ago

Intermittent failing test, TEST-UNEXPECTED-FAIL | /builds/slave/test/gaia/apps/system/test/marionette/browser_chrome_share_web_result_test.js | Browser Chrome - Share Web Result share web result via e-mail

Categories

(Firefox OS Graveyard :: Gaia, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
2.1 S6 (10oct)

People

(Reporter: kgrandon, Assigned: kgrandon)

References

Details

(Keywords: intermittent-failure, Whiteboard: [systemsfe])

Attachments

(1 file)

46 bytes, text/x-github-pull-request
daleharvey
: review+
Details | Review
NoSuchElement: (7) Unable to locate element: .icon[data-identifier*="mozilla1.org/"]
15:19:59     INFO -    Remote Stack:
15:19:59     INFO -    <none>
15:19:59     INFO -        at Error.MarionetteError (/builds/slave/test/gaia/node_modules/marionette-client/lib/marionette/error.js:67:13)
15:19:59     INFO -        at Object.Client._handleCallback (/builds/slave/test/gaia/node_modules/marionette-client/lib/marionette/client.js:476:19)
15:19:59     INFO -        at /builds/slave/test/gaia/node_modules/marionette-client/lib/marionette/client.js:510:21
15:19:59     INFO -        at TcpSync.send (/builds/slave/test/gaia/node_modules/marionette-client/lib/marionette/drivers/tcp-sync.js:153:10)
15:19:59     INFO -        at Object.send (/builds/slave/test/gaia/node_modules/marionette-client/lib/marionette/client.js:457:36)
15:19:59     INFO -        at Object.Client._sendCommand (/builds/slave/test/gaia/node_modules/marionette-client/lib/marionette/client.js:503:19)
15:19:59     INFO -        at Object._findElement (/builds/slave/test/gaia/node_modules/marionette-client/lib/marionette/client.js:1303:19)
15:19:59     INFO -        at Object.findElement (/builds/slave/test/gaia/node_modules/marionette-client/lib/marionette/client.js:1352:32)
15:19:59     INFO -        at Object.MarionetteHelper.waitForElement (/builds/slave/test/gaia/node_modules/marionette-helper/index.js:139:19)
15:19:59     INFO -        at Object.Search.checkResult (/builds/slave/test/gaia/apps/search/test/marionette/lib/search.js:70:37)
15:19:59     INFO -        at Context.<anonymous> (/builds/slave/test/gaia/apps/system/test/marionette/browser_chrome_share_web_result_test.js:67:25)
15:19:59     INFO -        at callFn (/builds/slave/test/gaia/node_modules/mocha/lib/runnable.js:223:21)
15:19:59     INFO -        at Test.Runnable.run (/builds/slave/test/gaia/node_modules/mocha/lib/runnable.js:216:7)
15:19:59     INFO -        at Runner.runTest (/builds/slave/test/gaia/node_modules/mocha/lib/runner.js:373:10)
15:19:59     INFO -        at /builds/slave/test/gaia/node_modules/mocha/lib/runner.js:451:12
15:19:59     INFO -        at next (/builds/slave/test/gaia/node_modules/mocha/lib/runner.js:298:14)
15:19:59     INFO -        at /builds/slave/test/gaia/node_modules/mocha/lib/runner.js:308:7
15:19:59     INFO -        at next (/builds/slave/test/gaia/node_modules/mocha/lib/runner.js:246:23)
15:19:59     INFO -        at /builds/slave/test/gaia/node_modules/mocha/lib/runner.js:270:7
15:19:59     INFO -        at done (/builds/slave/test/gaia/node_modules/mocha/lib/runnable.js:185:5)
15:19:59     INFO -        at callFn (/builds/slave/test/gaia/node_modules/mocha/lib/runnable.js:228:7)
15:19:59     INFO -        at Hook.Runnable.run (/builds/slave/test/gaia/node_modules/mocha/lib/runnable.js:216:7)
15:19:59     INFO -        at next (/builds/slave/test/gaia/node_modules/mocha/lib/runner.js:258:10)
15:19:59     INFO -        at /builds/slave/test/gaia/node_modules/mocha/lib/runner.js:270:7
15:19:59     INFO -        at done (/builds/slave/test/gaia/node_modules/mocha/lib/runnable.js:185:5)
15:19:59     INFO -        at /builds/slave/test/gaia/node_modules/mocha/lib/runnable.js:199:9
15:19:59     INFO -        at /builds/slave/test/gaia/apps/email/test/marionette/lib/servers/fakeimap.js:79:7
15:19:59     INFO -        at /builds/slave/test/gaia/node_modules/mail-fakeservers/lib/control_server.js:62:7
15:19:59     INFO -        at IncomingMessage.<anonymous> (/builds/slave/test/gaia/node_modules/mail-fakeservers/lib/control_request.js:35:7)
15:19:59     INFO -        at IncomingMessage.g (events.js:175:14)
15:19:59     INFO -        at IncomingMessage.EventEmitter.emit (events.js:117:20)
15:19:59     INFO -        at _stream_readable.js:920:16
15:19:59     INFO -        at process._tickCallback (node.js:415:13)
Target Milestone: --- → 2.1 S6 (10oct)
Attached file Github pull request
I noticed that this is the only test which is accessing e.me results and failing. The only difference was the waitForHome() call so I'm going to add that and see what happens.
See Also: → 1066363
This test is disabled for now in order to revive the tree: https://github.com/mozilla-b2g/gaia/commit/573faf15fbae44523336e548cc5f8a623abed6d1
Keywords: leave-open
Comment on attachment 8498577 [details] [review]
Github pull request

Dale - could you give this a review? I think I've finally got this one solved. The problem is that we were not waiting for the eme.init() to finish before making API calls. This led to us using the wrong URL for the API end point.
Attachment #8498577 - Flags: review?(dale)
Comment on attachment 8498577 [details] [review]
Github pull request

This looks great, thanks

Having a hard time parsing the treeherder results, not used to them vs tbpl but it looks to me like the failures are unrelated
Attachment #8498577 - Flags: review?(dale) → review+
Thanks! In master: https://github.com/mozilla-b2g/gaia/commit/55766f4d12f57b5e7289d068a81a3dc501cf10db
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Removing leave-open keyword from resolved bugs, per :sylvestre.
Keywords: leave-open
You need to log in before you can comment on or make changes to this bug.