[PP] A local image with a broken reference is not displaying the ALT name.

VERIFIED DUPLICATE of bug 24778

Status

()

defect
P3
normal
VERIFIED DUPLICATE of bug 24778
20 years ago
2 years ago

People

(Reporter: chrispetersen, Assigned: dcone)

Tracking

({platform-parity})

Trunk
PowerPC
Mac System 8.6
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 attachment)

Reporter

Description

20 years ago
Version: Apprunner
Build: 1999072815
Platform:Mac 8.6
Other Platforms: Works on Win 98 and Linux.
Expected results: The alt name should be displayed when the image can't be found.
What I got: When the file is local, the ALT name is not displayed. There is a 1
pixel object displayed where the text should appear.

Steps to reproduce:
1) Open and save the attached test case to local drive.
2) Open the file in Apprunner.
3) There will a 1 pixel object displayed in the window. The ALT name specified is
not appearing.

Updated

20 years ago
Status: NEW → ASSIGNED

Comment 2

20 years ago
Do other gifs display?
The description you gave could also match
what would happen if the gifcom module was
not linked properly with the gif decoder.

If other gif images display, then there is
a bug in error handling.

-pn

Updated

20 years ago
Summary: [PP]A local image with a broken reference is not displaying the ALT name. → [PP] A local image with a broken reference is not displaying the ALT name.

Comment 3

20 years ago
Confirmed. Grr...I knew I had written this up somewhere, but couldn't find it

when we spoke on the phone.



I believe that 9796 covers this problem. CC:ing Ian out of habit. ;)
Reporter

Comment 4

20 years ago
Yes, this does look like bug # 9796.

Updated

20 years ago
Target Milestone: M10
[thanks elig]

Bug 9796 refers to the case where the document itself is an invalid image, not
when an HTML document refers to a missing image. That would be bug 1995.

If this is a [PP] bug as the summary claims, then I suggest that bug 1995 be
added in the "Bugs depending on bug 10767" list above. Bug 1995 does not
mention Mac-only problems AFAICT, this bug would presumably cover this issue.

AFAIK, this is not a duplicate of anything.
For bug 1995, read bug 1994. *shoots self*
Blocks: 1994
[Adding dependency as per my previous comments...]

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME

Comment 8

20 years ago
I just checked a recent mac build and
I see the alt text.
This was most likely fixed by other checkins.

-pn
Eli: Since this is a Mac-only bug, I am not assigning myself as QA contact.

Updated

20 years ago
Status: RESOLVED → REOPENED

Updated

20 years ago
Resolution: WORKSFORME → ---

Comment 10

20 years ago
While this is not reproducible when loaded via the http:// server, I do see this
issue still on Mac OS using the 1999090609 build when loaded from a local file
(per the bug report.)

Thus, re-opening.

Comment 11

20 years ago
I just tested this on a new tree. It works on a local file
using apprunner and viewer.
Eli, would you try this again. I'm using mac os 8.5.
-pn

Comment 12

20 years ago
Using yesterday's build on Mac OS 8.6, this issue remains reproducible. I'd be
happy to check on a more recent build, but we're doing 4.7 until Monday morning.

Updated

20 years ago
Target Milestone: M10 → M11

Comment 13

20 years ago
I just checked this on Kritzer's mac with 8.6
and it worked fine.
Eli, show me the breakage on Monday.
Thanks.
-pn

Updated

20 years ago
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED

Comment 14

20 years ago
Last time I checked, this worked. No one has added a
comment saying they have had a different experience with
recent builds. I'm closing.
-pn

Updated

20 years ago
Status: RESOLVED → REOPENED

Updated

20 years ago
Resolution: FIXED → ---

Comment 15

20 years ago
Hey, Pam ---

Using the 1999102109 build, this problem still occurs on Mac OS-only, using the
Mac OS 8.6 system in Eli-land. Currently, it displays nothing, instead of the
broken image text. Other local text files display correctly.

Re-opening for pnunn.

Updated

20 years ago
Assignee: pnunn → troy
Status: REOPENED → NEW

Updated

20 years ago
Target Milestone: M11 → M13

Comment 16

20 years ago
This bug requires a mac layout person.
When I view the above url with a breakpoint
set at nsImageFrame:DisplayAltFeedback() on the
mac, it never hits the breakpoint. It does hit
the breakpoint on windows....

Troy, would you assign this to the appropriate person?
Thanks.
-p

Comment 17

20 years ago
This was an m11. I'm changing to m13.
-p

Updated

20 years ago
Assignee: troy → beard

Comment 18

20 years ago
Maybe Patrick Beard?

Comment 19

20 years ago
Or Done Cone?

Updated

20 years ago
Status: NEW → ASSIGNED

Updated

20 years ago
Assignee: beard → troy
Status: ASSIGNED → NEW

Comment 20

20 years ago
I just tried my build from 12/29/99, and it does hit the breakpoint I set on
nsImageFrame::DisplayAltFeedback() a couple of times, but then it stops getting
hit. For some reason, once the alternate text gets displayed,
nsImageFrame::Paint() never gets called again. Why would this be?

Comment 21

20 years ago
That would be because if the image can't be rendered, then we render the
alternate content instead. That means we create a text frame and replace the
image frame with the text frame, i.e., the image frame is destroyed

Updated

20 years ago
Assignee: troy → beard

Comment 22

20 years ago
This sounds like a Mac only problem so I'm re-assigning it back to Patrick

Comment 23

20 years ago
You'll have to give me more information to go on to help me fix this. Where
does the text frame get substituted?

Comment 24

20 years ago
The image frame gets notified by the image library that we can't load the
image. It notifies the pres shell (through the CantRenderReplacedElement()
function), which notifies the frame construction code. The frame construction
CantRenderReplacedElement() code throws away the image frame and creates a text
frame to display the alternate content instead.

Updated

20 years ago
Status: NEW → ASSIGNED

Updated

20 years ago
Assignee: beard → dcone
Status: ASSIGNED → NEW

Comment 25

20 years ago
Reassigning to dcone, so I can concentrate on remaining critical view manager
bugs. Feel free to defer.
Assignee

Updated

20 years ago
Status: NEW → ASSIGNED
Target Milestone: M13 → M14

Updated

20 years ago
Keywords: pp
Assignee

Comment 26

20 years ago
Sounds like this is a duplicate problem.. all platforms are having some problems 
with displaying alternate text due to the lack of an error being sent to the 
image observers when the image URL not being loaded.  Rod has this bug, we are 
all working on (pnunn, rods and dcone) to get this working.

*** This bug has been marked as a duplicate of 24778 ***
Status: ASSIGNED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → DUPLICATE

Comment 27

20 years ago
Ian, might you wish to verify this? (if you can do so without needing the Mac 
that you don't have?)

If you'd rather not, just QA Assign it back to me.

Thanks!
QA Contact: elig → py8ieh=bugzilla
Sounds like it probably is a dup. I'll add a comment on the other bug saying
that this one must be checked before marking the other one a dup.
Status: RESOLVED → VERIFIED
Depends on: 24778
No longer blocks: 1994
You need to log in before you can comment on or make changes to this bug.