[BLOCKED][FIX]image-button doesn't show alternative text value

VERIFIED FIXED in M16

Status

()

Core
Layout: Form Controls
P3
blocker
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: jessberger, Assigned: rods (gone))

Tracking

Trunk
x86
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2-]]Fix in my tree)

(Reporter)

Description

18 years ago
the image-button shows the value of the name-attribute instead of the
alt-attribute

Comment 1

18 years ago
Reassigning to Rod.
Assignee: karnaze → rods
(Assignee)

Comment 2

18 years ago
The problem is the nsImageFrame is never being notified that it couldn't find 
the file/image.

Comment 3

18 years ago
*** Bug 10767 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 4

18 years ago
setting to M14
Target Milestone: M14
(Assignee)

Comment 5

18 years ago
added dependency
Depends on: 25360
(Assignee)

Updated

18 years ago
Depends on: 26582
Blocks: 10767
Bug 10767 MUST be checked when this bug is verified.

ckritzer: Since this is an ALT text bug, I'm taking over QA contact. If you 
don't want me to do this, feel free to reinstate yourself...

rods: I'm a little confused as to what this bug is exactly covering... your 
comment of 2000-01-28 08:45 doesn't seem related to the original submission
comment???

jessberger: Do you have a test page for the problem you were reporting?
Depends on: 1994, 8979
QA Contact: ckritzer → py8ieh=bugzilla
(Assignee)

Comment 7

18 years ago
setting to M15
Status: NEW → ASSIGNED
Target Milestone: M14 → M15
(Assignee)

Comment 8

18 years ago
mass-move to M16
Target Milestone: M15 → M16

Comment 9

18 years ago
Moving out by executive order.
Target Milestone: M16 → M17
(Assignee)

Comment 10

18 years ago
adding dependency
Depends on: 35506
Nominating nsbeta2. Supporting ALT well is important for accessibility. There is 
also legal exposure for AOL under ADA for lack of accessibility. Therefore we 
should try to do as well as possible for FC for both reasons.
Keywords: nsbeta2
Depends on: 34981
(Assignee)

Comment 12

18 years ago
This bug cannot be marked nsbeta2+ unless you mark Bug 35506 nsbeta2+, this bug 
is BLOCKED by Bug 35506. In fact, once Bug 35506 is fixed, there is a good 
chance that this will just work. (But I can't do any testing until then)
Severity: normal → blocker
Summary: image-button doesn't show alternative text value → [BLOCKED]image-button doesn't show alternative text value
(Assignee)

Updated

18 years ago
Whiteboard: Fix in my tree
(Assignee)

Comment 13

18 years ago
Actually, it appears it is broken for net based images also and I just found the 
problem and fixed it. BUT Bug 35506 still needs to be fixed or the alt text 
won't show up for missing disk-based images.

Comment 14

18 years ago
Putting on [nsbeta2+][6/15] radar.
Whiteboard: Fix in my tree → [nsbeta2+][6/15]Fix in my tree
(Assignee)

Updated

18 years ago
Summary: [BLOCKED]image-button doesn't show alternative text value → [BLOCKED][FIX]image-button doesn't show alternative text value
(Assignee)

Updated

18 years ago
Target Milestone: M17 → M16
Since this probably won't make nsbeta2, nom. nsbeta3 & rtm, *strongly* recc.  
nsbeta3 hard-stop.

I'm confused: does this really depend on bug 8979 (which has been marked 
Future)?
Keywords: nsbeta3, rtm
Another thing I don't understand: is this bug specific to the handling of 
*broken* (not found) images (as implied by rods's previous comment "The problem 
is the nsImageFrame is never being notified that it couldn't find the 
file/image."), or does it apply to unbroken, found images? Could someone please 
clarify the Summary?

If this bug is specific to the handling of broken images, maybe we can Future 
this and the depending bugs (so long as we're showing *something* on broken 
links) since elegant handling of broken links (beyond what Nav4 did) isn't a 
priority for FCS. 

Comment 17

18 years ago
Cleaning up status whiteboard by marking beta2 minus (6/15 has passed).

IS the comment "fix in my tree" for real?  This was put in the whiteboard over a 
month ago.... and has me confused.

There are also several question by Ekrock that need clarification.

Rods: Could you update this bug with some info?

Thanks,

Jim
Whiteboard: [nsbeta2+][6/15]Fix in my tree → [nsbeta2-]]Fix in my tree
(Assignee)

Comment 18

18 years ago
Yes, it has been fixed that long, it was a bug dependency issue. it's now fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 19

18 years ago
Verifying on build 2000-09-18-06-M18
Platforms:
 -Windows 98
 -Linux RedHat 6.2
Status: RESOLVED → VERIFIED
Depends on: 75185
No longer depends on: 1994
You need to log in before you can comment on or make changes to this bug.