Closed Bug 1076926 Opened 5 years ago Closed 5 years ago

Add windows 10 support to exe manifest

Categories

(Firefox :: Shell Integration, defect)

32 Branch
x86_64
Windows 10
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 35

People

(Reporter: c, Assigned: c)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [testday-20150901])

Attachments

(1 file, 1 obsolete file)

Attached patch win10 (obsolete) — Splinter Review
User Agent: Mozilla/5.0 (Windows NT 6.4; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20141001101141
Attachment #8498921 - Attachment mime type: text/x-patch → text/plain
Attachment #8498921 - Attachment is patch: true
Attachment #8498921 - Flags: review?(jmathies)
Component: Widget: Win32 → Shell Integration
Product: Core → Firefox
Version: Trunk → 32 Branch
Comment on attachment 8498921 [details] [diff] [review]
win10

You should also to update CommandExecuteHandler.exe.manifest and xpcshell.exe.manifest.
Attached patch win10.patchSplinter Review
Attachment #8498921 - Attachment is obsolete: true
Attachment #8498921 - Flags: review?(jmathies)
OS: Windows NT → Windows 10
Comment on attachment 8499307 [details] [diff] [review]
win10.patch

Please ask a widget/win32 peer for a review.
Attachment #8499307 - Flags: review?(jmathies)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attachment #8499307 - Flags: review?(jmathies) → review+
Keywords: checkin-needed
Duplicate of this bug: 1077783
https://hg.mozilla.org/mozilla-central/rev/0343643a16ce
Assignee: nobody → zhoubcfan
Status: NEW → RESOLVED
Closed: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 35
See Also: → 1078306
Setting qe-verify- for this fix. zhoubcfan, Loic - if you think manual QA is in fact needed here, please flip the flag to +.
Flags: qe-verify-
If somebody is looking - bug 1183725 will update GfxInfo.cpp with the now correct value for Windows 10 - 0xA0000, rather than 0x60004.
Per today's QA bug day, verifying the fix.
Whiteboard: [testday-20150901]
Status: RESOLVED → VERIFIED
(In reply to Jerod Lycett from comment #10)
> Per today's QA bug day, verifying the fix.

Verified in both 41.0b6 (20150831172306) and 40.0.3 (20150826023504) on Windows 10 64bit.
You need to log in before you can comment on or make changes to this bug.