Closed Bug 1078306 Opened 6 years ago Closed 6 years ago

Add Windows 10 as supported OS version to SeaMonkey's exe manifest

Categories

(SeaMonkey :: OS Integration, defect)

x86_64
Windows 10
defect
Not set
normal

Tracking

(seamonkey2.32 fixed)

RESOLVED FIXED
seamonkey2.32
Tracking Status
seamonkey2.32 --- fixed

People

(Reporter: rsx11m.pub, Assigned: rsx11m.pub)

References

Details

Attachments

(1 file)

Porting FF bug 1076926 and TB bug 1078003 to SeaMonkey, patch follows soon.
Attached patch Copy-pasted fixSplinter Review
This is the only *.exe.manifest file I could find within suite/. I'm unable to actually test this patch due to the lack of a Windows 10 installation, but if it works for the other applications I'd guess that it's fine for SeaMonkey as well.
Attachment #8500472 - Flags: review?(neil)
Comment on attachment 8500472 [details] [diff] [review]
Copy-pasted fix

I've installed the tech preview in a VM, so I can confirm that the user agent includes Windows NT 6.4 with the patch but only 6.3 without.
Attachment #8500472 - Flags: review?(neil) → review+
Keywords: checkin-needed
See Also: → 1076926
Oh, I thought it was actually preventing the application from starting. Apparently it's just making it run in Windows 8.1 compatibility mode then. Thanks for the "checkin-needed" (just wanted to do that).
Pushed to comm-central
https://hg.mozilla.org/comm-central/rev/13472cf11a5c
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.32
You need to log in before you can comment on or make changes to this bug.