Stylus files show up blank in the style editor

RESOLVED FIXED in Firefox 34

Status

defect
RESOLVED FIXED
5 years ago
Last year

People

(Reporter: harth, Assigned: harth)

Tracking

unspecified
Firefox 35

Firefox Tracking Flags

(firefox32 wontfix, firefox33 wontfix, firefox34 fixed, firefox35 fixed, firefox-esr31 wontfix)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Assignee

Description

5 years ago
STR:

1) Enable "Show original sources" in the Style Editor
2) Open a page using a Stylus source
3) Open Style Editor

The stylus source in the editor is blank, where it should contain the text of the file.
Assignee

Comment 1

5 years ago
We're trying to prettify Stylus sources which don't use CSS-like syntax. This patch fixes that and also adds a test and fixes another one.
Assignee: nobody → fayearthur
Attachment #8499509 - Flags: review?(pbrosset)
Assignee

Comment 2

5 years ago
Whoops, had to remove a couple commented-out lines.
Attachment #8499509 - Attachment is obsolete: true
Attachment #8499509 - Flags: review?(pbrosset)
Attachment #8499514 - Flags: review?(pbrosset)
Comment on attachment 8499514 [details] [diff] [review]
Don't prettify original sources in the style editor

Review of attachment 8499514 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM
Attachment #8499514 - Flags: review?(pbrosset) → review+
Assignee

Updated

5 years ago
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/ce042529cac3
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 35
Assignee

Comment 7

5 years ago
Comment on attachment 8499514 [details] [diff] [review]
Don't prettify original sources in the style editor

Approval Request Comment
[Feature/regressing bug #]:
bug 926014

[User impact if declined]:
Users of the Stylus CSS pre-processing language will see blank files in the Style Editor, rendering the tool useless for editing their sources.

[Describe test coverage new/current, TBPL]:
Has test, in mozilla-central for a couple days.

[Risks and why]:
None known

[String/UUID change made/needed]:
None
Attachment #8499514 - Flags: approval-mozilla-aurora?
Comment on attachment 8499514 [details] [diff] [review]
Don't prettify original sources in the style editor

This is pretty old dating back to Firefox 29. How come we didn't hear about this sooner?

Aurora+
Attachment #8499514 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Assignee

Comment 9

5 years ago
(In reply to Lawrence Mandel [:lmandel] from comment #8)
> This is pretty old dating back to Firefox 29. How come we didn't hear about
> this sooner?
> 
> Aurora+

Thanks! The reason is that Stylus didn't generate source maps until a month ago. I was contacted on twitter shortly afterwards.
Assignee

Updated

5 years ago
Duplicate of this bug: 1004573

Updated

Last year
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.