location bar autocomplete does not show list of matching results

VERIFIED FIXED in mozilla0.9.6

Status

SeaMonkey
Autocomplete
P1
major
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: Phil Pishioneri, Assigned: dbaron)

Tracking

({regression})

Trunk
mozilla0.9.6
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
I have autocomplete enabled to "Show list of matching results", but
I'm not longer getting the drop down list.

Build is 2001103021 on linux.  The (immediately?) previous build
of 2001103012 did not have this problem.

Deleting my XUL.mfasl file did not help.  I tried toggling the
options a few times, no change.  The pref for "autocomplete best
match as you type" still appears to work.

I'm not seeing any errors on Mozilla's console or in the javascript
console window.

Comment 1

17 years ago
Confirming the bug on Linux 2001103021. You can get the autocompleted URL into
the URL bar by pressing the DOWN key but the autocomplete select dropdown never
appears automatically. (If you press the button for drop down it appears but it
has a different content.)
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: mozilla0.9.6, regression

Comment 2

17 years ago
changing platform and OS to all

seen on commercial builds:

windows 2001-10-31-03-trunk
linux 2001-10-31-06-trunk
mac 2001-10-31-04-trunk
OS: Linux → All
Hardware: PC → All

Updated

17 years ago
Status: NEW → ASSIGNED
Priority: -- → P1
Target Milestone: --- → mozilla0.9.6

Comment 3

17 years ago
*** Bug 107912 has been marked as a duplicate of this bug. ***

Comment 4

17 years ago
Probably not helpful, but I've noticed, sometimes the search part of the
dropdown comes up, but only for a second, and it just disapears. Seems random as
to the few times when it does come up for that second.
*** Bug 108020 has been marked as a duplicate of this bug. ***

Comment 6

17 years ago
Press a char not in the a-z 0-9 range and the search autocomplete bar shows up.
still no location autocomplete

Comment 7

17 years ago
dbaron has a fix for this

Comment 8

17 years ago
--> dbaron
Assignee: hewitt → dbaron
Status: ASSIGNED → NEW

Comment 10

17 years ago
Comment on attachment 56181 [details] [diff] [review]
patch

sr=hyatt
Attachment #56181 - Flags: superreview+

Comment 11

17 years ago
XXX Comment-worthy? r=waterson
(Assignee)

Comment 12

17 years ago
Fix checked in 2001-11-01 20:14 PDT.

For the record, this was a regression due to the patch on bug 107534.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 13

17 years ago
Fix is working in Linux build 2001110121.  Thanks!

Comment 14

17 years ago
Verified on recent builds
However, this patch or other patches made a regression, icons in search
autocomplete are gone. Filed bug 108184 to cover this
Status: RESOLVED → VERIFIED

Comment 15

17 years ago
Mozilla keeps forgetting my links in the urlbar
This behaviour was appearing on builds dated 2 weeks ago, while builds this week
definitely broke this and later was "fixed"
Bug 108281 was filed
No longer blocks: 104864
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.