animation of CSS transform: rotateX() shakes as it crosses rotation of 0

RESOLVED FIXED in Firefox 34

Status

()

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: maciek, Assigned: mstange)

Tracking

({regression})

32 Branch
mozilla36
x86_64
Windows 8
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox32 wontfix, firefox33- wontfix, firefox34+ fixed, firefox35+ fixed, firefox36+ fixed, b2g-v2.0 wontfix, b2g-v2.0M wontfix, b2g-v2.1 fixed, b2g-v2.2 fixed)

Details

Attachments

(3 attachments)

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140923175406

Steps to reproduce:

Here is all described http://stackoverflow.com/questions/25995581/firefox-32-0-2-transform-issue Problem is transform -> rotateX between -0.5deg and 0.5deg, here is result http://jsfiddle.net/hdxoo9wy/1/
It is new bug, last version (i guess 31) was working correctly.


Actual results:

rotation between -0.5deg and 0.5deg gives random effect and when animation has this range - it shakes.


Expected results:

Best result would be working as in ff 31 version.
Posted file 1078262.html
Reg range:
good=2014-05-13
bad=2014-05-14
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4b6d63b05a0a&tochange=2f8af55d6e9a

My guess goes to one of patches from bug 1008917.
Status: UNCONFIRMED → NEW
Component: Untriaged → Layout
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
(In reply to Loic from comment #2)
> http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4b6d63b05a0a&tochange=2f8af55d6e9a
> 
> My guess goes to one of patches from bug 1008917.

Seems unlikely.

I think the most likely is https://hg.mozilla.org/mozilla-central/rev/22b09f1086f9
Blocks: 1009020
Flags: needinfo?(mstange)
Summary: Recent firefox transform issue → animation of CSS transform: rotate() shakes as it crosses rotation of 0
Regression window(m-i)
Good:
https://hg.mozilla.org/integration/mozilla-inbound/rev/971b840c40ff
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0 ID:20140513042856
Bad:
https://hg.mozilla.org/integration/mozilla-inbound/rev/35af5d1c97c3
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0 ID:20140513043857
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=971b840c40ff&tochange=35af5d1c97c3

Suspect: Bug 1009020
Summary: animation of CSS transform: rotate() shakes as it crosses rotation of 0 → animation of CSS transform: rotateX() shakes as it crosses rotation of 0
I've confirmed that this was caused by bug 1009020.
Assignee: nobody → mstange
Status: NEW → ASSIGNED
Flags: needinfo?(mstange)
Comment on attachment 8504661 [details] [diff] [review]
Only use the fixed epsilon for the translation components

Review of attachment 8504661 [details] [diff] [review]:
-----------------------------------------------------------------

::: layout/reftests/bugs/1078262-1.html
@@ +25,5 @@
> +}
> +@keyframes active-rotation {
> +  from { transform: rotateX(10.01deg);}
> +  to { transform: rotateX(10.00deg);}
> +}  

trailing whitespace
Attachment #8504661 - Flags: review?(roc) → review+
https://hg.mozilla.org/mozilla-central/rev/60ff91674d5d
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
Duplicate of this bug: 1084253
Duplicate of this bug: 1064191
34 and 35 are marked as affected. This fix has now been on m-c for 6 days. Do you think this can be uplifted to Beta and Aurora?
Flags: needinfo?(mstange)
Comment on attachment 8504661 [details] [diff] [review]
Only use the fixed epsilon for the translation components

Approval Request Comment
[Feature/regressing bug #]: bug 1009020
[User impact if declined]: shaky animations
[Describe test coverage new/current, TBPL]: reftest included
[Risks and why]: fairly low
[String/UUID change made/needed]: none
Flags: needinfo?(mstange)
Attachment #8504661 - Flags: approval-mozilla-beta?
Attachment #8504661 - Flags: approval-mozilla-aurora?
Comment on attachment 8504661 [details] [diff] [review]
Only use the fixed epsilon for the translation components

Aurora+

I'm going to go ahead and assume that the Beta approval should be on the patch for beta instead of this patch.
Attachment #8504661 - Flags: approval-mozilla-beta?
Attachment #8504661 - Flags: approval-mozilla-aurora?
Attachment #8504661 - Flags: approval-mozilla-aurora+
Comment on attachment 8510981 [details] [diff] [review]
patch for Beta

Beta+
Attachment #8510981 - Flags: approval-mozilla-beta+
QA Whiteboard: [good first verify]
Blocks: 1097776
No longer blocks: 1097776
You need to log in before you can comment on or make changes to this bug.