[Usage][Cost Control] In Usage app - Hide Apps from Mobile Data Usage list if they use 0 data

VERIFIED FIXED in 2.1 S6 (10oct)

Status

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: kcaldwell, Assigned: justindarc)

Tracking

unspecified
2.1 S6 (10oct)
x86
macOS
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

Details

(Whiteboard: interaction-design)

Attachments

(1 attachment)

Reporter

Description

5 years ago
Only show apps (that use data) in Usage app / Mobile App Usage list. 

UX Rationale:
Showing apps that use 0 data creates confusion for the user (why are you showing me this? Will this app use data later?). We want to help the user understand their data usage behaviours without adding complexity to their experience.

UX Recommendation:
Hide apps that use 0 data (remove complexity and confusion).
[Blocking Requested - why for this release]: In the current state, the usage per app breakdown is currently flooded with many apps including hidden ones (which don't even have icons) which don't use any data.  This experience is incredibly poor.  
I realize this is very late for such a change, but if we don't make this change, I don't think we can ship as it is.
blocking-b2g: --- → 2.1?
Assignee

Updated

5 years ago
Assignee: nobody → jdarcangelo

Comment 2

5 years ago
Lets use this bug only to track the "User experience issue in showing apps with zero data consumption".  

Blocking Reason: Very poor user experience

Justin/Marshall,

Lets look into low risk fix (that does not have localization impact) for 2.1 to address this blocker.  

Peter/Katie, please open another bug for hidden apps case that consume data and provide ux recommendation on how we want to show that to the user in a way that does not cause any further ux confusion.
(In reply to Hema Koka [:hema] from comment #2)
> Peter/Katie, please open another bug for hidden apps case that consume data
> and provide ux recommendation on how we want to show that to the user in a
> way that does not cause any further ux confusion.

To clarify, "hidden apps" are those apps listed that the user has no understanding of (e.g.: OperatorVariant, FTU, etc.). We should use a separate bug to track the blacklisting of those specific apps we want to permanently hide from this list.
Comms triage: Really late for this new feature in 2.1, please ask for approval.
blocking-b2g: 2.1? → -
Attachment #8501141 - Flags: review?(marshall)
Comment on attachment 8501141 [details] [review]
pull-request (master)

Also adding Salva as a possible reviewer since Marshall may be too busy to review at the moment.
Attachment #8501141 - Flags: review?(salva)
Attachment #8501141 - Flags: review?(marshall) → review+
Could you please seek approval after landing on master?
Flags: needinfo?(jdarcangelo)
Assignee

Updated

5 years ago
Attachment #8501141 - Flags: review?(salva)
Flags: needinfo?(jdarcangelo)
Landed on master:

https://github.com/mozilla-b2g/gaia/commit/802f4accbbbba735725be380d5e72fe225467ba9
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
[Blocking Requested - why for this release]:

Re-noming as per Comment 1.
blocking-b2g: - → 2.1?
Comment on attachment 8501141 [details] [review]
pull-request (master)

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): none
[User impact] if declined: User can get confused by seeing tons of apps listed with 0 bytes of data usage
[Testing completed]: Tested on Flame-v184
[Risk to taking this patch] (and alternatives if risky): low/none
[String changes made]: none
Attachment #8501141 - Flags: approval-gaia-v2.1?(fabrice)
triage: this will prevent bug 1071270 to happen
blocking-b2g: 2.1? → 2.1+
Why is this commit not including new tests?
There is no infrastructure for testing the data usage UI, I filed bug 1079754 as a follow-up to not only add tests for this flow but for covering all data usage UI.
Attachment #8501141 - Flags: approval-gaia-v2.1?(fabrice) → approval-gaia-v2.1+
Fix verified on Flame 2.2 and Flame 2.1
Actual result: The Mobile App Usage section in the Usage app is no longer filled with applications that have taken 0.0 B of mobile data.

Flame 2.2
BuildID: 20141014040203
Gaia: 4f86c631e0465c0e56ccebeb1324fd28be9ea32f
Gecko: 54217864bae9
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Platform Version: 36.0a1
Firmware Version: V180
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Flame 2.1
BuildID: 20141013001201
Gaia: d18e130216cd3960cd327179364d9f71e42debda
Gecko: 610ee0e6a776
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Platform Version: 34.0a2
Firmware Version: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Reporter

Comment 16

5 years ago
(In reply to Justin D'Arcangelo [:justindarc] from comment #3)
> (In reply to Hema Koka [:hema] from comment #2)
> > Peter/Katie, please open another bug for hidden apps case that consume data
> > and provide ux recommendation on how we want to show that to the user in a
> > way that does not cause any further ux confusion.
> 
> To clarify, "hidden apps" are those apps listed that the user has no
> understanding of (e.g.: OperatorVariant, FTU, etc.). We should use a
> separate bug to track the blacklisting of those specific apps we want to
> permanently hide from this list.

[ bug opened for hidden apps : Bug 1079609 ]
You need to log in before you can comment on or make changes to this bug.