If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

URL becomes `about:preferences#` when Preferences is loaded more than once

VERIFIED FIXED in Firefox 43

Status

()

Firefox
Preferences
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: cvan, Assigned: Nikhil Gupta, Mentored)

Tracking

(Blocks: 1 bug)

Trunk
Firefox 43
Points:
---

Firefox Tracking Flags

(firefox39 affected, firefox41 affected, firefox42 affected, firefox43 verified)

Details

(Whiteboard: [lang=js][good first bug], URL)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
1. Load Firefox Nightly 35.0a1 (2014-10-03) on Mac OS X.
2. From the window options select Nightly > Preferences.
3. Notice the Preferences pane loads and the URL in the address bar is `about:preferences`.
4. Go to a different tab.
5. Open the Preferences again (step #2).
6. Notice the Preferences tab regains focus but the URL in the address is now `about:preferences#` (notice the trailing hash).
Not sure if this is a 'bug' on itsel, but if so, it blocks https://bugzilla.mozilla.org/show_bug.cgi?id=1182769

alex, what do you think, is this a bug?
Blocks: 1182769
Flags: needinfo?(alex_mayorga)
No longer blocks: 1182769

Comment 2

2 years ago
(In reply to Mauricio Navarro Miranda from comment #1)
> Not sure if this is a 'bug' on itsel, but if so, it blocks
> https://bugzilla.mozilla.org/show_bug.cgi?id=1182769
> 
> alex, what do you think, is this a bug?

¡Hola!

I honestly do not know.

Jared could you please asses this bug report?

¡Gracias!
Blocks: 718011
QA Whiteboard: mozLATAM
status-firefox39: --- → affected
status-firefox41: --- → affected
status-firefox42: --- → affected
Flags: needinfo?(alex_mayorga) → needinfo?(jaws)
OS: Mac OS X → All
Hardware: x86 → All
Version: unspecified → Trunk
Yeah, it doesn't seem necessary to change the hash. I think this is just a corner case that isn't caught in our hashchange code.
Mentor: jaws@mozilla.com
Flags: needinfo?(jaws)
Whiteboard: [lang=js][good first bug]
(Assignee)

Comment 4

2 years ago
Can I work on this bug? I'm new on Bugzilla.
Yes, go ahead :)

We usually wait to assign the bug to an individual until a patch is uploaded.
(Assignee)

Comment 6

2 years ago
Created attachment 8657689 [details] [diff] [review]
bug1078705_hashchange.diff
Attachment #8657689 - Flags: review?(jaws)
Created attachment 8658320 [details] [diff] [review]
Test changes
Attachment #8658320 - Flags: review?(dao)
Assignee: nobody → nanonikhil
Status: NEW → ASSIGNED
Comment on attachment 8657689 [details] [diff] [review]
bug1078705_hashchange.diff

Review of attachment 8657689 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks! I added another case to the test to make sure that this doesn't regress in the future.
Attachment #8657689 - Flags: review?(jaws) → review+

Updated

2 years ago
Attachment #8658320 - Flags: review?(dao) → review+
url:        https://hg.mozilla.org/integration/fx-team/rev/c02888af0ecb02bdfbee0be464079dafcc35e49b
changeset:  c02888af0ecb02bdfbee0be464079dafcc35e49b
user:       Nikhil <nanonikhil@gmail.com>
date:       Tue Sep 08 15:20:39 2015 -0400
description:
Bug 1078705 - Removed the # which appears when opening preferences more than once. r=jaws,dao
https://hg.mozilla.org/mozilla-central/rev/c02888af0ecb
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox43: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 43

Comment 11

2 years ago
¡Hola!

Verified on Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:43.0) Gecko/20100101 Firefox/43.0 ID:20150909030223 CSet: 01ae99b53561a2c3b40533d8c1c92bd3efc42d00

¡Gracias Nikhil!
Status: RESOLVED → VERIFIED
QA Whiteboard: mozLATAM → mozLATAM [good first verify]

Comment 12

2 years ago
Successfully reproduce the bug on 
Name 	Firefox
Version 	42.0
Build ID 	20151029151421
User Agent 	Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:42.0) Gecko/20100101 Firefox/42.0

The fix works for me on 
Name 	Firefox
Version 	43.0b4
Build ID 	20151116155110
User Agent 	Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:43.0) Gecko/20100101 Firefox/43.0
QA Whiteboard: mozLATAM [good first verify] → mozLATAM [good first verify][bugday-20151118]
I have reproduced this bug on Nightly 35.0a1 (2014-10-06) on Windows 7, 64 Bit!

This Bug's fix is now verified on Latest Firefox 43.0 Beta 4!

Build ID 	20151116155110
User Agent 	Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
status-firefox43: fixed → verified
You need to log in before you can comment on or make changes to this bug.