Closed Bug 1079795 Opened 7 years ago Closed 7 years ago

[woodduck][Comms][Contacts][Rose][Soul35]We tap "Cancel" when contacts are deleting,all contacts are checked,but the "Contacts"is displayed in title.(5/5)

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
2.1 S7 (24Oct)

People

(Reporter: jocheng, Assigned: jmcf, Mentored)

References

Details

(Whiteboard: [good-first-bug][p=3])

Attachments

(2 files)

46 bytes, text/x-github-pull-request
jmcf
: review-
Details | Review
191 bytes, text/html
arcturus
: review+
Details
+++ This bug was initially created as a clone of Bug #1070453 +++

ALPS01732304
[Initial condition]
1. SIM information:
   SIM1 :CMCC 3G.
   SIM2:CU 3G
2. Data connection:Off.   
3. Issue happen time: 2014-09-18 12:52PM
4. There are some contacts
5. Device language is English



[step]
1. Launch Contacts
2. Tap settings icon->tap "Delete Contacts"
** When contacts do not check,"Contacts"display in title
See 3.png
3. Tap "Select all"
** It display "XX selected"in title
See 3-1.png
4. Tap "Delete"->tap "Delete"
5. Tap "Cancel"
6. Check UI

[Expected Result]
It should display "XX selected"in title,or all contacts should not check.

[Error]
All contacts are checked,but the "Contacts"is displayed in title.


This issue caused by :
contacts/js/views/list.js
  var selectAction = function selectAction(action) {
    updateSelectCount(0);

when delete button pressed, updateSelectCount(0) will be called,
and user cancle, not updateSelectCount.

thanks!
Duplicate of this bug: 1070453
Mentor: francisco, sergi.mansilla
Whiteboard: [good-first-bug]
it seems to be pretty easy to be solved. Let's keep it open for contributors and if nobody fixes I can do it
Assignee: nobody → jmcf
Target Milestone: --- → 2.1 S7 (Oct24)
Whiteboard: [good-first-bug] → [good-first-bug][p=3]
Carrie,

We need your input here. To my mind if the bulk delete process is interrupted by the user the next screen to be showed should be the contacts list and not the 'contacts selection' screen. 

Please let us know

thanks!
Flags: needinfo?(cawang)
Hi Jose, 

I've checked the behavior in other APPs. On our system, if users tap "cancel" on the confirm window, the confirm window will be closed and they will be sent back to the previous step, which is the selection mode with selected items displayed. So in this case, we shall show "XX selected" on title. Thanks!
Flags: needinfo?(cawang)
Assignee: jmcf → mri
Attached file patch v1.0
Hi Jose,
would you mind review the patch?
Regards
Attachment #8506003 - Flags: review?(jmcf)
Comment on attachment 8506003 [details] [review]
patch v1.0

once we cancel we need to update the title to reflect the new number of selected contacts
Attachment #8506003 - Flags: review?(jmcf) → review-
Carrie,

We need to reconsider the flow. The rationale is, if while deleting the action is canceled, then I think the simplest and harmless thing is to come back to the contacts list. 

As a result the user will see an updated contact list in which all the deleted contacts (till that moment) will have dissappeared. Staying at the contacts selection screen will imply that we will need to rebuild the selection list and update it to show only those contacts that remain on the device (it is not only a matter of change the title :) ). Otherwise we will be showing an outdated list which will be harmful for the user. Furthermore, we would need to check / uncheck depending on what was deleted or not. A mess.  

So my proposal is to go back to the contacts list, as it happens with other similar actions in contacts, such as the importations from the different sources. 

Please let us know if you agree with my proposal
Flags: needinfo?(cawang)
Hi Jose,

We've discussed this on IRC, and yes, now I agree with you on comment 7 that we shall get back to the updated contacts list. Sorry for the misunderstanding. Thanks!
Flags: needinfo?(cawang)
Attached file 25174.html
Attachment #8506797 - Flags: review?(francisco)
Assignee: mri → jmcf
Comment on attachment 8506797 [details]
25174.html

Simple fix nice!

Retriggered some jobs in gaia-try please merge once green.
Attachment #8506797 - Flags: review?(francisco) → review+
https://github.com/mozilla-b2g/gaia/commit/58823c3b1d3cdecfd51e46ceaae4e1d4ebbfa6ae
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.