Closed Bug 1080059 Opened 6 years ago Closed 6 years ago

###!!! ASSERTION: QueryInterface needed: 'query_result.get() == mRawPtr', file ../../dist/include/nsCOMPtr.h, line 532

Categories

(Firefox OS Graveyard :: RIL, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 fixed)

RESOLVED FIXED
2.1 S6 (10oct)
blocking-b2g 2.2+
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.2 --- fixed

People

(Reporter: khuey, Assigned: khuey)

References

Details

(Keywords: assertion, regression)

Attachments

(2 files)

Attached file Stack
This assertion means that the nsIIccInfo pointer passed to IccInfo::Update is not the same pointer that is returned when that it is QueryInterface()d to nsIIccInfo.
Attached patch PatchSplinter Review
Assignee: nobody → khuey
Status: NEW → ASSIGNED
Attachment #8501967 - Flags: review?(echen)
Comment on attachment 8501967 [details] [diff] [review]
Patch

Review of attachment 8501967 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for catching this. :)
Attachment #8501967 - Flags: review?(echen) → review+
https://hg.mozilla.org/mozilla-central/rev/b418ec650903
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S6 (10oct)
Unable to verify as this is a back-end issue.
QA Whiteboard: [QAnalyst-Triage?], [QAnalyst-verify-]
Flags: needinfo?(ktucker)
Please ignore comment 5. Unable to verify this here because no repro steps are provided- this appears to be a crash that was encountered during automation.
QA Whiteboard: [QAnalyst-Triage?], [QAnalyst-verify-] → [QAnalyst-Triage+], [QAnalyst-verify-]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.