Switch win64 builds to MSVC2013

RESOLVED FIXED in mozilla35

Status

Firefox Build System
General
RESOLVED FIXED
4 years ago
5 months ago

People

(Reporter: Benjamin Smedberg, Assigned: dmajor)

Tracking

unspecified
mozilla35
x86_64
Linux
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Our nightly win64 builds are currently built using MSVC2012. We should switch them to MSVC2013. Since they are currently not riding the trains, I think we could do this immediately, or any time you are comfortable.

dmajor can you prepare the mozconfig changes for this?
(Assignee)

Comment 1

4 years ago
Yes, this sounds reasonable. It will also be a good practice run for the win32 change.

> Our nightly win64 builds are currently built using MSVC2012.
2010, right? Unless I'm missing something...
(Reporter)

Comment 2

4 years ago
I thought the win64 builds were 2012, but I can't remember why.
(Assignee)

Comment 3

4 years ago
Did a sanity test to make sure the build system doesn't mind having mixed mozconfigs: 
https://tbpl.mozilla.org/?tree=Try&rev=25b5cac50fe5
See Also: → bug 1061335
(Assignee)

Comment 4

4 years ago
Created attachment 8502261 [details] [diff] [review]
Switch Win64 builders to VS2013

Carrying forward r=glandium since this was split off of bug 1061335.

Bug 1080297 is a last-minute regression that will need to be fixed before this can go in. (It's in the dependency tree somewhere, so I didn't bother adding it separately to this bug)

bsmedberg, is there anything else that I need to wait on before pushing?
Attachment #8502261 - Flags: superreview?(benjamin)
Attachment #8502261 - Flags: review+
(Assignee)

Updated

4 years ago
Attachment #8502261 - Attachment description: vs3builders64 → Switch Win64 builders to VS2013
(Reporter)

Updated

4 years ago
Attachment #8502261 - Flags: superreview?(benjamin) → superreview+
https://hg.mozilla.org/mozilla-central/rev/3989c98e664c
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
(Assignee)

Comment 8

4 years ago
Sanity checks:

ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014/10/2014-10-11-03-02-03-mozilla-central/
The Win64 build log says: Microsoft (R) C/C++ Optimizing Compiler Version 18.00.30723 for x64
And the zip package contains msvcr120.dll/msvcp120.dll.

I installed the previous (VC10) Win64 nightly on a machine with no VC12 CRT, let it update, and confirmed that I get the new CRT and the new nightly loads without problems.

Updated

5 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.