Status

defect
RESOLVED FIXED
5 years ago
Last year

People

(Reporter: dmajor, Unassigned)

Tracking

Trunk
mozilla36
x86_64
Windows 7
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 2 obsolete attachments)

Reporter

Description

5 years ago
Thanks to jlund for the original patch. I've split it apart so that we can get the supporting pieces into the tree before actually flipping the switch.
Reporter

Comment 3

5 years ago
Part 2 is actually an |hg cp| with changes on top (Bugzilla doesn't show this very well).
Attachment #8482421 - Flags: review?(mh+mozilla) → review+
Attachment #8482422 - Flags: review?(mh+mozilla) → review+
Comment on attachment 8482423 [details] [diff] [review]
Part 3: Switch in-tree mozconfigs to VS2013 (DON'T LAND YET)

Review of attachment 8482423 [details] [diff] [review]:
-----------------------------------------------------------------

::: b2g/config/mozconfigs/win32_gecko/debug
@@ +19,2 @@
>  else
>    . $topsrcdir/build/win32/mozconfig.vs2010

Why not change this too?
Reporter

Comment 6

5 years ago
(In reply to Mike Hommey [:glandium] (out from Sep 6 to Sep 22) from comment #5)
> Comment on attachment 8482423 [details] [diff] [review]
> Part 3: Switch in-tree mozconfigs to VS2013 (DON'T LAND YET)
> 
> Review of attachment 8482423 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> ::: b2g/config/mozconfigs/win32_gecko/debug
> @@ +19,2 @@
> >  else
> >    . $topsrcdir/build/win32/mozconfig.vs2010
> 
> Why not change this too?

I wondered the same thing over in bug 1009807. Apparently we don't use win32 builders anymore. Those lines might be for Seamonkey.
Reporter

Updated

5 years ago
Attachment #8482421 - Flags: checkin+
Reporter

Updated

5 years ago
Attachment #8482422 - Flags: checkin+
ah cool, hopefully that makes it easier to do quick tests on try.

I'm in the middle of trying to clear up some points of confusion: namely win regressions and varying vs2013 versions

I'm sending out an email right now to folks from build, relops, and sheriffs. But until we have a unified understanding and plan going forward, could we hold off on actually pulling the trigger on this?
Reporter

Comment 10

5 years ago
> But until we have a unified understanding and plan going forward,
> could we hold off on actually pulling the trigger on this?

Yes, I agree. I'm not planning to push the final piece until we're completely ready.
Reporter

Comment 11

5 years ago
Comment on attachment 8482423 [details] [diff] [review]
Part 3: Switch in-tree mozconfigs to VS2013 (DON'T LAND YET)

I'm flagging this since glandium will be away for a while. I'm not planning to land it yet.
Attachment #8482423 - Flags: review?(mh+mozilla)
Attachment #8482423 - Flags: review?(mh+mozilla) → review+
Reporter

Comment 12

5 years ago
compare-mozconfigs.py pointed out that I missed one under Win64.

Carrying forward r=glandium.
Attachment #8482423 - Attachment is obsolete: true
Attachment #8501531 - Flags: review+
Reporter

Updated

5 years ago
See Also: → 1080074
Reporter

Comment 13

5 years ago
Removed the Win64 mozconfigs as they have been landed in bug 1080074. Carrying forward r=glandium from previous patch. sr=bsmedberg by IRC.

Try: https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=704087ef0991
PGO: https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=df44e744f079
Bn: https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=77258e23750e
Attachment #8501531 - Attachment is obsolete: true
Attachment #8504375 - Flags: superreview+
Attachment #8504375 - Flags: review+
Forgot to remove leave-open?
Flash videos stopped working with this patch based on some regression testing I did. I'm running the latest Flash beta 15.0.0.199.

 Mozilla/5.0 (Windows NT 6.3; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0

Updated

5 years ago
Depends on: 1082670
Reporter

Comment 20

5 years ago
> Forgot to remove leave-open?
Good catch.
Status: NEW → RESOLVED
Closed: 5 years ago
Keywords: leave-open
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
Reporter

Updated

5 years ago
Attachment #8504375 - Flags: checkin+
Depends on: 1084462

Updated

4 years ago
Depends on: 1138070

Updated

Last year
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.