Save file dialog doesn't initially enable saving

VERIFIED DUPLICATE of bug 98480

Status

Core Graveyard
File Handling
VERIFIED DUPLICATE of bug 98480
17 years ago
2 years ago

People

(Reporter: Preston Crow, Assigned: Brian Ryner (not reading))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
When downloading a file, the save file dialog first asks where to save the file.
 Normally, the filename is filled in to some reasonable default, and the
directory is set to the last directory to which something was downloaded. 
However, the "save" button is greyed out and useless.

Interestingly, if you change directories, the save button will then work. 
Hence, if I click on a subdirectory and then on the parent directory, I can save
just as I would have expected to be able to initially.

In case it is relevant, my window manager is twm.  I am not running Gnome or KDE.

Comment 1

17 years ago
please report detailed info to reproduce. Build ID, URL, directory path.
(Reporter)

Comment 2

17 years ago
Build ID: 2001110108
OS: Linux
Window Manager: twm
Desktop Manager: none

shift-click on any URL that doesn't end in a /, so that there is a default file
name (such as http://bugzilla.mozilla.org/votehelp.html above).

My default directory is my home directory.  Everything looks normal, except that
the Save button is greyed out.

If that doesn't do the same thing for you, then try doing it with no window
manager.  If that makes a difference, then it's probably related to bugs 78928
and 76854.

Comment 3

17 years ago
Possibly referring to the fact that the save button doesn't
enable itself until you click in the filename field, even if
a default filename is given.  I see this on Linux,
but not on Windows (probably because on Windows the default save
chooser is used).  As soon as you click on the filename field
though the button enables itself and you can save as normal.

Comment 4

17 years ago
->bryner

Brian, this looks to be a Linux filepicker thing.  Maybe fixed now?
Assignee: law → bryner
(Assignee)

Comment 5

17 years ago
sounds like the case where the window isn't getting focused (still haven't
figured out why that is happening)


*** This bug has been marked as a duplicate of 98480 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.