Disable win8-32 testing and enable win8-64 testing

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
5 months ago

People

(Reporter: catlee, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(7 attachments)

(Reporter)

Description

4 years ago
In order to have enough testing capacity for 64-bit windows, we need to disable some existing tests.

The best option we have right now is to disable 32-bit win8 tests. We can then use the win8 machines for testing 64-bit windows builds on trunk branches.

We'll need to keep release branches with 32-bit win8 tests enabled for the meanwhile.
(Reporter)

Comment 1

4 years ago
Created attachment 8503330 [details] [diff] [review]
disables vm tests; enables talos

step 1 - let's get date close to what we want the rest of the branches to look like.

Builders added:
+ win8_64 date talos chromez
+ win8_64 date talos dromaeojs
+ win8_64 date talos g1
+ win8_64 date talos other_nol64
+ win8_64 date talos svgr
+ win8_64 date talos tp5o
Builders removed
- win64_vm date debug test cppunit
- win64_vm date debug test crashtest
- win64_vm date debug test jetpack
- win64_vm date debug test jittest
- win64_vm date debug test jsreftest
- win64_vm date debug test mochitest-1
- win64_vm date debug test mochitest-2
- win64_vm date debug test mochitest-3
- win64_vm date debug test mochitest-4
- win64_vm date debug test mochitest-5
- win64_vm date debug test mochitest-browser-chrome-1
- win64_vm date debug test mochitest-browser-chrome-2
- win64_vm date debug test mochitest-browser-chrome-3
- win64_vm date debug test mochitest-devtools-chrome-1
- win64_vm date debug test mochitest-devtools-chrome-2
- win64_vm date debug test mochitest-devtools-chrome-3
- win64_vm date debug test mochitest-other
- win64_vm date debug test reftest
- win64_vm date debug test xpcshell
- win64_vm date opt test cppunit
- win64_vm date opt test crashtest
- win64_vm date opt test jetpack
- win64_vm date opt test jittest
- win64_vm date opt test jsreftest
- win64_vm date opt test mochitest-1
- win64_vm date opt test mochitest-2
- win64_vm date opt test mochitest-3
- win64_vm date opt test mochitest-4
- win64_vm date opt test mochitest-5
- win64_vm date opt test mochitest-browser-chrome-1
- win64_vm date opt test mochitest-browser-chrome-2
- win64_vm date opt test mochitest-browser-chrome-3
- win64_vm date opt test mochitest-devtools-chrome
- win64_vm date opt test mochitest-other
- win64_vm date opt test reftest
- win64_vm date opt test reftest-no-accel
- win64_vm date opt test xpcshell
Attachment #8503330 - Flags: review?(rail)
Comment on attachment 8503330 [details] [diff] [review]
disables vm tests; enables talos

lgtm
Attachment #8503330 - Flags: review?(rail) → review+
(Reporter)

Updated

4 years ago
Attachment #8503330 - Flags: checked-in+
Checked in code landed in production

Comment 4

4 years ago
There are some DB entries for the win8 64 vms:
https://secure.pub.build.mozilla.org/buildapi/revision/date/ed32730dc8e1
(Reporter)

Updated

4 years ago
Depends on: 1081799
(Reporter)

Comment 5

4 years ago
Created attachment 8505518 [details] [diff] [review]
disable 32-bit win8 testing

The default {talos_,}slave_platforms for win32 are ['xp-ix', 'win7-ix', 'win8'].

We need to remove win8 from the list of slave platforms for win32 and add 'win8_64' to the list of slave platforms for win64.

I think this patch gets us to the desired goal on the date branch. If it looks good on date, then we can change these settings for the other branches.

The 'enable_talos' flag here is useless, so I removed it.
Attachment #8505518 - Flags: review?(rail)
Attachment #8505518 - Flags: review?(rail) → review+
(Reporter)

Updated

4 years ago
Attachment #8505518 - Flags: checked-in+
Merged to production, and deployed.
(Reporter)

Comment 7

4 years ago
Created attachment 8506041 [details] [diff] [review]
remove unneeded code

this code doesn't do anything now that we switched to mozharness
Attachment #8506041 - Flags: review?(rail)
(Reporter)

Comment 8

4 years ago
Created attachment 8506043 [details] [diff] [review]
stop win64 sendchange from win32 builds.

this will stop triggering tests of the 32-bit builds on the 64-bit win8 machines.
Attachment #8506043 - Flags: review?(rail)
Attachment #8506041 - Flags: review?(rail) → review+
Attachment #8506043 - Flags: review?(rail) → review+
(Reporter)

Updated

4 years ago
Attachment #8506043 - Flags: checked-in+
(Reporter)

Updated

4 years ago
Attachment #8506041 - Flags: checked-in+

Comment 11

4 years ago
Is win8_64 going to be the final platform name for the buildername? (instead of "Windows 8 64-bit")
I have to adjust titanic to accept this different platform name.
Sure hope so since we already landed TPBL/TH patches under that assumption.
(Reporter)

Comment 13

4 years ago
I'm not sure. The other options I can think of are:
"WINNT 6.2 64-bit"
"WINNT 6.2 x64"

some previous examples:
"WINNT 6.2" - our current 32-bit win8 tests, which are going away
"Windows 7 32-bit" - for our current 32-bit win7 tests, which aren't changing
"Ubuntu VM 12.04 x64" - for 64-bit linux tests
"Ubuntu VM 12.04" - for 32-bit linux tests

Yay consistency.
*If* we end up changing them, I think "Windows 8 64-bit" makes the most sense. But given that our names are already an inconsistent mess and our tools are already looking for the current names, I'm not sure if it's really worth the effort either.

Comment 15

4 years ago
I would be happier if at least within the three Windows platforms we had consistency.

A while back when I added the iX batch of machines we started using "Windows {7|xp} {$arch}-bit".
I think Win8 arrived first to the iX machines and we kept the original WINNT X.Y format.

Could we please move to Windows 8 64-bit to make the Windows flavors consistent?

Comment 16

4 years ago
Created attachment 8507199 [details] [diff] [review]
rename_win8_64.diff
Attachment #8507199 - Flags: review?(catlee)
Attachment #8507199 - Flags: feedback?(ryanvm)
Comment on attachment 8507199 [details] [diff] [review]
rename_win8_64.diff

Review of attachment 8507199 [details] [diff] [review]:
-----------------------------------------------------------------

Please file TBPL and TH bugs for supporting this change. Definitely better to make it now while they're still running on Date, though.
Attachment #8507199 - Flags: feedback?(ryanvm) → feedback+

Comment 18

4 years ago
Great! I will wait for catlee reviewing the patch before filing those bugs.
(Reporter)

Comment 19

4 years ago
Comment on attachment 8507199 [details] [diff] [review]
rename_win8_64.diff

Review of attachment 8507199 [details] [diff] [review]:
-----------------------------------------------------------------

lgtm
Attachment #8507199 - Flags: review?(catlee) → review+

Comment 20

4 years ago
Comment on attachment 8507199 [details] [diff] [review]
rename_win8_64.diff

https://hg.mozilla.org/build/buildbot-configs/rev/4aecd2e78d93

I will file the mentioned bugs.
Attachment #8507199 - Flags: checked-in+

Updated

4 years ago
See Also: → bug 1085548

Updated

4 years ago
See Also: → bug 1085549

Updated

4 years ago
See Also: → bug 1084520
(Reporter)

Updated

4 years ago
Duplicate of this bug: 1081799
(Reporter)

Comment 24

4 years ago
Created attachment 8508901 [details] [diff] [review]
switch win8 from 32-bit to 64-bit testing

I love our configs.

So, we can't just remove 'win8' from the lists of slave_platforms for 'win32', since the global PLATFORMS is used in various places. The approach I took was to add 'win8_64' as a slave platform of 'win64', and then to use LOOOOOOOPS to add/remove the correct win8 platforms from various branches according to their version.

I also cleaned up some talos suites that are no longer used.

The result should be that for all trunk-based branches, the old 'WINNT 6.2' builders are replaced with 'Windows 8 64-bit' builders, except for PGO, which we're not running yet. Bug 1086703 for that.

The rest of the patch is fixing up various project branches that were hardcoding platforms, and I assume should be using win64 now as well if they were using win32 previously.
Attachment #8508901 - Flags: review?(jmaher)
Attachment #8508901 - Flags: review?(bhearsum)
Comment on attachment 8508901 [details] [diff] [review]
switch win8 from 32-bit to 64-bit testing

Review of attachment 8508901 [details] [diff] [review]:
-----------------------------------------------------------------

the talos bits looks pretty good.  Glancing over the rest, I don't see anything that jumps out at me as scary.

::: mozilla-tests/config.py
@@ +220,4 @@
>  LINUX64_ONLY = get_talos_slave_platforms(PLATFORMS, platforms=('linux64',))
>  NO_LINUX64 = get_talos_slave_platforms(PLATFORMS, platforms=('linux', 'win32', 'macosx64', 'win64'))
>  
> +def win864_to_win8(platforms):

I don't understand this.
Attachment #8508901 - Flags: review?(jmaher) → review+
(Reporter)

Comment 26

4 years ago
Comment on attachment 8508901 [details] [diff] [review]
switch win8 from 32-bit to 64-bit testing

Review of attachment 8508901 [details] [diff] [review]:
-----------------------------------------------------------------

::: mozilla-tests/config.py
@@ +220,4 @@
>  LINUX64_ONLY = get_talos_slave_platforms(PLATFORMS, platforms=('linux64',))
>  NO_LINUX64 = get_talos_slave_platforms(PLATFORMS, platforms=('linux', 'win32', 'macosx64', 'win64'))
>  
> +def win864_to_win8(platforms):

hmm, looks like this isn't required any more. I'll remove it, and how it's called below.
Comment on attachment 8508901 [details] [diff] [review]
switch win8 from 32-bit to 64-bit testing

Review of attachment 8508901 [details] [diff] [review]:
-----------------------------------------------------------------

Looks fine to me. Thank you for doing cleanup, you're a saint! Give this man more config bugs!!!
Attachment #8508901 - Flags: review?(bhearsum) → review+
(Reporter)

Comment 28

4 years ago
Created attachment 8508952 [details] [diff] [review]
enable win64 builds on trunk
Attachment #8508952 - Flags: review?(bhearsum)
Attachment #8508952 - Flags: review?(bhearsum) → review+

Comment 31

4 years ago
Did we enable pgo for win64?
Is the "win64 (not run by default)" string on TryChooser no longer accurate?
Depends on: 1088371
> Is the "win64 (not run by default)" string on TryChooser no longer accurate?

I filed bug 1088371 about updating TryChooser.
is there anything left here?  We have effectively completed  this.
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Updated

4 years ago
Depends on: 1100543
(Assignee)

Updated

5 months ago
Component: General Automation → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.