[FEATURE] Open Attachment

VERIFIED FIXED in M16

Status

MailNews Core
Backend
P2
major
VERIFIED FIXED
18 years ago
9 years ago

People

(Reporter: scottputterman, Assigned: Scott MacGregor)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+]Exception Feature - ETA 6/19)

(Reporter)

Description

18 years ago
bug tracking feature in Summary.
(Reporter)

Updated

18 years ago
Blocks: 10791
Target Milestone: M9

Updated

18 years ago
OS: Windows NT → All
QA Contact: lchiang → pmock
Hardware: PC → All

Updated

18 years ago
Whiteboard: [PR1]

Comment 1

18 years ago
This needs to be fixed for PR1, so I added a note to the Status Whiteboard.

Comment 2

18 years ago
Triage to M11

Comment 3

18 years ago
We few steps away. Save attachments is pretty much done. I still could not find
who is doing application registration work.

Comment 4

18 years ago
I just landed the save attachments work. We are just a few steps a way. We just
need to locate the right program and then launch the program with the
temporary saved attachment.

Updated

18 years ago
Blocks: 11091

Comment 5

18 years ago
(target milestone is M11 or M12 - add to mail beta tracking bug)

Updated

18 years ago
Whiteboard: [PR1] → [PR1] Waiting for necko's url dispatching and helper app registration work

Comment 6

18 years ago
This needs to wait until the Necko team finishs URL dispatching and helper
application registration stuff.

Updated

18 years ago
Target Milestone: M11 → M12

Comment 7

18 years ago
M12 more likely....

Updated

18 years ago
Target Milestone: M12 → M13

Comment 8

18 years ago
*** Bug 22804 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Target Milestone: M13 → M14

Comment 9

18 years ago
M14 ...

Comment 10

18 years ago
*** Bug 26200 has been marked as a duplicate of this bug. ***

Comment 11

18 years ago
should this be nominated for beta1 per sol's earlier comments?
Keywords: beta1

Comment 12

18 years ago
As long as we have save attachment, I think we can live without open attachment. 
Would love to have this for beta1, but not a stopper. Therefore, I'm removing 
the beta1 keyword (and [PR1] from the Status Whiteboard.
Keywords: beta1
Whiteboard: [PR1] Waiting for necko's url dispatching and helper app registration work → Waiting for necko's url dispatching and helper app registration work

Updated

18 years ago
Target Milestone: M14 → M16

Updated

18 years ago
Whiteboard: Waiting for necko's url dispatching and helper app registration work → ETA ??? - depends on necko mime registration component

Comment 13

18 years ago
Jeff, please add the necko blocking bug to the "depends on" list for this bug.
What is their estimate for when they will unblock you?  Is it making beta 2?

Updated

18 years ago
Depends on: 13784

Comment 14

18 years ago
Syncing priority with marketing.  Moving to P2 to connote "In" for beta2.
Priority: P3 → P2

Comment 15

18 years ago
Partial fix checked in. New openSaveAttachment.xul & openSaveAttachment.js 
added.

Comment 16

18 years ago
More checkins to pass along attachment part and content type when calling
DisplayMessage(). Hand over to mscott for the rest of nsURILoader work.
Assignee: jefft → mscott
Status: ASSIGNED → NEW
Whiteboard: ETA ??? - depends on necko mime registration component

Comment 17

18 years ago
This needs to be on nsbeta2 list.  Marking keyword "nsbeta2" so we can get a 
complete list of items.
Severity: normal → major
Keywords: nsbeta2

Comment 18

18 years ago
Putting on [nsbeta2+] radar for beta2 fix. 
Whiteboard: [nsbeta2+]
(Reporter)

Comment 19

17 years ago
Setting ETA based on what we talked about earlier of 1-1.5 weeks from now.
Whiteboard: [nsbeta2+] → [nsbeta2+] ETA 6/19

Comment 20

17 years ago
Mscott,

With David Matiskella leaving Netscape, I'm concerned about his area, Helper 
Apps.  He had two bugs on Helper Applications and mime registration, reference 
bug 38374 and bug 13784. Do you agree with Scottip that this feature will be 
ready by ETA 6/19?  

/Peter

Comment 21

17 years ago
Adding Exception Feature info.
Whiteboard: [nsbeta2+] ETA 6/19 → [nsbeta2+]Exception Feature - ETA 6/19

Comment 22

17 years ago
M16 has been out for a while now, these bugs target milestones need to be 
updated.
(Assignee)

Comment 23

17 years ago
accepting. I'm starting to tackle this right now. Hopefully I'll have it done by
the morning or tomorrow afternoon.
Status: NEW → ASSIGNED
(Assignee)

Comment 24

17 years ago
This feature has been checked in and is working. You should be able to open
attachments on pop and imap.

There are several caveats:
1) If the content type of the attachment is something the browser can handle, it
shold work on all platforms.

2) if the attachment is something like pdf, it doesn't work because of Bug #43075.
3) On windows, opening attachments with content types that require helper
applications like excel, real audio etc. work
4) on mac we don't use internet config yet to figure out which helper app to
open so it won't work there: Bug #43585.

See the comments in the helper application bug #38374 for more information about
how to expect helper apps and open attachment to work.


Note: Seamonkey doesn't set the content type on attachments correctly if the
content type isn't a basic (.html, .gif, etc) content type. This means when we
try to open it using seamonkey, we won't be able to find the right application
to handle it. This is filed as Bug #43574
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 25

17 years ago
Verified as fixed on Win32, Linux, and Mac using the following builds
 Win32 commercial seamonkey build 2000-062509-m17 installed on PIII Win98
 Linux commercial seamonkey build 2000-062509-m17 installed on PII RedHat 6.1
 MacOS commercial seamonkey build 2000-062508-m17 installed on G3/400 OS 9.04

As per mscott described: 
 - I confirmed that if the content type of the attachment is something the 
browser can handle such as gif, jpeg, png, and html will open a separate browser 
window.  .TXT file will display in the message pane only
 - On windows, I find that trying to open attachments that require helper 
applications such as excel or word documents does NOT work.  
 - On Mac and Linux, I can open open attachments that the browser can handle 
internally (gif, jpeg, etc).

Mscott has filed the appropriate bugs.

Verified as fixed.  Good Work MacDaddy.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.