Tweak the display of Win64 builds & tests to match the TBPL changes

RESOLVED FIXED

Status

P1
normal
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: RyanVM, Assigned: emorley)

Tracking

Details

Attachments

(2 attachments)

49 bytes, text/x-github-pull-request
Details | Review | Splinter Review
54 bytes, text/x-github-pull-request
mdoglio
: review+
Details | Review | Splinter Review
(Reporter)

Description

4 years ago
Once bug 1080249 is fixed for TBPL, we'll need the same changes for Treeherder.
(Assignee)

Updated

4 years ago
Assignee: nobody → emorley
Status: NEW → ASSIGNED

Comment 1

4 years ago
Why can't I vote for this bug?
(Reporter)

Comment 2

4 years ago
What's there to vote on here? This is about changing the UI of our dashboards for monitoring build and test results. It has nothing to do with what builds and tests are being scheduled, though.

Comment 3

4 years ago
I was just confused as I have had the option of clicking "vote" next to the importance field in every other bug that I've ever looked at. This is nice because you get emails with updates without having to comment or add yourself to the cc list.

Why do I care about this particular bug? Because it's blocking 880004, which I'm interested in.

I guess the question is more about Bugzilla itself and maybe I should file a bug, but I thought if someone knew why this bug was special then some time could be saved.
(Reporter)

Comment 4

4 years ago
I believe that voting is enabled on a per-component basis. Sorry, you'll have to live with CCing yourself to this one if you want to follow along.

Comment 5

4 years ago
That makes sense. I'm on it now so no big deal. Thanks for explaining.
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1085548
(Assignee)

Comment 7

4 years ago
TBPL's initial change:
https://hg.mozilla.org/webtools/tbpl/rev/547a7de112ac

diff --git a/js/Config.js b/js/Config.js
...
     "windows8-32": "Windows 8",
+    "windows8-64": "Windows 8 x64",
     "windows2012-64": "Windows 2012 x64",

diff --git a/js/Data.js b/js/Data.js
...
         // Windows x64 builds are created on Win Server 2k8, but for the sake
-        // of consistency, we display them on the same row as the Win2012 tests
-        /WINNT 6\.1 x(?:86-)?64|win64/i.test(name) ? "windows2012-64" :
+        // of consistency, we display them on the same row as the Win8 x64 tests
+        /WINNT 6\.1 x(?:86-)?64|win8_64/i.test(name) ? "windows8-64" :
+        /win64_vm/i.test(name) ? "windows2012-64" :
         /WINNT 6\.1|win7|Windows 7 32-bit/i.test(name) ? "windows7-32" :
         /WINNT 6\.2|win8/i.test(name) ? "windows8-32" :

Plus:
(In reply to Armen Zambrano - Automation & Tools Engineer (:armenzg) from bug 1085548 comment #0)
> From win8_64 to Windows 8 64-bit, could you please update treeherder?
> 
> -PLATFORMS['win64']['win8_64'] = {'name': 'win8_64'}
> +PLATFORMS['win64']['win8_64'] = {'name': 'Windows 8 64-bit'}
(Assignee)

Comment 8

4 years ago
Created attachment 8508722 [details] [review]
UI part
Attachment #8508722 - Flags: review?(cdawson)
(Assignee)

Comment 9

4 years ago
Created attachment 8508725 [details] [review]
Service part



Treeherder equivalent of:
https://hg.mozilla.org/webtools/tbpl/rev/547a7de112ac
plus the followup bug 1085549.

(This is rebased on PR #256 to avoid future conflicts, so please look at the commit diff directly [1] or wait until that PR is merged to master, so the PR is cleaner)

[1] https://github.com/mozilla/treeherder-service/commit/49fd42996de5583475054b715515124f2b6adc4e
Attachment #8508725 - Flags: review?(cdawson)
Attachment #8508725 - Flags: review?(cdawson) → review+
(Assignee)

Updated

4 years ago
Attachment #8508722 - Flags: review?(cdawson)
(Assignee)

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Priority: -- → P1
You need to log in before you can comment on or make changes to this bug.