Revert bug 990214, to re-introduce deletion of webapps during cleanup

RESOLVED FIXED

Status

Firefox OS
Gaia::UI Tests
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: zac, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

46 bytes, text/x-github-pull-request
Bebe
: review+
Martijn Wargers (zombie)
: review+
Details | Review | Splinter Review
Comment hidden (empty)
(Reporter)

Comment 1

4 years ago
Created attachment 8502424 [details] [review]
github pr
Attachment #8502424 - Flags: review?(martijn.martijn)
Attachment #8502424 - Flags: review?(florin.strugariu)
Zac do we have a unit test that checks that the app is deleted? If not can you add one?
Flags: needinfo?(zcampbell)
Comment on attachment 8502424 [details] [review]
github pr

I can confirm this removes the installed apps, thanks.

I guess this could be tested by having one testcase install an app and then the second one check that it isn't there anymore?
Attachment #8502424 - Flags: review?(martijn.martijn) → review+
(Reporter)

Comment 4

4 years ago
(In reply to Florin Strugariu [:Bebe] from comment #2)
> Zac do we have a unit test that checks that the app is deleted? If not can
> you add one?

If I can do it easily I will try to incorporate it into test_cleanup_gaia but it might be messy.
Flags: needinfo?(zcampbell)
(Reporter)

Comment 5

4 years ago
(In reply to Florin Strugariu [:Bebe] from comment #2)
> Zac do we have a unit test that checks that the app is deleted? If not can
> you add one?

I don't think this is a candidate for a unit test because it relies on b2g being restarted and I think that will be a bit too long or a bit heavy for this purpose.

We should however probably have a unit test for apps.uninstall and apps.install.
(Reporter)

Comment 6

4 years ago
Adhoc job here:
http://jenkins1.qa.scl3.mozilla.com/job/flame-kk.ui.adhoc/192/

If it's OK we'll merge on Monday.
(Reporter)

Comment 8

4 years ago
Merged:
https://github.com/mozilla-b2g/gaia/commit/83779ff088c794606c00f98851ada88402cb55dd
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Attachment #8502424 - Flags: review?(florin.strugariu) → review+
You need to log in before you can comment on or make changes to this bug.