Participants not removed on leaving a channel

RESOLVED FIXED in 1.6

Status

Chat Core
IRC
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: aleth, Assigned: aleth)

Tracking

({regression})

trunk
regression

Thunderbird Tracking Flags

(thunderbird34 fixed, thunderbird35 fixed, thunderbird_esr3134+ fixed)

Details

(Whiteboard: [1.6-blocking])

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
Despite the QUIT message being received and apparently handled without error, the participant is not removed from the room. On rejoin, there is obviously a "trying to add chat buddy twice" error.
(Assignee)

Updated

3 years ago
Whiteboard: [1.6-blocking]
(Assignee)

Comment 1

3 years ago
I wonder if this is somehow due to receiving a WATCH 601 before QUIT?
(Assignee)

Comment 2

3 years ago
So the problem here is that ircAccount.userPrefixes (used for normalizing purposes) is fixed but iSUPPORT PREFIX can extend the actual list of userPrefixes (userPrefixToModeMap), leading to mismatches.
(Assignee)

Comment 3

3 years ago
Created attachment 8507392 [details] [diff] [review]
userprefixupdate.diff
Assignee: nobody → aleth
Status: NEW → ASSIGNED
Attachment #8507392 - Flags: review?(clokep)
Comment on attachment 8507392 [details] [diff] [review]
userprefixupdate.diff

Review of attachment 8507392 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for debugging this!
Attachment #8507392 - Flags: review?(clokep) → review+
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/fd014df4dd07

Again, should we backport this to TB 31? Thanks for fixing this!
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 1.6
Here too, I would say yes.
(Assignee)

Comment 7

3 years ago
We'd like to uplift this to TB31 as it badly affects IRC on inspircd servers such as, since recently, moznet. There doesn't seem to be an appropriate flag to set as this bug is not in the TB component, so using needinfo.
Flags: needinfo?(standard8)
(In reply to aleth [:aleth] from comment #7)
> We'd like to uplift this to TB31 as it badly affects IRC on inspircd servers
> such as, since recently, moznet. There doesn't seem to be an appropriate
> flag to set as this bug is not in the TB component, so using needinfo.

See bug 1078223 comment 12
Flags: needinfo?(standard8)
(Assignee)

Comment 9

3 years ago
Comment on attachment 8507392 [details] [diff] [review]
userprefixupdate.diff

[Approval Request Comment]
User impact if declined: incorrect participant list entries, subsequent UI breakage
Testing completed (on c-c, etc.): works well
Risk to taking this patch (and alternatives if risky): none I can think of
Attachment #8507392 - Flags: approval-comm-esr31?
Attachment #8507392 - Flags: approval-comm-beta?
Attachment #8507392 - Flags: approval-comm-aurora?
Attachment #8507392 - Flags: approval-comm-beta?
Attachment #8507392 - Flags: approval-comm-beta+
Attachment #8507392 - Flags: approval-comm-aurora?
Attachment #8507392 - Flags: approval-comm-aurora+
https://hg.mozilla.org/releases/comm-aurora/rev/c286aae15d96
status-thunderbird35: --- → fixed
https://hg.mozilla.org/releases/comm-beta/rev/759077ce09b6
status-thunderbird34: --- → fixed
Attachment #8507392 - Flags: approval-comm-esr31? → approval-comm-esr31+
https://hg.mozilla.org/releases/comm-esr31/rev/107a8daec69b
status-thunderbird_esr31: --- → fixed
tracking-thunderbird_esr31: --- → 34+
You need to log in before you can comment on or make changes to this bug.