Incoming call window stays open forever if the caller closes the window/tab or crashes

VERIFIED FIXED in Firefox 34

Status

defect
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: standard8, Assigned: standard8)

Tracking

unspecified
mozilla36
Points:
1
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox33 unaffected, firefox34+ verified, firefox35+ verified, firefox36 verified)

Details

(Whiteboard: [loop-inccall1])

Attachments

(1 attachment)

Assignee

Description

5 years ago
STR:

1) Set up an incoming call (either url or direct), but do not accept it.
2) Close the tab or the Window on the callee's side

Expected results:

The incoming call window closes

Actual results:

The incoming call window stays open forever.


The incoming call handling needs to handle the "closed" termination state from the server.
Assignee

Updated

5 years ago
OS: Mac OS X → All
Hardware: x86 → All
Assignee

Updated

5 years ago
Duplicate of this bug: 1081377
Assignee

Updated

5 years ago
Summary: Incoming call window stays open forever if the caller closes the window/tab → Incoming call window stays open forever if the caller closes the window/tab or crashes
Assignee

Comment 2

5 years ago
(In reply to Mark Banner (:standard8) from comment #0)
> 1) Set up an incoming call (either url or direct), but do not accept it.

Actually, this doesn't apply to direct calls. I just re-tested and also re-examined the code to confirm.
Assignee

Comment 3

5 years ago
Simple patch to take account of the closed state, that's a new one that we now receive from the server.
Attachment #8503802 - Flags: review?(nperriault)
Comment on attachment 8503802 [details] [diff] [review]
Incoming call window stays open forever if the caller closes the window/tab or crashes.

Review of attachment 8503802 [details] [diff] [review]:
-----------------------------------------------------------------

Makes sense.
Attachment #8503802 - Flags: review?(nperriault) → review+
Assignee

Comment 5

5 years ago
https://hg.mozilla.org/integration/fx-team/rev/10fadf2f8b7d
Assignee: nobody → standard8
Status: NEW → ASSIGNED
Iteration: --- → 35.3
Points: --- → 1
Target Milestone: --- → mozilla35
Assignee

Updated

5 years ago
Duplicate of this bug: 1081966
https://hg.mozilla.org/mozilla-central/rev/10fadf2f8b7d
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8503802 [details] [diff] [review]
Incoming call window stays open forever if the caller closes the window/tab or crashes.

Approval Request Comment
[Feature/regressing bug #]: Handling the other side going away before the call is answered
[User impact if declined]: We won't handle the fact that the other side went away
[Describe test coverage new/current, TBPL]: landing on nightly, has unit tests
[Risks and why]:  Without this change, the client thinks that the other side is still active and so things like ringing would continue even though the other side is no longer there
[String/UUID change made/needed]:No strings
Attachment #8503802 - Flags: approval-mozilla-beta?

Updated

5 years ago
Target Milestone: mozilla35 → mozilla36
I definitely think we should take this on Beta but we shouldn't be skipping Aurora. If I understand this correctly, it looks like this landed in Nightly 36. This should be uplifted to Aurora 35 and tested before requesting uplift to Beta.
Paul, can you please test this in Nightly to confirm it's working as expected?
Flags: needinfo?(paul.silaghi)
QA Contact: anthony.s.hughes → paul.silaghi
Comment on attachment 8503802 [details] [diff] [review]
Incoming call window stays open forever if the caller closes the window/tab or crashes.

Please see Beta request.  We want to take this into fx34 and x35.
Attachment #8503802 - Flags: approval-mozilla-aurora?
backlog: --- → Fx34+
[Tracking Requested - why for this release]:
Tracking for uplift.  See Comment 8.
Verified fixed 36.0a1 (2014-10-17) Win 7, OS X 10.9.5
Status: RESOLVED → VERIFIED
Flags: needinfo?(paul.silaghi)
Comment on attachment 8503802 [details] [diff] [review]
Incoming call window stays open forever if the caller closes the window/tab or crashes.

Approved for Aurora. If everything goes well with testing on Aurora on Sunday, we'll get this uplifted for beta2.
Attachment #8503802 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Tested and good on Aurora nightly build; windows and linux.
Comment on attachment 8503802 [details] [diff] [review]
Incoming call window stays open forever if the caller closes the window/tab or crashes.

Previously approved offline. Adding approval to the bug.
Attachment #8503802 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
Paul, can you please verify this in the latest Aurora and Beta build?
Flags: needinfo?(paul.silaghi)
Flags: in-testsuite?
Verified fixed FF 34b2, 35.0a2 (2014-10-23) Ubuntu 14.04 x64
Flags: needinfo?(paul.silaghi)
Assignee

Comment 21

4 years ago
Clearing in-testsuite requests for features that are being removed from Hello as part of the user journey work in bug 1209713.
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.