Closed Bug 1081130 Opened 5 years ago Closed 5 years ago

Google contacts with phone number but no email are not imported

Categories

(Hello (Loop) :: Client, defect)

defect
Not set
Points:
2

Tracking

(firefox34 verified, firefox35 verified, firefox36 verified)

VERIFIED FIXED
mozilla36
Iteration:
36.1
Tracking Status
firefox34 --- verified
firefox35 --- verified
firefox36 --- verified
Blocking Flags:
backlog Fx34+

People

(Reporter: pauly, Assigned: mikedeboer)

References

Details

Attachments

(1 file)

35.0a1 (2014-10-10)
The following contacts are not imported:
- with only name
- with name, organization but no title job
- with only organization

There may be other cases.
- with only phone number
To be clear, the intended design here is that contacts are imported only if they contain at least one email address and/or at least one phone number. So the situation described in comment 0 is simply the importer working as designed. The issue in comment 1 is a defect that should be fixed.

This is called out in the review in Bug 1069816 comment 8.
Summary: Some google contacts aren't imported → Google contacts with phone number but no email are not imported
Taking this to investigate further.
Assignee: nobody → mdeboer
Status: NEW → ASSIGNED
Points: --- → 2
Flags: qe-verify+
Flags: firefox-backlog+
OS: Windows 7 → All
Hardware: x86_64 → All
(In reply to Paul Silaghi, QA [:pauly] from comment #1)
> - with only phone number
Note that the problem is with a contact having just the phone number without any other details (name etc).
The import button in the Loop panel remains stuck on 'Importing' until the browser is restarted.
Iteration: --- → 35.3
No longer blocks: 1080094
Blocks: 1069816
Comment on attachment 8503219 [details] [diff] [review]
Patch v1: fix importing contacts with only a phone number and fetch the correct format

Review of attachment 8503219 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM
Attachment #8503219 - Flags: review?(adam) → review+
Iteration: 35.3 → 36.1
https://hg.mozilla.org/mozilla-central/rev/87136846a6c8
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
backlog: --- → Fx34+
Pauly, can you verify this when you get a chance?  Thanks!
Flags: needinfo?(paul.silaghi)
Comment on attachment 8503219 [details] [diff] [review]
Patch v1: fix importing contacts with only a phone number and fetch the correct format

Approval Request Comment
[Feature/regressing bug #]: bug 1069816
[User impact if declined]: User will not see their Google contacts imported that have only a phone number listed and no email address. On top of that, the wrong phone number format will be imported, which is not future-compatible for Loop/ Hello mobile interop.
[Describe test coverage new/current, TBPL]: landed on m-c, tests pass and covered.
[Risks and why]: minor.
[String/UUID change made/needed]: n/a.
Attachment #8503219 - Flags: approval-mozilla-beta?
Attachment #8503219 - Flags: approval-mozilla-aurora?
Attachment #8503219 - Flags: approval-mozilla-beta?
Attachment #8503219 - Flags: approval-mozilla-beta+
Attachment #8503219 - Flags: approval-mozilla-aurora?
Attachment #8503219 - Flags: approval-mozilla-aurora+
Pauly -- can you verify this as soon as possible?  This got uplifted before verification -- though I do want this fix in Beta.
Something is still wrong - after import, the button remains stuck on 'importing...'
Browser console log:
"1413548703318	Loop.Importer.Google	ERROR	resource://app/modules/loop/MozLoopAPI.jsm:80: Encountered unsupported value type writing stack-scoped structured clone Log.jsm:749"
Flags: needinfo?(paul.silaghi) → needinfo?(mdeboer)
Depends on: 1084384
I'm marking this bug verified on 36.0a1 (2014-10-17) since the import of a standard phone format works fine.
The work continues in the follow-up bug 1084384.
Status: RESOLVED → VERIFIED
Flags: needinfo?(mdeboer)
Paul, can you please verify this is fixed in the latest Aurora and Beta builds?
Flags: needinfo?(paul.silaghi)
Flags: in-moztrap-
QA Contact: anthony.s.hughes → paul.silaghi
Verified fixed FF 34b2, 35.0a2 (2014-10-23) OS X 10.9.5
Flags: needinfo?(paul.silaghi)
You need to log in before you can comment on or make changes to this bug.