Closed Bug 1081148 Opened 7 years ago Closed 5 years ago

Anisotropic filtering leads to rendering issues

Categories

(Core :: Graphics, defect)

x86_64
All
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: nucrap, Unassigned)

References

(Depends on 4 open bugs)

Details

Attachments

(5 files)

This bugreport aims to wrap up multiple issues all resulting from the same cause.

Enabling anitrosophic filtering (from 4x on) in the graphics driver - no matter if nvidia, amd or intel, leads to blurry rendering in certain situations.

For example CSS triangle rendering is severely affected: At x4 Anisotropic filtering we get a blurry triangle, and at 16x it often ends up being a blurry mess.

I have uploaded multiple attachments illustrating this issue.
Is Internet Explorer affected?
Attached image Blurry arrow on GitHub
Depends on: 804747
Depends on: 549419
Depends on: 646053, 644104, 734748
OS: Windows 7 → All
IE and Chrome are not affected.
Disabling HW accel is a valid workaround too of course.
(In reply to nucrap from comment #5)
> Disabling HW accel is a valid workaround too of course.

To fix only this issue, it's not. HWA is useful for many things and disabling HWA hurts the perf of the browser in many ways.
I wonder how IE avoids being impacted...
(In reply to Loic from comment #7)
> To fix only this issue, it's not. HWA is useful for many things and
> disabling HWA hurts the perf of the browser in many ways.

Yeah sure it is, that's why I called it a *workaround*. Just wanted to point out that this is indeed a behaviour that firefox permits.

> I wonder how IE avoids being impacted...

What about Chrome? I guess it uses HW accel too and isn't affected...
Cannot reproduce this anymore with my AMD r7 260x graohics card, using Radeon Drivers 16.3.2.
Some NVIDIA and Intel users should try to reproduce, too, since these were affected as well.
WFM on NVIDIA, so closing
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Flags: needinfo?(nucrap)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.