"What is this page" link appears on "blank" version of about:newtab

VERIFIED FIXED in Firefox 33

Status

()

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: mbrubeck, Assigned: Mardak)

Tracking

({regression, ux-control, ux-minimalism})

33 Branch
Firefox 36
Points:
2
Dependency tree / graph
Bug Flags:
firefox-backlog +
qe-verify +

Firefox Tracking Flags

(firefox33+ verified, firefox34 verified, firefox35 verified, firefox36 verified)

Details

Attachments

(2 attachments)

Reporter

Description

5 years ago
Bug 1062256 intentionally added a "What is this page" link to the body of the new tab page.

This link does not make sense when the new tab page is set to "blank" mode.  For example, clicking the link says, "When you open a new tab, you'll see tiles...," which is not true when the page is set to blank.

Also, this link adds clutter and distraction and makes the page less "blank" than it was.  Having a distraction-free option has long been a goal of the new tab page design, going back to the first iterations 5 years ago:
https://blog.mozilla.org/labs/2009/03/firefox-new-tab-page-cognitive-shield/

Therefore, the "What is this page?" link should be hidden when the "blank" option is selected.
Assignee

Comment 1

5 years ago
re: status-firefox33, the UI is turned off for all 33 users but we'll turn it on later in 33.

dcrobot, was your intent of moving the link outside of the menu to have "what is this page" visible on "blank" newtab pages?
Flags: needinfo?(athornburgh)
Assignee

Comment 2

5 years ago
Posted patch v1Splinter Review
Attachment #8503258 - Flags: review?(ttaubert)
Comment on attachment 8503258 [details] [diff] [review]
v1

Review of attachment 8503258 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/base/content/newtab/newTab.css
@@ +58,5 @@
>  
> +#newtab-scrollbox[page-disabled] #newtab-intro-what {
> +  opacity: 0;
> +  pointer-events: none;
> +}

I think display:none would be better. I can't exactly remember why the grid uses opacity/pointer-events but I think it had something to do with transitions and moving tiles around.
Attachment #8503258 - Flags: review?(ttaubert) → review+
Assignee

Updated

5 years ago
Blocks: 1050643

Comment 5

5 years ago
Yes, Ed, that is correct. That link should remain present for all 3 views (enhanced, classic, blank).
Flags: needinfo?(athornburgh)
https://hg.mozilla.org/mozilla-central/rev/d3ed7981bd8f
Assignee: nobody → edilee
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 35

Updated

5 years ago
Target Milestone: Firefox 35 → Firefox 36
Reporter

Comment 7

5 years ago
(In reply to Aaron from comment #5)
> Yes, Ed, that is correct. That link should remain present for all 3 views
> (enhanced, classic, blank).

Do you have any comment on the reasons given in comment 0 to hide it when "blank" is selected?  The text really doesn't make any sense for users who have disabled tiles.

Should this be uplifted to beta/aurora?

Comment 8

5 years ago
After thinking about this further, I agree with you Ed. Let's drop "What is this page?" from the Blank New Tab view.
Reporter

Comment 9

5 years ago
[Tracking Requested - why for this release]: Part of the 33.x tiles release.
33.1, tracking!
Assignee

Comment 11

5 years ago
Approval Request Comment
[Feature/regressing bug #]: Bug 1062256
[User impact if declined]: Users expecting a blank experience will see some text
[Describe test coverage new/current, TBPL]: manual QE verification
[Risks and why]: Low - simple css change similar to existing css rules
[String/UUID change made/needed]: None
Attachment #8506428 - Flags: approval-mozilla-release?
Attachment #8506428 - Flags: approval-mozilla-beta?
Attachment #8506428 - Flags: approval-mozilla-aurora?
Assignee

Updated

5 years ago
Flags: qe-verify+
Flags: firefox-backlog+
Attachment #8506428 - Flags: approval-mozilla-release?
Attachment #8506428 - Flags: approval-mozilla-release+
Attachment #8506428 - Flags: approval-mozilla-beta?
Attachment #8506428 - Flags: approval-mozilla-beta+
Attachment #8506428 - Flags: approval-mozilla-aurora?
Attachment #8506428 - Flags: approval-mozilla-aurora+
QA Whiteboard: [good first verify]

Comment 13

5 years ago
I was able to reproduce this bug on Nightly 35.0a1 (2014-10-11), using Windows 7 x64.

Verified fixed on Windows 7 x64, Mac OSX 10.9.5 and Ubuntu 14.04 x86 using Nightly 36.0a1 (2014-10-21), Aurora 35.0a2 (2014-10-21) and Beta 34.0b2 (20141020184313).

This fix can be marked as verified.

[bugday-20141022]
Also verified this on the elder branch, build ID: 20141021103730.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.