Calendar invite links default to Chrome

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
4 years ago
2 years ago

People

(Reporter: wesj, Unassigned, Mentored)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first bug][lang=java])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
I noticed that a calendar invite in my email opened in chrome instead of us. i.e.

https://www.google.com/calendar will prompt for the browser to use
https://www.google.com/calendar/event will open in Chrome regardless of defaults

Do we need to add something to our manifest to compete for these?
Here's some discussion of the link patterns:

http://android.stackexchange.com/questions/30608/why-does-accepting-calendar-invites-open-a-browser-can-i-prevent-it

Should be easy to test -- match those URI patterns in BrowserApp's intent filters.
Mentor: wjohnston, rnewman
OS: Mac OS X → Android
Hardware: x86 → All
Whiteboard: [good first bug][lang=java]
(Reporter)

Comment 2

4 years ago
Ahh. Digging into calendar, it looks like it tries to take the intent. If that fails it calls startNextMatchingActivity [1] which is apparently Chrome. We need to move ourselves higher in the alphabet I bet. I also bet the exact same thing is happening in bug 984301 :)

http://androidxref.com/4.2.2_r1/xref/packages/apps/Calendar/src/com/android/calendar/GoogleCalendarUriIntentFilter.java#242
Hi, could someone please assign this bug to me?? Thanks!!

Updated

4 years ago
Assignee: nobody → panjwaninazma
Status: NEW → ASSIGNED

Comment 4

4 years ago
Hi, it looks like there's been a month since the last activity. Nazma, are you still interested in this bug? If not, would it be possible for me to work on this? Thanks!
Flags: needinfo?(panjwaninazma)
yes sure, go on!!! I have built Fennec and documented everything. If you need my help, let me know!
Flags: needinfo?(panjwaninazma)
Unassigning due to inactivity. I don't know if this is still an issue so first step would be to confirm we still see the behavior from comment 0. Then, once confirmed, fix the issue.
Assignee: panjwaninazma → nobody
Mentor: wjohnston2000 → michael.l.comella
Status: ASSIGNED → NEW

Comment 7

2 years ago
can i be assigned this bug?
Flags: needinfo?(michael.l.comella)
(In reply to amol1994mane from comment #7)
> can i be assigned this bug?

Hi, amol. We'll assign you to this bug once you post a patch – just reply to this message to let us know you'll be working on it so someone else does not take it in the meantime.
Flags: needinfo?(michael.l.comella)

Comment 9

2 years ago
(In reply to Michael Comella (:mcomella) from comment #8)
> (In reply to amol1994mane from comment #7)
> > can i be assigned this bug?
> 
> Hi, amol. We'll assign you to this bug once you post a patch – just reply to
> this message to let us know you'll be working on it so someone else does not
> take it in the meantime.

Sure, would love to work on this too!

Comment 10

2 years ago
I'm having trouble recreating this bug. Am I supposed to put the 2 links in comment 0 in an email, or actually send a calendar event invite through email? In all cases (clicking on the link or accepting an invite), a new tab opens in firefox for me.


Also, assuming the bug is still valid, could I get some pointers on how to solve this? I'm assuming I have to add an intent-filter in AndroidManifest, something like this:

<activity android:name="BrowserApp">
    <intent-filter>
        <action android:name="android.intent.action.VIEW"/>
        <data android:scheme="https" android:host="path/of/calendar/invite" />
    </intent-filter>
</activity>

Am I going in the right direction with this?
Flags: needinfo?(michael.l.comella)

Comment 11

2 years ago
(In reply to amol1994mane from comment #10)
> I'm having trouble recreating this bug. Am I supposed to put the 2 links in
> comment 0 in an email, or actually send a calendar event invite through
> email? In all cases (clicking on the link or accepting an invite), a new tab
> opens in firefox for me.

Never mind, figured out how to recreate it. I was using gmail in firefox previously. Should have used their email app.

Comment 12

2 years ago
Created attachment 8762261 [details] [diff] [review]
Changes to AndroidManifest

Added an intent filter with the links given in the samsung document. Question - when firefox opens the second link, it displays the desktop calendar website. Is there a way to open the mobile version of the calendar website?
Attachment #8762261 - Flags: feedback?(rnewman)
Attachment #8762261 - Flags: feedback?(michael.l.comella)
Comment on attachment 8762261 [details] [diff] [review]
Changes to AndroidManifest

Hey amol.

Sorry for the delay – I'm at a conference of sorts this week.

Clearing NI – will try to look at the feedback today.

Clearing Richard's f? because he doesn't really work in this area anymore.
Flags: needinfo?(michael.l.comella)
Attachment #8762261 - Flags: feedback?(rnewman)
Assignee: nobody → amol1994mane
Unfortunately, my phone died and I can't reproduce this on the emulator; I may get to this later tonight.

If not, do you mind taking a look at this, Sebastian? I'll be PTO next week.
Flags: needinfo?(s.kaspari)
@amol: Can you explain what you did exactly in order to reproduce this issue (and on what device / Android version)? It seems like I'm unable to get chrome to open any of the links from an invitation email (My default is Nightly).

The patch is very specific for the Google Calendar links. In theory this would be required for any app that handles fine granular links if those apps get prioritized over apps handling more generic links like browsers (Is this the case?). With App Linking[1] this connection between apps and URLs is even stronger and there's no way we can prevent that.

Is the idea of the patch to get ranked higher for the call to startNextMatchingActivity()?

Is chrome just chosen because it "randomly" was the next matching activity? Does this call never show a prompt?

It seems like chrome doesn't do anything special in the manifest?
https://cs.chromium.org/chromium/src/chrome/android/java/AndroidManifest.xml

[1] https://developer.android.com/training/app-links/index.html
Flags: needinfo?(s.kaspari) → needinfo?(amol1994mane)
Comment on attachment 8762261 [details] [diff] [review]
Changes to AndroidManifest

Clear f? – waiting for a response to comment 15.
Attachment #8762261 - Flags: feedback?(michael.l.comella)

Comment 17

2 years ago
Hi, I would like to work on this bug. Straight away picking up from where Amol left?
Flags: needinfo?(michael.l.comella)
(Unassigning due to inactivity)

(In reply to Shubham from comment #17)
> Hi, I would like to work on this bug. Straight away picking up from where
> Amol left?

Hey Shubham. Feel free to pick up this bug. I think we're unclear what amol's patch is doing so you can 1) look at the patch, identify what it is intended to do, and make changes as necessary or 2) just start from scratch – your choice!
Assignee: amol1994mane → nobody
Flags: needinfo?(michael.l.comella)
Flags: needinfo?(amol1994mane)

Comment 19

2 years ago
(In reply to Michael Comella (:mcomella) [not actively working on fennec: expect slow responses] from comment #18)
> (Unassigning due to inactivity)
> 
> (In reply to Shubham from comment #17)
> > Hi, I would like to work on this bug. Straight away picking up from where
> > Amol left?
> 
> Hey Shubham. Feel free to pick up this bug. I think we're unclear what
> amol's patch is doing so you can 1) look at the patch, identify what it is
> intended to do, and make changes as necessary or 2) just start from scratch
> – your choice!

I will start by looking at his solution, if things are unclear I will start from scratch. Can I get back here for assistance in case I am stuck given this is my first bug. Thanks.
(In reply to Shubham from comment #19)
> I will start by looking at his solution, if things are unclear I will start
> from scratch. Can I get back here for assistance in case I am stuck given
> this is my first bug. Thanks.

I will do my best to get back to you in a timely manner but just in case, feel free to NI both myself and :sebastian, which should get you a response more quickly.

Thanks for your help!
Mentor: s.kaspari

Comment 21

2 years ago
Hi, I am having trouble reproducing the bug. I am using nexus 6p(Android 7, API 24). Here is the link to the video what I am trying to do: http://bit.ly/2bPVt2v.
Shubham, do you have Chrome installed?

I can reproduce the issue on my Nexus 5 and, on my GS4, I can reproduce but it opens in the stock browser (called "Internet") instead of Chrome.

If you do have Chrome installed and you still can't reproduce, I wonder if this is an issue only when a browser comes pre-installed.

By the way, you can use the "Need more information from" field to give a user a persistent notification so they'll be more likely to see your comments or questions.
Flags: needinfo?(shubham2892)
(In reply to Michael Comella (:mcomella) [not actively working on fennec: expect slow responses] from comment #22)
> If you do have Chrome installed and you still can't reproduce, I wonder if
> this is an issue only when a browser comes pre-installed.

If this is the case and you don't have a device to reproduce, maybe the emulator comes pre-installed with a browser and you can reproduce there.

Comment 24

2 years ago
I have been able to reproduce it on emulator and Android 4.4.4. Working on fixing it.

Comment 25

2 years ago
(In reply to Michael Comella (:mcomella) [not actively working on fennec: expect slow responses] from comment #23)
> (In reply to Michael Comella (:mcomella) [not actively working on fennec:
> expect slow responses] from comment #22)
> > If you do have Chrome installed and you still can't reproduce, I wonder if
> > this is an issue only when a browser comes pre-installed.
> 
> If this is the case and you don't have a device to reproduce, maybe the
> emulator comes pre-installed with a browser and you can reproduce there.

Hi Michael, I am not able to reproduce the bug. I tried on android version 4.3, 4.4, 5.1 and 7 all of them with chrome and mozilla both installed. Can you try "clear default" for your "Internet" browser and try again, else I am missing something majorly. Also, please ignore my previous I thought I was able to reproduce it but it was just opening in default calendar app and not the browser.
Flags: needinfo?(shubham2892) → needinfo?(s.kaspari)
(In reply to Shubham from comment #25)
> Hi Michael, [..]

I guess this needinfo was meant for Michael.
Flags: needinfo?(s.kaspari) → needinfo?(michael.l.comella)
(In reply to Shubham from comment #25)
> Hi Michael, I am not able to reproduce the bug. I tried on android version
> 4.3, 4.4, 5.1 and 7 all of them with chrome and mozilla both installed. Can
> you try "clear default" for your "Internet" browser and try again, else I am
> missing something majorly.

I don't appear to have an defaults set on my browsers, gmail, or my calendars.

It's possible that this is only reproducible on devices with a certain default configuration (e.g. a pre-installed browser). fwiw, the emulators are pretty empty by default (i.e. kind of lacking a default configuration) so I'd easily believe it wouldn't reproduce there.

Unfortunately, if you're unable to reproduce the bug, I'd recommend finding another bug to fix – sorry! You could try to make a speculative fix that I can test for you, but the feedback cycle is so long I'm not sure it's worth it. Let me know if you need help finding additional bugs.
Flags: needinfo?(michael.l.comella)

Comment 28

2 years ago
(In reply to Michael Comella (:mcomella) [not actively working on fennec: expect slow responses] from comment #27)
> (In reply to Shubham from comment #25)
> > Hi Michael, I am not able to reproduce the bug. I tried on android version
> > 4.3, 4.4, 5.1 and 7 all of them with chrome and mozilla both installed. Can
> > you try "clear default" for your "Internet" browser and try again, else I am
> > missing something majorly.
> 
> I don't appear to have an defaults set on my browsers, gmail, or my
> calendars.
> 
> It's possible that this is only reproducible on devices with a certain
> default configuration (e.g. a pre-installed browser). fwiw, the emulators
> are pretty empty by default (i.e. kind of lacking a default configuration)
> so I'd easily believe it wouldn't reproduce there.
> 
> Unfortunately, if you're unable to reproduce the bug, I'd recommend finding
> another bug to fix – sorry! You could try to make a speculative fix that I
> can test for you, but the feedback cycle is so long I'm not sure it's worth
> it. Let me know if you need help finding additional bugs.

Hi Michael,
It would be super helpful if you could help me finding a bug. This was supposed to be my first my bug, but unfortunately I was not able to reproduce it.
Hi Shubham.

I apologize for the long delay in my responses – I've been busy with other work but even so, it's been irresponsible for me to leave it so long. I will do my best in the future to respond more quickly.

(In reply to Shubham from comment #28)
> It would be super helpful if you could help me finding a bug. This was
> supposed to be my first my bug, but unfortunately I was not able to
> reproduce it.

I see you've already commented and started moving on other bugs – thanks for taking initiative! If you still need a bug to fix (or want a good-next-bug after you're done), bug 1155860 seems like a valuable change for users. Perhaps you'd like to take a look at that?

Comment 30

2 years ago
is this bug still relevant?
Sebastian, can you please triage this? Maybe it's not important enough to spend cycles on even if it's still an issue.
Flags: needinfo?(s.kaspari)
Okay, I can finally reproduce this issue. Whenever you get a meeting invite mail that contains a "more details" link then this link will always open in the native app.

I applied the attached patch and now those links open in Firefox. But only in Firefox. They do not open in the Calendar app anymore. And switching from Firefox to the Calendar app by clicking the little android icon in the URL bar doesn't work either. Interestingly even after uninstalling my Firefox build those links do not open in the Calendar app again (just nothing happens) - maybe that's because we use sharedIds for the different builds (I still have other builds installed).

Assuming that a lot of people expect those links to open in the calendar app it seems like this patch will break more than it fixes. For all other use cases you can long press and copy the link (at least in gmail). Therefore I will just close this bug now. In the last two years this bug has been open only new contributors cared about it (mentor bug) - without any actual users complaining about this behavior.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(s.kaspari)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.