If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Camera] The share button in camera preview is difficult to tap

RESOLVED DUPLICATE of bug 1081319

Status

Firefox OS
Gaia::Camera
RESOLVED DUPLICATE of bug 1081319
3 years ago
3 years ago

People

(Reporter: rpribble, Assigned: pdahiya)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.1-exploratory-3])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8503671 [details]
Logcat.txt

Description:
The touch area of the share and ellipses buttons in the camera preview seems to be too low. Tapping the buttons is difficult, and the user must tap lower than expected to try and activate the hit box.
   
Repro Steps:
1) Update a Flame device to BuildID: 20141011000201
2) Enter the camera app
3) Take a picture or video
4) Enter the preview of the picture
5) Try and touch the share button
  
Actual:
The share and ellipses button in the camera preview are difficult to tap.
  
Expected: 
Buttons are easy for the user to tap.
  
Environmental Variables:
Device: Flame 2.1 KK (319 MB)
BuildID: 20141011000201 (full flash)
Gaia: f5d4ff60ffed8961f7d0380ada9d0facfdfd56b1
Gecko: d813d79d3eae
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  
Repro frequency: 100%
See attached: Logcat
(Reporter)

Comment 1

3 years ago
This issue also occurs on v2.2.

Environmental Variables:
Device: Flame 2.2 Master KK (319 MB)
BuildID: 20141011040204 (full flash)
Gaia: 95f580a1522ffd0f09302372b78200dab9b6f322
Gecko: 3f6a51950eb5
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

The share and ellipses button in the camera preview are difficult to tap.
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → affected
Flags: needinfo?(dharris)
Whiteboard: [2.1-Daily-Testing] → [2.1-exploratory-3]
(Reporter)

Comment 2

3 years ago
This bug fails verification of bug 1076158.
Blocks: 1076158
(Assignee)

Comment 3

3 years ago
Taking bug to investigate and fix. This issue is seen in Video and Camera app which has full screen mode.It appears in Video and camera app the area where the status bar icons normally are (top right) is not receiving touch events.

Messaging app doesn't do full screen mode and has status bar on top and not seeing this issue. On flashing messaging app in full screen mode using below steps, I can replicate this issue in messaging app
a) Add   "fullscreen": true to manifest.webapp
b) Flash Flame using make reset-gaia GAIA_DEV_PIXELS_PER_PX=1.5
(Assignee)

Updated

3 years ago
Assignee: nobody → pdahiya
(Assignee)

Comment 4

3 years ago
Created attachment 8504269 [details] [review]
PR with fix of bug 1081562

Hi Alive
Attached PR removes explicit set of pointer-events: auto; on div inside status-bar, this improves responsiveness in options icon in Video and Camera app header on top right. Please review. Thanks
Attachment #8504269 - Flags: review?(alive)
(Assignee)

Comment 5

3 years ago
The proposed fix in attached PR touches code that was added as a fix of bug 1045017. Setting NI flag for yzen to provide input if this change is going to impact screen reader accessibility for status bar icons.
Flags: needinfo?(yzenevich)
Comment on attachment 8504269 [details] [review]
PR with fix of bug 1081562

Delegating review to michael
Attachment #8504269 - Flags: review?(alive) → review?(mhenretty)
Comment on attachment 8504269 [details] [review]
PR with fix of bug 1081562

This will break status bar accessibility. The believe this should be fixed by handling the status bar visibility appropriately: by adding :not(.fullscreen-app) to lines 42 and 47 of the statusbar.css
Attachment #8504269 - Flags: a11y-review-
Flags: needinfo?(yzenevich)
In fact this should be fixed if the PR for bug 1081319 is accepted and merged in.
Depends on: 1081319
(Assignee)

Comment 9

3 years ago
(In reply to Yura Zenevich [:yzen] from comment #8)
> In fact this should be fixed if the PR for bug 1081319 is accepted and
> merged in.

Thanks Yura, I have verified the patch in bug 1081319 improves the responsiveness in top half in options icon for both camera and video app. Cancelling the review for attachment 8504269 [details] [review] in favor of bug1081319 patch for fixing the issue reported in this bug.
(Assignee)

Updated

3 years ago
Attachment #8504269 - Flags: review?(mhenretty)
Marking as a duplicate of bug 1081319 for now. We can reopen this if landing that one does not resolve that issue.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1081319
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
You need to log in before you can comment on or make changes to this bug.