The default bug view has changed. See this FAQ.

Connection to Google calendar failing with a 400 error due to network.http.spdy.enabled.http2draft;True

RESOLVED WORKSFORME

Status

Calendar
Provider: CalDAV
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: Matt, Unassigned)

Tracking

({regression})

Lightning 3.7
x86_64
Windows 7
regression
Dependency tree / graph

Details

(Reporter)

Description

3 years ago
Calendar synchronisation fails with a 400 error

Initial entry in the error console is 
Timestamp: 12/10/2014 11:24:58 AM
Error: NS_ERROR_UNEXPECTED: Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getCharPref]
Source File: resource://gre/components/imIncomingServer.js
Line: 182

Extended error information is
CalDAV: send: <?xml version="1.0" encoding="UTF-8"?>
<D:propfind xmlns:D="DAV:" xmlns:CS="http://calendarserver.org/ns/" xmlns:C="urn:ietf:params:xml:ns:caldav"><D:prop><D:resourcetype/><D:owner/><D:current-user-principal/><D:supported-report-set/><C:supported-calendar-component-set/><CS:getctag/></D:prop></D:propfind>

CalDAV: Status 400 on initial PROPFIND for calendar Google Test

Have substituted a user.js pref of
user_pref("general.useragent.override", "Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.18) Gecko/20110616 Lightning/1.0b2 Thunderbird/3.1.11");

But apparently it is not something funny at the Google end with application and version checking.

Disabling the Preference network.http.spdy.enabled.http2draft results in the Calendars synchronising as Normal and remaining active.
(In reply to Matt from comment #0)

> Have substituted a user.js pref of
> user_pref("general.useragent.override", "Mozilla/5.0 (Windows; U; Windows NT
> 5.1; de; rv:1.9.2.18) Gecko/20110616 Lightning/1.0b2 Thunderbird/3.1.11");
So wait, you are using this version, or you are faking this version for whatever reason?

If this is at least aurora or even beta, the http2draft issue is something in the Mozilla platform. You might have the same experience logging into Google using a Firefox on the same gecko version.

If this is the case, I'd rather duplicate this bug against whatever bug is there to track the issue in the Mozilla platform. Last I heard its a faulty http2 implementation at Google though.
(Reporter)

Comment 2

3 years ago
(In reply to Philipp Kewisch [:Fallen] from comment #1)
> (In reply to Matt from comment #0)
> 
> > Have substituted a user.js pref of
> > user_pref("general.useragent.override", "Mozilla/5.0 (Windows; U; Windows NT
> > 5.1; de; rv:1.9.2.18) Gecko/20110616 Lightning/1.0b2 Thunderbird/3.1.11");
> So wait, you are using this version, or you are faking this version for
> whatever reason?

I faked the version,  simply to test if Google are doing some sort of version checking at their end.  They are not apparently.
> 
> If this is at least aurora or even beta, the http2draft issue is something
> in the Mozilla platform. You might have the same experience logging into
> Google using a Firefox on the same gecko version.

This is 
Daily Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Thunderbird/35.0a1
Nightly Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
Lightning Lightning 3.7a1 20141010030202

The only apparent issue I have had has been with Lightning.

> If this is the case, I'd rather duplicate this bug against whatever bug is
> there to track the issue in the Mozilla platform. Last I heard its a faulty
> http2 implementation at Google though.

The issue might be Googles,  but the support forums are filling fast and Google is not the one they are blaming. The Gdata provider is the usual suspect.  At least I now have something to answer them with.  

Given how little actual HTTP traffic Thunderbird does I really wonder if we would not be better to simply disable the option for the foreseeable future.
Blocks: 1047594
Keywords: regression
this should work now that 1128038 has been identified as the root cause
Depends on: 1128038
(Reporter)

Comment 4

2 years ago
I am happy to close it.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.