key.wav and special.wav does not sound different

VERIFIED FIXED in 2.1 S7 (24Oct)

Status

defect
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: timdream, Assigned: pivanov)

Tracking

({regression})

unspecified
2.1 S7 (24Oct)
x86
macOS
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

special.wav was landed in bug 1061445. It sounds exactly the same with key.wav. I can confirm that too by opening up the files in Audacity.

The strange thing is, they comes with different file size although the codec/channel/wave is complete the same.

Not sure if there is some kind of mix-up.

BTW we need to trim the silence at the beginning and the end, so the user can hear the sound as soon as we play it in the code.

I am not seeing bug 1061445 reach v2.1 but I do see bug 1046336 in v2.1 branch. If this regression is present in v2.1 we need to back it out as well.
Flags: needinfo?(pivanov)
Flags: needinfo?(padamczyk)
I confirm the bug by import the two wave file into an Audacity project as two channels, and invert one of the channel, and hit play.
Posted file Correct Sounds (obsolete) —
That is strange. I attached the correct WAVs to this bug.
Flags: needinfo?(padamczyk)
special.wav sound is the same ... this patch contains only key.wav sound change
Attachment #8505320 - Flags: ui-review?(padamczyk)
Flags: needinfo?(pivanov)
Could you trim the file so we don't have a silence before and after the sound?
Assignee: nobody → pivanov
Status: NEW → ASSIGNED
Flags: needinfo?(pivanov)
Attached at the trimmed sounds.
Attachment #8504730 - Attachment is obsolete: true
Flags: needinfo?(pivanov)
Comment on attachment 8505320 [details]
patch for Gaia/master

Thanks Patryk :)

Hey Tim, it's ready for r?
Attachment #8505320 - Flags: review?(timdream)
Comment on attachment 8505320 [details]
patch for Gaia/master

Assuming you drop the right files.

I am seeing 6 samples (~0.2ms) of silence in the beginning of special.wav from comment 5. Let's ignore it ...
Attachment #8505320 - Flags: review?(timdream) → review+
Thanks :)

Landed to master:
https://github.com/mozilla-b2g/gaia/commit/758427b158ce698bc4c211a9262557dd0dc250dd
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Attachment #8505320 - Flags: ui-review?(padamczyk)
Blocking 2.2+ for all fixed regressions.
blocking-b2g: 2.2? → 2.2+
While attempting to verify bug, the triggers for key and special sound files appear to have been reversed from 2.1 to 2.2

In 2.1 the higher pitched file is key.wav and the lower pitched file is special.opus

In 2.2 the lower pitched file is key.wav and the higher pitched file is special.wav

Was this a deliberate design decision, or is this an unintentional change?

Besides the above the issue is verified fixed, but I don't want to change status until the above question is resolved.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pivanov)
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
not sure ... maybe Patryk can help us?
Flags: needinfo?(pivanov) → needinfo?(padamczyk)
Yes :BroganZ the higher pitched file is correct for regular keys.
Flags: needinfo?(padamczyk)

Comment 13

5 years ago
Verified the issue is fixed on Flame 2.2

key.wav and special.wav are sound differently 
As per the attached file, higher pitched sound is for special.wav and lower pitched sound is for key.wav on 2.2 Flame

BuildID: 20141209040203
Gaia: 9e0b96c7b61c7ff943876ca93e2596d972437b80
Gecko: acf5660d2048
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Target Milestone: --- → 2.1 S7 (24Oct)
You need to log in before you can comment on or make changes to this bug.