Closed Bug 1081714 Opened 8 years ago Closed 8 years ago

[Dialer][Call Screen] Phone number & name disappear from the call screen after making several calls sequentially

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.1+, b2g-v2.1 affected, b2g-v2.2 affected)

RESOLVED DUPLICATE of bug 1078448
blocking-b2g 2.1+
Tracking Status
b2g-v2.1 --- affected
b2g-v2.2 --- affected

People

(Reporter: fmuyumba, Assigned: gerard-majax)

References

()

Details

(Whiteboard: [2.1-exploratory-3][planned-sprint])

Attachments

(4 files)

Attached file logcat.txt
Description:
When a user makes several calls sequentially, the phone number and name disappear and occasionally the call screen turns black

This bug fails verification of bug 1061427
   
Repro Steps:
1) Update a Flame device to BuildID: 20141012001201
2) Tap "Dial" to make the call
3) Make a call and hang up
4) Repeat step 3 several times sequentially
  
Actual:
The phone number and name disappear from the screen
  
Expected: 
The phone number and name do NOT disappear from the screen
  
Environmental Variables:
Device:Flame 2.1 KK (319mb) (Full Flash)
BuildID: 20141012001201
Gaia: d18e130216cd3960cd327179364d9f71e42debda
Gecko: 610ee0e6a776
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  
  
Repro frequency: 100%
See attached: video clip & logcat: http://youtu.be/eg9iyE4D7UI
Flags: needinfo?(dharris)
This issue is reproducible on Flame 2.2 Master KK (319mb) (Full Flash)

Result: When a user makes several calls sequentially, the phone number and name disappear and occasionally the call screen turns black

Environmental Variables:
Device: Flame 2.2 Master  KK (319mb) (Full Flash)
BuildID: 20141012040203
Gaia: 717ad4e8b7fc10ab8248500d00ba5ba0977fa8ab
Gecko: 44168a7af20d
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
QA Whiteboard: [QAnalyst-Triage?]
[Blocking Requested - why for this release]:

Nominating this to block 2.1? because it is blocking the verification of bug 1061427
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
triage: this is a blocker. 
Isn't it duplicate to bug 1061427?
blocking-b2g: 2.1? → 2.1+
Bug 1076597 supposedly solved the race conditions for this, but seems some problems remains.
Depends on: 1076597
(In reply to Wesley Huang [:wesley_huang] from comment #4)
> Bug 1076597 supposedly solved the race conditions for this, but seems some
> problems remains.

"seems" "some" ? That's not really useful. Can you document any status on the repro rate ? Did bug 1076597 improved anything at all ?
Flags: needinfo?(whuang)
Bug 1081714 is still open because we might need changes to the callscreen too.
(In reply to Alexandre LISSY :gerard-majax from comment #5)
> (In reply to Wesley Huang [:wesley_huang] from comment #4)
> > Bug 1076597 supposedly solved the race conditions for this, but seems some
> > problems remains.
> 
> "seems" "some" ? That's not really useful. Can you document any status on
> the repro rate ? Did bug 1076597 improved anything at all ?

My apology for not having clear enough info. That's actually suspect mentioned during the triage meeting.
Maybe Fred can comment on the reproduce rate.
Flags: needinfo?(whuang) → needinfo?(fmuyumba)
Assignee: nobody → gtorodelvalle
Whiteboard: [2.1-exploratory-3] → [2.1-exploratory-3][planned-sprint]
I was able to reproduce it 100% on both Flame 2.2 and Flame 2.1. On 2.2 I was able to reproduce it after 12 redials and after that, the name and number never appeared on subsequent attempts. On 2.1, I was able to reproduce it after 22 redials and after that, the name and number never appeared.


Device: Flame 2.2 Master KK (319mb) (Full Flash)
BuildID: 20141013040202
Gaia: 3b81896f04a02697e615fa5390086bd5ecfed84f
Gecko: f547cf19d104
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
-----------------------------------------------------------------------------------------------------------------

Device: Flame 2.1 KK (319mb) (Full Flash)
BuildID: 20141013001201
Gaia: d18e130216cd3960cd327179364d9f71e42debda
Gecko: 610ee0e6a776
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(fmuyumba) → needinfo?(dharris)
I cannot reproduce after implementing a workaround/fix for bug 1078448.
Depends on: 1078448
Could QA checks that bug 1078448 attachment 8505528 [details] fixes this issue ?
Keywords: qaurgent, qawanted
QA Contact: pcheng
(In reply to Alexandre LISSY :gerard-majax from comment #10)
> Could QA checks that bug 1078448 attachment 8505528 [details] fixes this
> issue ?

I assume you meant bug 1078448 attachment 8505522 [details] [review] ? attachment 8505528 [details] seems to be a memory report.

After applying the patch on top of latest master build, the bug no longer occurs. I placed ~40 calls out and hung up, and each time the phone number/name was displayed correctly. I didn't see the call screen turning black either.

However I noticed that after the patch, the call screen uses low resolution icons, as well as lacking the word 'connecting' when making a call. I've attached screenshots comparing the call screens.
Flags: needinfo?(jmitchell)
Keywords: qaurgent, qawanted
NI to Alexandre to direct attention to comment 11
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(lissyx+mozillians)
QA Contact: pcheng
Thanks! That confirms we are on the good lead. Looking at your screenshots, I see that *all* icons are low res, so I'm not sure if you did not made a mistake :)

The "Connecting" string may be a good catch, though.

May I ask you to try to run much more calls, just to make sure?
Flags: needinfo?(lissyx+mozillians) → needinfo?(jmitchell)
Stealing.
Assignee: gtorodelvalle → lissyx+mozillians
(In reply to Alexandre LISSY :gerard-majax from comment #13)
> Thanks! That confirms we are on the good lead. Looking at your screenshots,
> I see that *all* icons are low res, so I'm not sure if you did not made a
> mistake :)
> 
> The "Connecting" string may be a good catch, though.
> 
> May I ask you to try to run much more calls, just to make sure?

The screenshot on the left shows hi-res icons, and on the right shows low-res icons. It might be a bit hard to differentiate, but on the phone (Flame) the difference is quite noticeable.

I'll try more calls just to make sure. Transferring the NI to myself.
Flags: needinfo?(jmitchell) → needinfo?(pcheng)
Alexandre, I think I know what you mean now, even the wifi & battery icon on status bar seem to be low-res; I just applied the patch again and is now noticing this weird issue. Not sure what went wrong there.
(In reply to Pi Wei Cheng [:piwei] from comment #16)
> Alexandre, I think I know what you mean now, even the wifi & battery icon on
> status bar seem to be low-res; I just applied the patch again and is now
> noticing this weird issue. Not sure what went wrong there.

Do you still have the missing "Connecting" issue ?
(In reply to Alexandre LISSY :gerard-majax from comment #17)
> Do you still have the missing "Connecting" issue ?

I do still have the missing 'connecting' issue.

I tested 200 calls without issue reproducing. Around half way into the test I experienced an LMK - Phone app force-closed and brought me to homescreen, but this issue was present before the patch so I don't think there's anything we can do here with 319MB mem.

Let me know if you still need anything else tested.
Flags: needinfo?(pcheng)
Attaching the console outputs from doing the patchwork. I don't know what went wrong with those low-res icons so I'm attaching what I did here.
(In reply to Pi Wei Cheng [:piwei] from comment #19)
> Created attachment 8505724 [details]
> console outputs from patchwork
> 
> Attaching the console outputs from doing the patchwork. I don't know what
> went wrong with those low-res icons so I'm attaching what I did here.

No wonder you had wrong icons: |flash@FlashStation65:~/patch/gaia$ make reset-gaia|.

Doing this, you did reset gaia but missed to specify the proper device pixels css ratio.

You should have done: |flash@FlashStation65:~/patch/gaia$ make GAIA_DEV_PIXELS_PER_PX=1.5 reset-gaia|.
Flags: needinfo?(pcheng)
I'm not able to see any missing "Connecting" string :(
Depends on: 1083729
(In reply to Alexandre LISSY :gerard-majax from comment #10)
> Could QA checks that bug 1078448 attachment 8505528 [details] fixes this
> issue ?

Before applying the patch, I ran 3 times the test in attachment 8504694 [details]. On each try, the test fails at the 24th call.
After applying it, I am able to go to beyond 66 call (68 on the first and second try, 66 on the third). In that case, the test failed because of an OOM on a 319MB device.

Note that the issue only occured on a french Orange SIM card, but not on a SIM from Free carrier. :gerard-majax said that it might be that Orange SIM cards have SIM Application Toolkit, but Free's don't.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1074379
(In reply to Alexandre LISSY :gerard-majax from comment #20)
> No wonder you had wrong icons: |flash@FlashStation65:~/patch/gaia$ make
> reset-gaia|.
> 
> Doing this, you did reset gaia but missed to specify the proper device
> pixels css ratio.
> 
> You should have done: |flash@FlashStation65:~/patch/gaia$ make
> GAIA_DEV_PIXELS_PER_PX=1.5 reset-gaia|.

Thanks for pointing that out. Our patchwork documentation doesn't specify this. I'll make sure to add this information to our documentation.

After applying the patch I see hi res icons now :)

However I'm still missing the 'connecting' when making a call. Since this bug has been closed I'm not sure if anyone still pays attention here but I'm attaching the logcat when making a phone call anyway. I use AT&T SIM, not sure if that makes a difference.
Flags: needinfo?(pcheng)
Flags: needinfo?(dharris)
(In reply to Pi Wei Cheng [:piwei] from comment #24)
> However I'm still missing the 'connecting' when making a call.

I don't know what wrong with that build but from my side, I keep seeing the "Connecting" string before applying the patches and after. Thus, even after 20 calls placed (or 50 after the patch).
No longer depends on: 1078448
See Also: → 1078448
You need to log in before you can comment on or make changes to this bug.