If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Remove tools/httptester/, which is ancient and unused

RESOLVED FIXED in mozilla36

Status

()

Core
General
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: njn, Assigned: njn)

Tracking

unspecified
mozilla36
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
tools/httptester/ is a "(scriptable) framework for regression-testing mozilla
stuff." It appears to be entirely unused. It was added in August 2001
(https://github.com/mozilla/gecko-dev/commit/b3886c70ba34c6583bf3d96f545f832063493d75),
there is no bug associated with it, and it has received only trivial changes
since then (e.g. blanket spelling mistake fixes). We have a lot more tests
these days than we had back then.
(Assignee)

Updated

3 years ago
Blocks: 1080290
(Assignee)

Comment 1

3 years ago
Created attachment 8503858 [details] [diff] [review]
Remove tools/httptester/, which is ancient and unused

Ted, I couldn't find anyone associated with this code who still works on the
project. So as someone who has been a Mozillian for a long time and knows a lot
about testing stuff, I'm giving the review to you. Thanks.

 36 files changed, 745 deletions(-)
Attachment #8503858 - Flags: review?(ted)
(Assignee)

Comment 2

3 years ago
ted: 9 day review ping.
Attachment #8503858 - Flags: review?(ted) → review+
(Assignee)

Comment 3

3 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/a7642da794ba
https://hg.mozilla.org/mozilla-central/rev/a7642da794ba
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
You need to log in before you can comment on or make changes to this bug.