Closed Bug 1082002 Opened 5 years ago Closed 5 years ago

[10.10] White border on URL bar for popup window

Categories

(Firefox :: Theme, defect)

x86
macOS
defect
Not set
Points:
2

Tracking

()

RESOLVED FIXED
Firefox 36
Iteration:
36.1
Tracking Status
firefox33 --- wontfix
firefox34 --- fixed
firefox35 --- fixed
firefox36 --- fixed

People

(Reporter: Dolske, Assigned: Gijs)

References

(Blocks 1 open bug)

Details

Attachments

(3 files, 1 obsolete file)

Attached image Screenshot
Not sure if this is a bug or feature!

On 10.10, popup windows (eg for Persona logins) have a white border around the URL bar. It's not present on normal windows.
This needs some CSS love; stuck this on the backlog generation.
Points: --- → 2
Flags: qe-verify-
Flags: in-testsuite-
Flags: firefox-backlog+
Changing the border-color to transparent in [0] should work. But I can't really confirm the fix (or find regressions) as I don't have an OSX machine.

[0] http://mxr.mozilla.org/mozilla-central/source/browser/themes/osx/browser.css#1950
(In reply to Tim Nguyen [:ntim] from comment #3)
> Changing the border-color to transparent in [0] should work. But I can't
> really confirm the fix (or find regressions) as I don't have an OSX machine.
> 
> [0]
> http://mxr.mozilla.org/mozilla-central/source/browser/themes/osx/browser.
> css#1950

The border was deliberately made white in order to match yosemite's own native theme. We should specialcase the disabled/readonly state that it has in popups; we can't just change [0].
(In reply to :Gijs Kruitbosch from comment #4)
> (In reply to Tim Nguyen [:ntim] from comment #3)
> > Changing the border-color to transparent in [0] should work. But I can't
> > really confirm the fix (or find regressions) as I don't have an OSX machine.
> > 
> > [0]
> > http://mxr.mozilla.org/mozilla-central/source/browser/themes/osx/browser.
> > css#1950
> 
> The border was deliberately made white in order to match yosemite's own
> native theme. We should specialcase the disabled/readonly state that it has
> in popups; we can't just change [0].

I think border-color: transparent automatically fits the background-color : http://jsfiddle.net/bh98w8La/1/
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Iteration: --- → 36.1
(In reply to Tim Nguyen [:ntim] from comment #5)
> (In reply to :Gijs Kruitbosch from comment #4)
> > (In reply to Tim Nguyen [:ntim] from comment #3)
> > > Changing the border-color to transparent in [0] should work. But I can't
> > > really confirm the fix (or find regressions) as I don't have an OSX machine.
> > > 
> > > [0]
> > > http://mxr.mozilla.org/mozilla-central/source/browser/themes/osx/browser.
> > > css#1950
> > 
> > The border was deliberately made white in order to match yosemite's own
> > native theme. We should specialcase the disabled/readonly state that it has
> > in popups; we can't just change [0].
> 
> I think border-color: transparent automatically fits the background-color :
> http://jsfiddle.net/bh98w8La/1/

Sure, but that doesn't look right. :-)
Attached patch fix urlbar to stay white, (obsolete) — Splinter Review
Toolkit overrides readonly inputs to have a -moz-dialog background. This just overrides that in keeping with our pre-10.10 styles for readonly urlbar (which basically looks exactly the same on OS X as the non-read-only one). I've not updated the text color because that 'just works', and OS X isn't as themable as Windows. Let me know if you think I should change that.
Attachment #8508374 - Flags: review?(dao)
Comment on attachment 8508374 [details] [diff] [review]
fix urlbar to stay white,

I don't understand why this is specific to 10.10.
Attachment #8508374 - Flags: review?(dao)
Comment on attachment 8508374 [details] [diff] [review]
fix urlbar to stay white,

Review of attachment 8508374 [details] [diff] [review]:
-----------------------------------------------------------------

Because we set background-image: none; on pre-10.10, the background image is a linear gradient which fully covers the original textbox background color.
Attachment #8508374 - Flags: review?(dao)
Comment on attachment 8508374 [details] [diff] [review]
fix urlbar to stay white,

(In reply to :Gijs Kruitbosch from comment #9)
> on pre-10.10, the background image is
> a linear gradient which fully covers the original textbox background color.

That's dependent on -moz-mac-lion-theme. We should just set the background color unconditionally.

Also, #fff should be -moz-field instead.

If you use #urlbar[readonly], this becomes self-documenting and you can omit the comment.
Attachment #8508374 - Flags: review?(dao) → review-
Attachment #8508611 - Flags: review?(dao)
Attachment #8508374 - Attachment is obsolete: true
Attachment #8508611 - Flags: review?(dao) → review+
Comment on attachment 8508611 [details] [diff] [review]
fix urlbar to stay white,

Approval Request Comment
[Feature/regressing bug #]: yosemite
[User impact if declined]: silly looking url bar in popups on yosemite (and also 10.6, I imagine)
[Describe test coverage new/current, TBPL]: nope
[Risks and why]: pretty much 0, small targeted CSS fix
[String/UUID change made/needed]: nope

remote:   https://hg.mozilla.org/integration/fx-team/rev/c51c71d1a378
Attachment #8508611 - Flags: approval-mozilla-beta?
Attachment #8508611 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/c51c71d1a378
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 36
Comment on attachment 8508611 [details] [diff] [review]
fix urlbar to stay white,

Beta+
Aurora+
Attachment #8508611 - Flags: approval-mozilla-beta?
Attachment #8508611 - Flags: approval-mozilla-beta+
Attachment #8508611 - Flags: approval-mozilla-aurora?
Attachment #8508611 - Flags: approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.