Middle mouse button does not work

RESOLVED DUPLICATE of bug 106215

Status

()

--
major
RESOLVED DUPLICATE of bug 106215
17 years ago
17 years ago

People

(Reporter: thomas+mozilla, Assigned: hyatt)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.5+)
Gecko/20011026
BuildID:    2001102605

It would appear that my middle mouse button does not work to open new links. The
middle button works in other applications, such as XFree86 (XonX). My mouse is
does go through a PS/2->USB adapter, but this shouldn't matter at all.

I'd like to be able to open a new tab with the middle button.

Reproducible: Always
Steps to Reproduce:
1. Plug in 3 button mouse
2. Click Link



Actual Results:  absolutely nothing.

Expected Results:  should have opened the link in a new window, or in my
configuration, a new tab.
You likely need to set 

user_pref("middlemouse.openNewWindow", true);

That preference defaults to true on Unix and false on MacOS, with OSX being
treated as MacOS.  Please set that pref and comment in this bug on the results.
Summary: Middle mouse button does not work → Middle mouse button does not work
(Reporter)

Comment 2

17 years ago
I added user_pref("middlemouse.openNewWindow", true); to my prefs.js, and it
didn't work. Just to avoid any confusion with custom settings, I decided to nuke
my ~/Library/Mozilla, and get a nice clean profile.

What's interesting, is that a clean Mozilla still will open new links with
Command-Click (the universal MacOS way to emulate middle button I guess -- it
works in my xterm). Even when I added the middlemouse option to my fresh Mozilla
profile, middle clicking did not work.

Hope this is of some help.
Thomas, thanks for checking that. Looks like an issue with mouse events on OSX...

*** This bug has been marked as a duplicate of 106215 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.