Reject pymake in client.mk

RESOLVED FIXED in Firefox 34

Status

--
major
RESOLVED FIXED
4 years ago
6 months ago

People

(Reporter: angeljanai, Assigned: glandium)

Tracking

33 Branch
mozilla36
x86_64
Windows 7

Firefox Tracking Flags

(firefox34 fixed, firefox35 fixed, firefox36 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8504480 [details]
mozconfig

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140925174249

Steps to reproduce:

download latest stable firefox 33.0 source code.
extract to c:\downloads
\mozilla-build\start-shell-msvc2012-x64.bat
cd /c/downloads/mozilla-release
python ./build/pymake/make.py -f client.mk build


Actual results:

$ python ./build/pymake/make.py -f client.mk build
make.py[0]: Entering directory 'c:\downloads\mozilla-release'
c:\downloads\mozilla-release\config\makefiles\autotargets.mk:59:0$ pymake.builti
ns mkdir -p 'c:/downloads/mozilla-release/obj-x86_64-pc-mingw32/'
c:\downloads\mozilla-release\client.mk:328:0$ python2.7 c:/downloads/mozilla-rel
ease/config/pythonpath.py -I c:/downloads/mozilla-release/testing/mozbase/mozfil
e \
    c:/downloads/mozilla-release/python/mozbuild/mozbuild/controller/clobber.py
c:/downloads/mozilla-release c:/downloads/mozilla-release/obj-x86_64-pc-mingw32
[Error 2] 指定されたファイルが見つかりません。 <-- means File not found
c:\downloads\mozilla-release\client.mk:328:0: command 'python2.7 c:/downloads/mo
zilla-release/config/pythonpath.py -I c:/downloads/mozilla-release/testing/mozba
se/mozfile \
    c:/downloads/mozilla-release/python/mozbuild/mozbuild/controller/clobber.py
c:/downloads/mozilla-release c:/downloads/mozilla-release/obj-x86_64-pc-mingw32'
 failed, return code -127
Error remaking makefiles (ignored)
No rule to remake missing include file c:/downloads/mozilla-release/obj-x86_64-p
c-mingw32/.mozconfig.mk


Expected results:

firefox builds without errors as it did with older versions(tested on 32.0.3 and no error in the same environment with the same mozconfig).
(Reporter)

Updated

4 years ago
Severity: normal → major
Component: Untriaged → Build Config
Hardware: x86 → x86_64
Version: 32 Branch → 33 Branch
(Assignee)

Comment 1

4 years ago
(In reply to Dmitry Stepanushkin from comment #0)
> Created attachment 8504480 [details]
> mozconfig
> 
> User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:32.0) Gecko/20100101
> Firefox/32.0
> Build ID: 20140925174249
> 
> Steps to reproduce:
> 
> download latest stable firefox 33.0 source code.
> extract to c:\downloads
> \mozilla-build\start-shell-msvc2012-x64.bat
> cd /c/downloads/mozilla-release
> python ./build/pymake/make.py -f client.mk build
> 
> 
> Actual results:
> 
> $ python ./build/pymake/make.py -f client.mk build
> make.py[0]: Entering directory 'c:\downloads\mozilla-release'
> c:\downloads\mozilla-release\config\makefiles\autotargets.mk:59:0$
> pymake.builti
> ns mkdir -p 'c:/downloads/mozilla-release/obj-x86_64-pc-mingw32/'
> c:\downloads\mozilla-release\client.mk:328:0$ python2.7
> c:/downloads/mozilla-rel
> ease/config/pythonpath.py -I
> c:/downloads/mozilla-release/testing/mozbase/mozfil
> e \
>    
> c:/downloads/mozilla-release/python/mozbuild/mozbuild/controller/clobber.py
> c:/downloads/mozilla-release
> c:/downloads/mozilla-release/obj-x86_64-pc-mingw32
> [Error 2] 指定されたファイルが見つかりません。 <-- means File not found
> c:\downloads\mozilla-release\client.mk:328:0: command 'python2.7
> c:/downloads/mo
> zilla-release/config/pythonpath.py -I
> c:/downloads/mozilla-release/testing/mozba
> se/mozfile \
>    
> c:/downloads/mozilla-release/python/mozbuild/mozbuild/controller/clobber.py
> c:/downloads/mozilla-release
> c:/downloads/mozilla-release/obj-x86_64-pc-mingw32'
>  failed, return code -127
> Error remaking makefiles (ignored)

This is a red herring

> No rule to remake missing include file
> c:/downloads/mozilla-release/obj-x86_64-p
> c-mingw32/.mozconfig.mk

This is the actual error. Looking at http://hg.mozilla.org/releases/mozilla-release/file/a223fd497cdf/client.mk all I can say is that it's very possible it's a pymake bug. Don't use pymake. It hasn't been the recommended tool to build Firefox for a while, and in fact, is actually rejected since bug 1027890, which, guess what, landed in Firefox 33. We unfortunately forgot to make client.mk reject it.

Please don't use pymake, use mozmake instead (or use mach, which will use mozmake)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Firefox 33.0 pymake build fails → Reject pymake in client.mk
(Assignee)

Comment 2

4 years ago
Created attachment 8504503 [details] [diff] [review]
Reject pymake in client.mk
Attachment #8504503 - Flags: review?(mshal)
(Assignee)

Updated

4 years ago
Assignee: nobody → mh+mozilla
Status: NEW → ASSIGNED
(Reporter)

Comment 3

4 years ago
Ah, I see.
will use mozmake, it worked fine indeed.
good bye pymake, and wontfix is ok for me.
Thanks!
Comment on attachment 8504503 [details] [diff] [review]
Reject pymake in client.mk

Unfortunately it runs configure before telling you not to use pymake, but meh :)
Attachment #8504503 - Flags: review?(mshal) → review+
Component: Build Config → Build Config
Product: Firefox → Core
(Assignee)

Comment 5

4 years ago
(In reply to Michael Shal [:mshal] from comment #4)
> Comment on attachment 8504503 [details] [diff] [review]
> Reject pymake in client.mk
> 
> Unfortunately it runs configure before telling you not to use pymake, but
> meh :)

O_o it doesn't, here (and I wouldn't expect it to). What did you try?
(Assignee)

Comment 7

4 years ago
(In reply to Mike Hommey [:glandium] from comment #6)
> https://hg.mozilla.org/integration/mozilla-inbound/rev/b30422149e3e

Note the version I landed moved the include closer to setting HOST_OS_ARCH.
(Assignee)

Comment 8

4 years ago
... which, of course, was a terrible idea.

Backed out
https://hg.mozilla.org/integration/mozilla-inbound/rev/26273b92b2d7

And landed the original patch:
https://hg.mozilla.org/integration/mozilla-inbound/rev/72b3317ead18
(In reply to Mike Hommey [:glandium] from comment #5)
> (In reply to Michael Shal [:mshal] from comment #4)
> > Comment on attachment 8504503 [details] [diff] [review]
> > Reject pymake in client.mk
> > 
> > Unfortunately it runs configure before telling you not to use pymake, but
> > meh :)
> 
> O_o it doesn't, here (and I wouldn't expect it to). What did you try?

Oh, nevermind - it works fine in Windows. On Linux it runs configure first and then dies from the check in Makefile.in. I didn't examine closely enough :/
https://hg.mozilla.org/mozilla-central/rev/72b3317ead18
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
(Assignee)

Comment 11

4 years ago
Comment on attachment 8504503 [details] [diff] [review]
Reject pymake in client.mk

Approval Request Comment
[Feature/regressing bug #]: non-obvious problem arising after bug 1027890
[User impact if declined]: people building firefox on windows using the good old pymake may see errors before seeing the explicit mention that pymake is not supported anymore.
[Describe test coverage new/current, TBPL]: Tested locally with pymake. Landed on m-c a few days ago.
[Risks and why]: Low. If it were to cause problems, it would have caused problems already on m-c, because the file touched in this patch is the very first makefile that is invoked during the build
[String/UUID change made/needed]: None
Attachment #8504503 - Flags: approval-mozilla-beta?
Attachment #8504503 - Flags: approval-mozilla-aurora?
status-firefox34: --- → affected
status-firefox35: --- → affected
status-firefox36: --- → fixed
Attachment #8504503 - Flags: approval-mozilla-beta?
Attachment #8504503 - Flags: approval-mozilla-beta+
Attachment #8504503 - Flags: approval-mozilla-aurora?
Attachment #8504503 - Flags: approval-mozilla-aurora+

Updated

6 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.