Closed Bug 1082879 Opened 8 years ago Closed 8 years ago

TypeError: settings is null at: app://system.gaiamobile.org/shared/js/dump.js line: 24

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.1+, b2g-v2.1 fixed, b2g-v2.2 fixed)

RESOLVED FIXED
2.1 S8 (7Nov)
blocking-b2g 2.1+
Tracking Status
b2g-v2.1 --- fixed
b2g-v2.2 --- fixed

People

(Reporter: anshulj, Assigned: kgrandon)

References

Details

(Whiteboard: [caf priority: p2][CR 741216][systemsfe][eta=14/11])

Attachments

(1 file)

105.05 KB, text/plain
Details
[Blocking Requested - why for this release]: This exception is preventing us to run our unit test to ensure the quality of this release.

I am seeing the following exception while running marionette test cases related to voice calls, which is causing the test to fail. 

JavascriptException: TypeError: settings is null at: app://system.gaiamobile.org/shared/js/dump.js line: 24
Can we have a full logcat here?
2.1 CC blocker = 2.1+.
blocking-b2g: 2.1? → 2.1+
(In reply to Gregor Wagner [:gwagner] from comment #1)
> Can we have a full logcat here?

Ni Anshul for request in comment #1
Flags: needinfo?(anshulj)
Attached file android logs
Flags: needinfo?(anshulj)
Whiteboard: [CR 741216]
Whiteboard: [CR 741216] → [caf priority: p2][CR 741216]
Anshul - it looks like something is overwriting navigator or something on it. Very strange, I've never seen something like this. You can also see so from the below lines in logcat.

This sounds like an issue with your test, but in order to verify it, we would need to see it. Is there any way you can provide your test here or in private?


10-16 15:02:06.413 E/GeckoConsole(  223): [JavaScript Error: "TypeError: window.navigator.mozSettings is null" {file: "app://system.gaiamobile.org/shared/js/date_time_helper.js" line: 33}]

10-16 15:02:06.443 E/GeckoConsole(  223): [JavaScript Error: "TypeError: document.registerElement is not a function" {file: "app://system.gaiamobile.org/shared/elements/gaia_buttons/script.js" line: 17}]

navigator.getDataStores is not a function" {file: "app://system.gaiamobile.org/js/places.js" line: 71}]
10-16 15:02:08.693 E/GeckoConsole(  223): [JavaScript Error: "TypeError: settings is null" {file: "app://system.gaiamobile.org/shared/js/settings_listener.js" line: 28}]
Flags: needinfo?(anshulj)
Kevin, I send you an email with the the test script.
Flags: needinfo?(anshulj)
Assigning to you Kgrandon since you are investigating this :)...thanks!!!
Assignee: nobody → kgrandon
Whiteboard: [caf priority: p2][CR 741216] → [caf priority: p2][CR 741216][systemsfe]
This seems like it could be a problem with the test profile or test environment. It looks like we are successfully trying to load the callscreen app, with an origin of callscreen.gaiamobile.org, but failing to do so and instead loading the system app without any permissions.

Anshul - would you be able to provide the full profile that you are running the test with? Is this profile able to make a phone call on an emulator/device normally?
Flags: needinfo?(anshulj)
(In reply to Kevin Grandon :kgrandon from comment #8)
> This seems like it could be a problem with the test profile or test
> environment. It looks like we are successfully trying to load the callscreen
> app, with an origin of callscreen.gaiamobile.org, but failing to do so and
> instead loading the system app without any permissions.
> 
> Anshul - would you be able to provide the full profile that you are running
> the test with? Is this profile able to make a phone call on an
> emulator/device normally?
Kevin, with this script I am able to make a call manually. However I do see that every now and then when there is an incoming call, the callscreen doesn't show up at all. Following is the command I am using to run the test, not sure if that is what you mean by full profile.

python2.7 -c "from marionette import runtests; runtests.cli()" --address localhost:$MARIONETTE_PORTpython2.7 -c "from marionette import runtests; runtests.cli()" --address localhost:$MARIONETTE_PORT <test_script>
Flags: needinfo?(anshulj)
Hey Kevin,

Hoping comment #9 here was helpful and we are making progress here, else please shout out, if you need more info given the timeline to fix the CAF bugs :) Thanks!
Flags: needinfo?(kgrandon)
No update here yet, I'm unable to reproduce. Anshul - do you think you could get us a screenshot after this happens? It may help us figure out next steps to debug this. Thanks!
Flags: needinfo?(kgrandon) → needinfo?(anshulj)
Kevin, there isn't anything unusual visible on the UI for me to share with you when this error happens. Could you provide a patch that does some null checking in the code to prevent the crash since we may not be able to find the root cause of the issue?
Flags: needinfo?(anshulj)
It seems like almost every navigator property is undefined in the log. I don't think it's feasible to add null checking in this case unfortunately. We'll need to find the root cause here.
Target Milestone: --- → 2.1 S8 (7Nov)
Fabrice, Boris - Apparently it's possible to get into a state where it's missing navigator properties. Can you guys think of anything that may cause this, and if not - is there any logging we can add to the platform to help debug this?
Flags: needinfo?(fabrice)
Flags: needinfo?(bzbarsky)
Which properties are missing?  Is it the ones that are only exposed to apps that have the right permissions?  I kinda doubt that navigator.appName/appVersion/userAgent/product/language/languages/registerProtocolHandler/mimeTypes/doNotTrack/etc are missing, right?
Flags: needinfo?(bzbarsky)
Anshul - to answer comment 15, are you able to interact with the frame with marionette or the app manager to see what app properties are present? 

For example, is navigator.userAgent present, but navigator.mozSettings is not?
Flags: needinfo?(anshulj)
Adding an ETA as requested - though I don't think I will be the person that ends up fixing this.
Whiteboard: [caf priority: p2][CR 741216][systemsfe] → [caf priority: p2][CR 741216][systemsfe][eta=14/11]
Anshul, we landed some workaround related to placing several calls in bug 1083729. This landed after you filed the bug. Would there be any chance this is related to this issue ?

Do you mind giving a try to a more recent bug that includes bug 1083729, which should now be on both master and v2.1 ?
Anshul - I'm currently unable to reproduce this, and based on comment 18, it seems that there's a high probability that bug 1083729 fixed this. If you are still seeing this please reopen with the info requested in comment 16. Thanks!
Status: NEW → RESOLVED
Closed: 8 years ago
Depends on: 1083729
Flags: needinfo?(fabrice)
Resolution: --- → FIXED
Sounds good. I am seeing this issue less often now as the bunch of other exceptions I was seeing are now resolved.
Flags: needinfo?(anshulj)
Unable to verify. back-end issue
QA Whiteboard: [QAnalyst-Triage?][QAnalyst-verify-]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][QAnalyst-verify-] → [QAnalyst-Triage+][QAnalyst-verify-]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.